Версия для печати темы
Нажмите сюда для просмотра этой темы в оригинальном формате
Форум программистов > Delphi: WinAPI и системное программирование > Error 1783


Автор: Штабс 27.1.2005, 11:53
Hi Pipl
проблема такова
стоял Server 2kb
поставили 2003
серверный софт при простом переносе заглючил

так вот
вычленили несколько мест ошибок

одна из них

ReadEventLog на ней софтина и валится Error 1783
кто нибудь встречался с этим?
как бороться?

О ! кстаит! на 2kb и ХР все ОК


Автор: Snowy 27.1.2005, 12:08
Вопрос не в тот форум. Здесь программирование, а не администрирование.

Автор: Штабс 27.1.2005, 12:25
А об админстве никто и не спрашивает. Еще раз: кто рабюотал с функцией ReadEventLog под 2003? Если сталкивались с ошибкой заглушки DCOM при вызове этой ф-ции, подскажите как бороться. Под 2000 и ХР такой ошибки нет, все равботает.

Автор: Штабс 27.1.2005, 13:19
Просто хочу еще раз подчеркнуть
Если кто работал с функцией ReadEventLog под 2003? Если сталкивались с ошибкой заглушки DCOM при вызове этой ф-ции, подскажите как бороться. Под 2000 и ХР такой ошибки нет, все равботает

Автор: Snowy 27.1.2005, 14:36
Вероятно проблема с правами. Попробуй запустить под пользователем у которого точно есть права на чтение журнала или проверить, что у того пользователя права на это есть.
В 2003 дефолтовые права ограничены намного сильнее, чем в 2000.

Автор: Штабс 27.1.2005, 15:09
Под этим же юзером работает другое приложение (разработанное не нами), которое успешно обрабатывает этиже логи для каких-то своих целей.

Автор: Snowy 27.1.2005, 15:23
Проверь права. Может они ограничены. В 2003-х ограничений по умолчанию гораздо больше.
Попробуй запустить от имени пользователя, который наверняка имеет права на просмотр журнала.

Автор: Snowy 27.1.2005, 15:29
Эта ошибка может выходить даже при испольсовании стандартного софта. Так что я думаю она как-то завязана на системные политики. Попробуй другую систему с 2003-ми. Если и там не пойдет, попробуй ослабить ограничения на работу с журналами.

Автор: Штабс 27.1.2005, 15:47
Все права есть. Проверено на 2 разных серверах. Не работает.

Автор: p0s0l 27.1.2005, 16:03
Темы объединены...

Автор: Snowy 27.1.2005, 20:55
Может это поможет:
Цитата

• Windows Server 2003
• Windows 2000 Service Pack 4 (SP4)
• Windows XP Service Pack 1 (SP1)
"Error 1783 (RPC_X_BAD_STUB_DATA)" Error Message When You Use the EnumDependentServices Function
SYMPTOMS
When you create a custom program that uses the EnumDependentServices function to retrieve information about dependent services, the EnumDependentServices function may not work correctly. The EnumDependentServices function may return an incorrect buffer size, and you receive an error message that is similar to the following:
CAUSE
This problem occurs if your program requires a buffer that is larger than 64 kilobytes (KB).
RESOLUTION
A supported hotfix is now available from Microsoft
http://support.microsoft.com/default.aspx?scid=fh;%5Bln%5D;cntactms

Автор: Штабс 28.1.2005, 11:47
Snowy
все ОК
заработало
у меня передаваемый буфер был больше
но 64kb... это кисло...
а по наводке

RESOLUTION
A supported hotfix is now available from Microsoft
http://support.microsoft.com/default.aspx?...Bln%5D;cntactms

я ничего не нашел
вы не знаете кто нибудь патчил это...
если знаете подскажите

Автор: Snowy 28.1.2005, 13:04
Как-то не приходилось. Попробуй на микрософте поискать. Видимо страница сменилась, а может патчик поновей сделали. Но, если есть проблема, то и патч у них тоже где-то должен валяться.

Powered by Invision Power Board (http://www.invisionboard.com)
© Invision Power Services (http://www.invisionpower.com)