| Версия для печати темы
Нажмите сюда для просмотра этой темы в оригинальном формате |
| Форум программистов > C/C++: Общие вопросы > Как расчитать погрешность |
| Автор: Faramir 15.8.2005, 09:10 |
| Запрос на сервер,включение счётчика,ответ сервера,отключение счётчика,сохранение данных по текущему значению счётчика. Кто-нибудь знает как рассчитать погрешность времени передачи по сети в данной ситуации? |
| Автор: Romikgy 15.8.2005, 11:19 |
| Погрешность ... относительно чего? |
| Автор: _hunter 15.8.2005, 11:24 |
| это тебе в метрологию нужно наводящий вопрос: поднесли линейку, померяли, убрали линейку. как измерить погрешность измерения да и зачем тебе такая точность? |
| Автор: Дрон 15.8.2005, 12:16 |
| Faramir Сделай сотню запросов и найди среднее значение времени, потом посмотри отклонение каждого запроса от среднего, ну а дальше там какие-то формулы есть, но я их не помню |
| Автор: Hroft 16.8.2005, 11:02 |
| Дак тут совершенно случайные могут отклонения быть... Это не детерминированная система, и даже закона распределения, который можно было бы определить, нет... Тут имеет смысл разве что вероятность того, что отклонение не будет превышать заданного порога. |
| Автор: avek 16.8.2005, 12:52 |
| Есть в Инете такой протокол синхронизации времени - NTP, он как раз этим занимается (передаёт время с хоста на хост и пытается внести поправку на время передачи). Он описан в RFC1305, вот ссылочка, может, сработает: http://www.rfc-editor.org/cgi-bin/rfcdoctype.pl?loc=RFC&letsgo=1305&type=http&file_format=txt Ну и ещё можно там же, на http://www.rfc-editor.org/, глянуть RFC-1119 и RFC-1129, если я не вру насчёт их номеров. |