Модераторы: powerfox, pythonwin, ZeeLax
  

Поиск:

Ответ в темуСоздание новой темы Создание опроса
> Проблема с python3 в Debian 
:(
    Опции темы
NZero
Дата 18.3.2020, 18:52 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Опытный
**


Профиль
Группа: Участник
Сообщений: 358
Регистрация: 28.4.2010
Где: Москва

Репутация: нет
Всего: нет



Всем привет! Столкнулся с такой проблемой. У нас упал proxmox на котором крутятся виртуалки. После поднятий одной из виртуалок на Denian 10.3, начал ругаться python3. Попытался его удалить, чтобы затем установить, но не получилось. А получилось получить такую проблему.

Код

apt-get update
Hit:1 http://security.debian.org buster/updates InRelease
Hit:2 http://ftp.debian.org/debian buster InRelease                        
Hit:3 http://ftp.debian.org/debian buster-updates InRelease                
Hit:4 https://deb.nodesource.com/node_11.x stretch InRelease               
Hit:5 http://ftp.debian.org/debian buster-backports InRelease
Err:4 https://deb.nodesource.com/node_11.x stretch InRelease
  The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 1655A0AB68576280
Reading package lists... Done
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: https://deb.nodesource.com/node_11.x stretch InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 1655A0AB68576280
W: Failed to fetch https://deb.nodesource.com/node_11.x/dists/stretch/InRelease  The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 1655A0AB68576280
W: Some index files failed to download. They have been ignored, or old ones used instead.


а при попытке установить любой из пакетов, получаю такое сообщение

Код

apt-get install libpython3.7-stdlib
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libpython3.7-stdlib is already the newest version (3.7.3-2+deb10u1).
libpython3.7-stdlib set to manually installed.
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 apt-listchanges : Depends: python-support (>= 0.90.0) but it is not installable
                   Depends: python-apt (>= 0.7.93) but it is not going to be installed
 debconf : Breaks: apt-listchanges (< 3.14) but 2.85.13+nmu1 is to be installed
 dh-python : Depends: python3-distutils but it is not going to be installed or
                      python3 (< 3.6.5~rc1-1) but 3.7.3-1 is to be installed
 python3 : PreDepends: python3-minimal (= 3.7.3-1) but it is not going to be installed
           Depends: python3.7 (>= 3.7.3-1~) but it is not going to be installed
 python3-cryptography : Depends: python3-cffi-backend-api-min (<= 9729)
                        Depends: python3-cffi-backend-api-max (>= 9729)
 python3-pip : Depends: python3-distutils but it is not going to be installed
               Recommends: python3-dev (>= 3.2) but it is not going to be installed
 python3-setuptools : Depends: python3-distutils but it is not going to be installed
 software-properties-common : Depends: python3-software-properties (= 0.96.20.2-2) but it is not going to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).


Выполняю команду, как указано в рекомендации

Код

apt --fix-broken install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  bc fish-common irqbalance liblzo2-2 libpcre2-32-0 libpython3-dev libpython3.7 libpython3.7-dev linux-compiler-gcc-6-x86 linux-kbuild-4.9
  runit-helper squashfs-tools xsel
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
  apt-listchanges lsb-release python3-cffi-backend python3-distutils python3-lib2to3 python3-minimal python3-software-properties python3.7
  unattended-upgrades
Suggested packages:
  default-mta | mail-transport-agent x-terminal-emulator lsb python3.7-venv python3.7-doc bsd-mailx needrestart
The following NEW packages will be installed:
  lsb-release python3-cffi-backend python3-distutils python3-lib2to3 python3-minimal python3-software-properties python3.7
  unattended-upgrades
The following packages will be upgraded:
  apt-listchanges
1 upgraded, 8 newly installed, 0 to remove and 1 not upgraded.
35 not fully installed or removed.
Need to get 0 B/943 kB of archives.
After this operation, 2,278 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
Traceback (most recent call last):
  File "/usr/bin/apt-listchanges", line 28, in <module>
    import apt_pkg
ImportError: No module named apt_pkg
Preconfiguring packages ...
Deferring configuration of apt-listchanges until /usr/bin/python3
and python's debconf module are available
Setting up python3.7-minimal (3.7.3-2+deb10u1) ...
# Empty sitecustomize.py to avoid a dangling symlink
Traceback (most recent call last):
  File "/usr/lib/python3.7/py_compile.py", line 7, in <module>
    import importlib._bootstrap_external
ModuleNotFoundError: No module named 'importlib._bootstrap_external'
dpkg: error processing package python3.7-minimal (--configure):
 installed python3.7-minimal package post-installation script subprocess returned error exit status 1
Errors were encountered while processing:
 python3.7-minimal
E: Sub-process /usr/bin/dpkg returned an error code (1)


Кто-то сталкивался с подобной ошибкой и как решали?
PM MAIL WWW ICQ   Вверх
Google
  Дата 30.3.2020, 23:10 (ссылка)  





  Вверх
  
Ответ в темуСоздание новой темы Создание опроса
Правила форума "Linux/UNIX: Администрирование"
ZeeLax
Imple
nerezus
Этот форум предназначен для решения вопросов по администрации *n?x-систем, в частности по настройке сложных сетей и обслуживанию серверного оборудования.

  • Вы должны соблюдать правила форума.
  • Помните: какой вопрос, такой и ответ. Прежде чем задать вопрос прочитайте вот эту статью на форуме CIT.
  • Оскорблять запрещается.
  • Религиозные войны в Религиозных войнах.
  • Общение "просто так" в Клубе юнуксоидов. В отличие от многих других разделов, здесь разрешается сдержанно оффтопить и юморить в тему.

За интересные статьи, находки, решения, программы и просто реальную помощь будут ставиться + в репу).


В данный момент этот раздел модерируют nerezus, nickless, powerfox, pythonwin, Imple и ZeeLax. Если вы хотите помочь нам, пишите в ПМ и мы обсудим.


Спасибо. И use UNIX or die; С уважением, nerezus, nickless, powerfox, pythonwin, Imple, ZeeLax.

 
1 Пользователей читают эту тему (1 Гостей и 0 Скрытых Пользователей)
0 Пользователей:
« Предыдущая тема | Администрирование *NIX систем | Следующая тема »


 




[ Время генерации скрипта: 0.1064 ]   [ Использовано запросов: 21 ]   [ GZIP включён ]


Реклама на сайте     Информационное спонсорство

 
По вопросам размещения рекламы пишите на vladimir(sobaka)vingrad.ru
Отказ от ответственности     Powered by Invision Power Board(R) 1.3 © 2003  IPS, Inc.