![]() |
|
|
![]()
|
|
| Icaros |
|
|||
|
Новичок Профиль Группа: Участник Сообщений: 30 Регистрация: 26.5.2006 Репутация: нет Всего: нет |
Установил Апач 2.2.2 с помощью инсталлера. (d:/server/bin/apache)
Скопировал файлы из архива php в папку (d:/server/bin/php), php.ini в каталог windows В файле httpd.conf добавил в конце строки: ScriptAlias /php/ "D:/server/bin/php/" AddType application/x-httpd-php .php Action application/x-httpd-php "/php/php.exe" В файле php.ini исправил: doc_root = "D:\server\bin\apache\htdocs" extension_dir = "D:\server\bin\php\extensions" В результате при попытке вызвать *.php выводит error 403 (You don't have permission to access /php/php.exe/index.php on this server.) В файле error.log: [Wed Jul 12 19:47:38 2006] [error] [client 127.0.0.1] client denied by server configuration: D:/server/bin/php/php.exe Граждане, помогите. 3-ий день "прыгаю" с серваком... Это сообщение отредактировал(а) Icaros - 12.7.2006, 18:52 |
|||
|
||||
| 2man |
|
|||
![]() Эксперт ![]() ![]() ![]() ![]() Профиль Группа: Комодератор Сообщений: 2007 Регистрация: 6.5.2005 Где: Нижние Чигири Репутация: 1 Всего: 71 |
-------------------- Быстро поднятое - упавшим не считаеся |
|||
|
||||
| Icaros |
|
|||
|
Новичок Профиль Группа: Участник Сообщений: 30 Регистрация: 26.5.2006 Репутация: нет Всего: нет |
2man, я не подключал никаких модулей. Мне не понятно. Однако, с Апачей версии 1.х.х все прошло удачно. В чем причина с Апачей 2 я так и не понимаю. А за ссылку все равно спасибо.
|
|||
|
||||
| Kuber |
|
|||
![]() Шустрый ![]() Профиль Группа: Участник Сообщений: 119 Регистрация: 7.4.2006 Где: #vingrad Репутация: нет Всего: 3 |
Попробуй РНР как модуль подключить:
--------------------
Если меня угораздило написать что то умное и вам понравилось, то не забудте нажать [-]...:) |
|||
|
||||
| Icaros |
|
|||
|
Новичок Профиль Группа: Участник Сообщений: 30 Регистрация: 26.5.2006 Репутация: нет Всего: нет |
Я нашел выход из ситуации.
#<Directory /> # Options FollowSymLinks # AllowOverride None # Order deny,allow # Deny from all # Satisfy all #</Directory> ... и сервер ожил. Господа, может кто даст внятное разъяснение сему случаю ? (напомню: стоит Виндоз ХР СП2, Апача 2, ПХП 5) |
|||
|
||||
| DENNN |
|
|||
|
Эксперт ![]() ![]() ![]() ![]() Профиль Группа: Участник Клуба Сообщений: 3878 Регистрация: 27.3.2002 Где: Москва Репутация: 2 Всего: 43 |
||||
|
||||
| kaa |
|
|||
![]() Опытный ![]() ![]() Профиль Группа: Участник Сообщений: 817 Регистрация: 5.11.2005 Репутация: -1 Всего: 2 |
[ФЛУД]
DENNN, Самое противное что у мя такая же бодяга... Самое странное что для 2.0.43 ничего комментировать ненадо было! [/ФЛУД] |
|||
|
||||
| DENNN |
|
|||
|
Эксперт ![]() ![]() ![]() ![]() Профиль Группа: Участник Клуба Сообщений: 3878 Регистрация: 27.3.2002 Где: Москва Репутация: 2 Всего: 43 |
||||
|
||||
![]()
|
| 0 Пользователей читают эту тему (0 Гостей и 0 Скрытых Пользователей) | |
| 0 Пользователей: | |
| « Предыдущая тема | Администрирование Web серверов и Web служб | Следующая тема » |
|
|
По вопросам размещения рекламы пишите на vladimir(sobaka)vingrad.ru
Отказ от ответственности Powered by Invision Power Board(R) 1.3 © 2003 IPS, Inc. |