![]() |
|
|
![]()
|
|
| Wolf1994 |
|
||||
|
Эксперт ![]() ![]() ![]() Профиль Группа: Завсегдатай Сообщений: 1701 Регистрация: 5.10.2004 Репутация: 3 Всего: 29 |
Провёл полчаса в поиске по Яндексу, но ничего не нашёл...
Как исключить определённый директорий со всеми поддиреториями и файлами из обработки модом-реврайтом? То есть, как, например, сделать, чтобы в этих правилах:
игнорировался директоий works и его вхождения? ...И чтобы два раза не спрашивать
|
||||
|
|||||
| Mal Hack |
|
|||
![]() Мудрый... ![]() ![]() ![]() ![]() Профиль Группа: Участник Клуба Сообщений: 9926 Регистрация: 15.2.2004 Репутация: 15 Всего: 261 |
RewriteRule ^/works(.*?)$ /works$1 [L]
В самое начало |
|||
|
||||
| Wolf1994 |
|
||||
|
Эксперт ![]() ![]() ![]() Профиль Группа: Завсегдатай Сообщений: 1701 Регистрация: 5.10.2004 Репутация: 3 Всего: 29 |
Не работает (500 ошибка) Причём, так работает правило:
А так тоже - нет:
Это сообщение отредактировал(а) Wolf1994 - 19.10.2006, 11:16 |
||||
|
|||||
| Wolf1994 |
|
|||
|
Эксперт ![]() ![]() ![]() Профиль Группа: Завсегдатай Сообщений: 1701 Регистрация: 5.10.2004 Репутация: 3 Всего: 29 |
Так сработало:
RewriteRule ^works([A-Za-z/0-9-]+)$ works$1/index [L,NS] Вопрос решён. Добавлено @ 21:16 ...Если бы ещё знать почему сработало и почему не работало по-другому... |
|||
|
||||
| Mal Hack |
|
|||
![]() Мудрый... ![]() ![]() ![]() ![]() Профиль Группа: Участник Клуба Сообщений: 9926 Регистрация: 15.2.2004 Репутация: 15 Всего: 261 |
Попробуй так.
Твой вариант не пропустит к примеру URL: works/по русски или works/we_34/ |
|||
|
||||
| Wolf1994 |
|
||||
|
Эксперт ![]() ![]() ![]() Профиль Группа: Завсегдатай Сообщений: 1701 Регистрация: 5.10.2004 Репутация: 3 Всего: 29 |
Мой вариант не сработал на хостинге (сработал на Денвере) - "Ошибка 500".
Твой вариант или проигнорировался, или "взялся", но при повторном прохождении перешёл на обработку к:
То есть правила:
привели к исполнению index.php |
||||
|
|||||
| Mal Hack |
|
|||
![]() Мудрый... ![]() ![]() ![]() ![]() Профиль Группа: Участник Клуба Сообщений: 9926 Регистрация: 15.2.2004 Репутация: 15 Всего: 261 |
|
|||
|
||||
| Wolf1994 |
|
|||
|
Эксперт ![]() ![]() ![]() Профиль Группа: Завсегдатай Сообщений: 1701 Регистрация: 5.10.2004 Репутация: 3 Всего: 29 |
"Internal Server Error" и на Денвере и в Сети
Может надо сделать поправку на версию Apache? На хостинге стоит Apache/1.3.33 (Unix). |
|||
|
||||
| Mal Hack |
|
|||
![]() Мудрый... ![]() ![]() ![]() ![]() Профиль Группа: Участник Клуба Сообщений: 9926 Регистрация: 15.2.2004 Репутация: 15 Всего: 261 |
Это тут не причем...
|
|||
|
||||
| Wolf1994 |
|
|||
|
Эксперт ![]() ![]() ![]() Профиль Группа: Завсегдатай Сообщений: 1701 Регистрация: 5.10.2004 Репутация: 3 Всего: 29 |
Ошибка.
А может, то что я хочу - невозможно? То есть непредусмотрена перезапись с одного "красивого" URL на другой? |
|||
|
||||
| Wolf1994 |
|
|||
|
Эксперт ![]() ![]() ![]() Профиль Группа: Завсегдатай Сообщений: 1701 Регистрация: 5.10.2004 Репутация: 3 Всего: 29 |
Нашёл!!!
|
|||
|
||||
![]()
|
| 0 Пользователей читают эту тему (0 Гостей и 0 Скрытых Пользователей) | |
| 0 Пользователей: | |
| « Предыдущая тема | Администрирование Web серверов и Web служб | Следующая тема » |
|
|
По вопросам размещения рекламы пишите на vladimir(sobaka)vingrad.ru
Отказ от ответственности Powered by Invision Power Board(R) 1.3 © 2003 IPS, Inc. |