Модераторы: skyboy, MoLeX, Aliance, ksnk
  

Поиск:

Ответ в темуСоздание новой темы Создание опроса
> [Oracle] отсутствие соединения, ORA-12154 
V
    Опции темы
azesmcar
Дата 13.2.2007, 12:17 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


uploading...
****


Профиль
Группа: Участник Клуба
Сообщений: 6291
Регистрация: 12.11.2004
Где: Армения

Репутация: 1
Всего: 211



Здравствуйте..

Я настроил оракл под линукс..сделал build php4 с поддержкой oracle -а..функции он понимает...но при попытке приконектиться выдает ошибку
ORA-12154: TNS:could not resolve the connect identifier specified
sqlplus нормально работает..

Цитата

[[email protected] bin]$ sqlplus test/test@billing

SQL*Plus: Release 10.2.0.1.0 - Production on Tue Feb 13 14:17:10 2007

Copyright © 1982, 2005, Oracle.  All rights reserved.


Connected to:
Oracle Database 10g Enterprise Edition Release 10.2.0.1.0 - Production
With the Partitioning, OLAP and Data Mining options

SQL>


А в php код

Код

<?
    OCILogon("test", "test", "billing");
?>


выдает ошибку.
конфигурацию можно посмотреть здесь

Заранее спасибо
PM   Вверх
Mal Hack
Дата 13.2.2007, 22:49 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Мудрый...
****


Профиль
Группа: Участник Клуба
Сообщений: 9926
Регистрация: 15.2.2004

Репутация: 11
Всего: 261



Какую ошибку выдает?
PHP5 попробуй заюзать.
PM ICQ   Вверх
azesmcar
Дата 13.2.2007, 23:30 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


uploading...
****


Профиль
Группа: Участник Клуба
Сообщений: 6291
Регистрация: 12.11.2004
Где: Армения

Репутация: 1
Всего: 211



Выдает

Цитата

ORA-12154: TNS:could not resolve the connect identifier specified


php4 в до переинсталяции работал нормально...если поконкретней то эта же версия php с той же самой версией oracle и под той же самой версией RedHat работали. А теперь почему то отказываются.
PM   Вверх
Mal Hack
Дата 13.2.2007, 23:39 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Мудрый...
****


Профиль
Группа: Участник Клуба
Сообщений: 9926
Регистрация: 15.2.2004

Репутация: 11
Всего: 261



Точно не могу сказать, т.к. с ОРаклом не работал.
Проверь конфигурации. Может по сравнению с ранее стоявшей версией PHP, чего-ть не хватает в настройках PHP.

Цитата
ORA-12154: TNS:could not resolve the connect identifier specified
    Cause: A connection to a database or other service was requested using a connect identifier, and the connect identifier specified could not be resolved into a connect descriptor using one of the naming methods configured. For example, if the type of connect identifier used was a net service name then the net service name could not be found in a naming method repository, or the repository could not be located or reached.
    Action:

    - If you are using local naming (TNSNAMES.ORA file):

    - Make sure that "TNSNAMES" is listed as one of the values of the NAMES.DIRECTORY_PATH parameter in the Oracle Net profile (SQLNET.ORA)

    - Verify that a TNSNAMES.ORA file exists and is in the proper directory and is accessible.

    - Check that the net service name used as the connect identifier exists in the TNSNAMES.ORA file.

    - Make sure there are no syntax errors anywhere in the TNSNAMES.ORA file. Look for unmatched parentheses or stray characters. Errors in a TNSNAMES.ORA file may make it unusable.

    - If you are using directory naming:

    - Verify that "LDAP" is listed as one of the values of the NAMES.DIRETORY_PATH parameter in the Oracle Net profile (SQLNET.ORA).

    - Verify that the LDAP directory server is up and that it is accessible.

    - Verify that the net service name or database name used as the connect identifier is configured in the directory.

    - Verify that the default context being used is correct by specifying a fully qualified net service name or a full LDAP DN as the connect identifier

    - If you are using easy connect naming:

    - Verify that "EZCONNECT" is listed as one of the values of the NAMES.DIRETORY_PATH parameter in the Oracle Net profile (SQLNET.ORA).

    - Make sure the host, port and service name specified are correct.

    - Try enclosing the connect identifier in quote marks. See the Oracle Net Services Administrators Guide or the Oracle operating system specific guide for more information on naming.


http://linuxforum.ru/index.php?showtopic=18341&st=30
PM ICQ   Вверх
azesmcar
Дата 14.2.2007, 09:35 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


uploading...
****


Профиль
Группа: Участник Клуба
Сообщений: 6291
Регистрация: 12.11.2004
Где: Армения

Репутация: 1
Всего: 211



Это описание ошибки из оракла..но вопрос в том что оракл нормально работает..я могу запустить SQLPLUS, он нормально работает..а вот с PHP проблема...версия таже самая, php.ini тоже..у меня такое ощущение что я что-то забыл. instant client установлен, уже не знаю что бы еще сделать. Никто не настраивал php4 под линукс для работы с ораклом?
PM   Вверх
azesmcar
Дата 14.2.2007, 12:07 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


uploading...
****


Профиль
Группа: Участник Клуба
Сообщений: 6291
Регистрация: 12.11.2004
Где: Армения

Репутация: 1
Всего: 211



Фууу...исправил..

Кому интересно, надо добавить пользователя apache в группу пользователя которым инсталировал оракл.

PM   Вверх
  
Ответ в темуСоздание новой темы Создание опроса
0 Пользователей читают эту тему (0 Гостей и 0 Скрытых Пользователей)
0 Пользователей:
« Предыдущая тема | PHP: Базы Данных | Следующая тема »


 




[ Время генерации скрипта: 0.0542 ]   [ Использовано запросов: 22 ]   [ GZIP включён ]


Реклама на сайте     Информационное спонсорство

 
По вопросам размещения рекламы пишите на vladimir(sobaka)vingrad.ru
Отказ от ответственности     Powered by Invision Power Board(R) 1.3 © 2003  IPS, Inc.