![]() |
|
Модераторы: LSD, AntonSaburov |
![]()
|
|
| Llucas |
|
||||||||||
![]() J2EE Developer ![]() Профиль Группа: Участник Сообщений: 160 Регистрация: 29.11.2006 Где: Одесса Репутация: нет Всего: нет |
Доброй ночи! Подскажите пожалуйста, не могу запустить пример из книги.
faces-config.xml
web.xml
UserBean.java
index.html
index.jsp
Создаю War файл. Пытаюсь его задеплоить в томкат. Выскакивает экзепшен: description The server encountered an internal error () that prevented it from fulfilling this request. exception javax.servlet.ServletException: Servlet.init() for servlet Faces Servlet threw exception org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:105) org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:148) org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:869) org.apache.coyote.http11.Http11BaseProtocol$Http11ConnectionHandler.processConnection(Http11BaseProtocol.java:664) org.apache.tomcat.util.net.PoolTcpEndpoint.processSocket(PoolTcpEndpoint.java:527) org.apache.tomcat.util.net.LeaderFollowerWorkerThread.runIt(LeaderFollowerWorkerThread.java:80) org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:684) java.lang.Thread.run(Unknown Source) root cause java.lang.IllegalStateException: Application was not properly initialized at startup, could not find Factory: javax.faces.context.FacesContextFactory javax.faces.FactoryFinder.getFactory(FactoryFinder.java:263) javax.faces.webapp.FacesServlet.init(FacesServlet.java:142) org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:105) org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:148) org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:869) org.apache.coyote.http11.Http11BaseProtocol$Http11ConnectionHandler.processConnection(Http11BaseProtocol.java:664) org.apache.tomcat.util.net.PoolTcpEndpoint.processSocket(PoolTcpEndpoint.java:527) org.apache.tomcat.util.net.LeaderFollowerWorkerThread.runIt(LeaderFollowerWorkerThread.java:80) org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:684) java.lang.Thread.run(Unknown Source) Так как я пока не очень понимаю....куда смотреть и где искать ошибку, прошу помощи, спасибо. |
||||||||||
|
|||||||||||
| Maksym |
|
|||
![]() . ![]() ![]() ![]() Профиль Группа: Участник Клуба Сообщений: 1456 Регистрация: 19.8.2005 Где: Odessa, Black Sea Репутация: 24 Всего: 62 |
UserBean действительно лежит в пакете com.corejsf.*?
|
|||
|
||||
| Llucas |
|
|||
![]() J2EE Developer ![]() Профиль Группа: Участник Сообщений: 160 Регистрация: 29.11.2006 Где: Одесса Репутация: нет Всего: нет |
Совершенно точно. |
|||
|
||||
| Maksym |
|
|||
![]() . ![]() ![]() ![]() Профиль Группа: Участник Клуба Сообщений: 1456 Регистрация: 19.8.2005 Где: Odessa, Black Sea Репутация: 24 Всего: 62 |
jsf-api.jar, jsf-impl.jar попадают в .war, а именно в папку WEB-INF/lib?
|
|||
|
||||
| Llucas |
|
|||
![]() J2EE Developer ![]() Профиль Группа: Участник Сообщений: 160 Регистрация: 29.11.2006 Где: Одесса Репутация: нет Всего: нет |
Попадают... и еще два *jar-ика из томката, так было написано в инструкции по установке.
|
|||
|
||||
| Maksym |
|
|||
![]() . ![]() ![]() ![]() Профиль Группа: Участник Клуба Сообщений: 1456 Регистрация: 19.8.2005 Где: Odessa, Black Sea Репутация: 24 Всего: 62 |
Llucas
Гм, ну еще вижу, что редирект с index.html идет на index.faces, а файл у тебя index.jsp. Хотя проблема, не в этом, насколько понимаю... какие версии jsf-api.jar, jsf-impl.jar используешь? И остальных jar'ов? Это сообщение отредактировал(а) Maksym - 27.9.2007, 16:03 |
|||
|
||||
| Llucas |
|
|||
![]() J2EE Developer ![]() Профиль Группа: Участник Сообщений: 160 Регистрация: 29.11.2006 Где: Одесса Репутация: нет Всего: нет |
jsf-api.jar, jsf-impl.jar версии 1_2_03. Tomcat 5.5 . Из него остальные джары. Изменил редирект - все равно не пашет.
|
|||
|
||||
| powerOn |
|
|||
![]() software saboteur ![]() ![]() ![]() ![]() Профиль Группа: Участник Сообщений: 4367 Регистрация: 7.10.2005 Репутация: 28 Всего: 159 |
если мне не изменяет память, но для JSF 1.2 нужен Servlet 2.5 и JSP 2.1 т.е. Tomcat 6.х
|
|||
|
||||
| Maksym |
|
|||
![]() . ![]() ![]() ![]() Профиль Группа: Участник Клуба Сообщений: 1456 Регистрация: 19.8.2005 Где: Odessa, Black Sea Репутация: 24 Всего: 62 |
powerOn
Не изменяет Llucas Попробуй продеплоить приложение по Tomcat 6 либо используй JSF 1.1 |
|||
|
||||
| ssserg |
|
|||
|
Новичок Профиль Группа: Участник Сообщений: 1 Регистрация: 1.10.2007 Репутация: нет Всего: нет |
измени обратно редирект на index.faces иначе работать не будет 100%,
так как в web.xml прописан шаблон который будет обрабатывать Faces Servlet, далее тебе потребуются следующие библиотеки они нужны все, иначе не будет работать даже Hello world вот они commons-beanutils commons-collections commons-digester jsf-api jsf-impl commons-logging еще библиотека standart, но в ее нужности не уверен и еще ошибка, если по русски в том что при запуске не находится класс javax.faces.context.FacesContextFactory он лежит в jsf-api, как вариант еще проверь есть ли он в этой библиотеке у тебя если нет, то закачай полный jar и если не поможет вот еще вариант добавь это в web.xml <servlet-mapping> <servlet-name>Faces Servlet</servlet-name> <url-pattern>/faces/*</url-pattern> </servlet-mapping> когда задеплоишь в томкате желательно 6-м вызови сразу http://localhost:8080/имя_твоего_приложения/faces/index.jsp или вызови сразу http://localhost:8080/имя_твоего_приложения/index.faces если страницы загрузятся то все ок про то что надо помещать war файл в Apache Software Foundation\Tomcat 6.0\webapps я думаю говорить не надо, удачи Это сообщение отредактировал(а) ssserg - 1.10.2007, 23:06 |
|||
|
||||
![]()
|
| Правила форума "Java" | |
|
|
Если Вам помогли, и атмосфера форума Вам понравилась, то заходите к нам чаще! С уважением, LSD, AntonSaburov, powerOn, tux. |
| 0 Пользователей читают эту тему (0 Гостей и 0 Скрытых Пользователей) | |
| 0 Пользователей: | |
| « Предыдущая тема | Java EE (J2EE) и Spring | Следующая тема » |
|
|
По вопросам размещения рекламы пишите на vladimir(sobaka)vingrad.ru
Отказ от ответственности Powered by Invision Power Board(R) 1.3 © 2003 IPS, Inc. |