Поиск:

Ответ в темуСоздание новой темы Создание опроса
> Ошибка в логах и пустая страница в отображении, Failed opening for inclusion 
:(
    Опции темы
Ace Wentura
Дата 19.3.2009, 16:56 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Бывалый
*


Профиль
Группа: Участник
Сообщений: 161
Регистрация: 19.2.2004
Где: Санкт-Петербург

Репутация: нет
Всего: нет



Иногда (непонятно по какой причине и от чего зависит) страница не отображается. При этом простая перезагрузка страницы (релоад) может привести к нормальной работе, а может и не привести.
В логах примерно такой текст:
Код

[Thu Mar 19 16:18:42 2009] [error] [client ...] PHP Warning:  Unknown: failed to open stream: No such file or directory in Unknown on line 0, referer: ...
[Thu Mar 19 16:18:42 2009] [error] [client ...] PHP Warning:  Unknown: Failed opening 'ПУТЬ/ФАЙЛ' for inclusion (include_path='.:') in Unknown on line 0, referer: ...

Что это и как с этим бороться?
Рестарт сервера не помогает никак.

PS: связка Apache+PHP

Это сообщение отредактировал(а) Ace Wentura - 19.3.2009, 16:58
PM MAIL   Вверх
DSsupport
Дата 19.3.2009, 19:09 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Шустрый
*


Профиль
Группа: Участник
Сообщений: 64
Регистрация: 5.3.2009

Репутация: 5
Всего: 5



Есть несколько наиболее вероятных вариантов:

1) Неправильный путь к файлу(возможно в полном пути указан пробел или не английские символы). Тут необходим полный вывод ошибки, без замены 'ПУТЬ/ФАЙЛ'.
2) Возможно, пристроен некий mod_rewrite, к-рый все запросы переадресовывает на broken_include_script.php, к-рый что-то там инициализирует (с ошибками), а затем уже включает file.php
3) Неправильно собран php. Какая операционная система? как устанавливался php.
PM MAIL WWW ICQ GTalk Jabber   Вверх
Ace Wentura
Дата 19.3.2009, 22:50 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Бывалый
*


Профиль
Группа: Участник
Сообщений: 161
Регистрация: 19.2.2004
Где: Санкт-Петербург

Репутация: нет
Всего: нет



Такое ощущение, что это третий вариант.
1 нереален вследствие того, что нет пробелов в пути. Да и происходит это не каждый раз. Можно просто нажать релоад и не получить ничего, а потом нажать ещё раз и получить нормальное отображение. Раз на раз не приходится
2 нереален из-за того, что происходит это на нескольких сайтах, один из которых по модреврайту не работает (там только аутентификация через апач), второй вообще без htaccess, а остальные с мод-реврайтом. Так что грешить на это наверное не стоит
3. Стоит FreeBSD+php5. НО ставили панель ISPManager. И что там с ней происходило, что она с собой принесла - никто не знает. При этом реально стала заметна проблема только в последние несколько дней, хотя сервер работает уже порядка двух лет. Может быть обновление (вроде как какие-то ставятся автоматом) при установке сделало какую-нибудь гадость?
PM MAIL   Вверх
  
Ответ в темуСоздание новой темы Создание опроса
0 Пользователей читают эту тему (0 Гостей и 0 Скрытых Пользователей)
0 Пользователей:
« Предыдущая тема | Администрирование Web серверов и Web служб | Следующая тема »


 




[ Время генерации скрипта: 0.0801 ]   [ Использовано запросов: 21 ]   [ GZIP включён ]


Реклама на сайте     Информационное спонсорство

 
По вопросам размещения рекламы пишите на vladimir(sobaka)vingrad.ru
Отказ от ответственности     Powered by Invision Power Board(R) 1.3 © 2003  IPS, Inc.