Модераторы: skyboy
  

Поиск:

Ответ в темуСоздание новой темы Создание опроса
> Скопировала базу на другой раздел, она не запускае 
V
    Опции темы
animegirl
Дата 6.9.2012, 14:35 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Незнайка на Марсе
**


Профиль
Группа: Участник
Сообщений: 326
Регистрация: 24.7.2011

Репутация: нет
Всего: нет



Вот что выдал server.err
Код

120906 05:16:37 mysqld_safe Starting mysqld daemon with databases from /base/db_tests/db/db
120906  5:16:37 [Warning] '--log' is deprecated and will be removed in a future release. Please use ''--general_log'/'--general_log_file'' instead.
 /usr/sbin/mysqld: Can't create/write to file '/base/db_tests/db/tmp/ibbWeTs9' (Errcode: 13)
 120906  5:16:38  InnoDB: Error: unable to create temporary file; errno: 13
 120906  5:16:38 [ERROR] Plugin 'InnoDB' init function returned error.
 120906  5:16:38 [ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE failed.
 /usr/sbin/mysqld: File '/var/log/mysqld.log' not found (Errcode: 13)
 120906  5:16:38 [ERROR] Could not use /var/log/mysqld.log for logging (error 13). Turning logging off for the whole duration of the MySQL server process. To turn it on again: fix the cause, shutdown the MySQL server and restart it.
 120906  5:16:38 [ERROR] Unknown/unsupported table type: innodb
 120906  5:16:38 [ERROR] Aborting

 120906  5:16:38 [Note] /usr/sbin/mysqld: Shutdown complete

 120906 05:16:38 mysqld_safe mysqld from pid file /base/db_tests/db/db/tests.pid ended


В чём может быть проблема? Права папкам выдала, овнера переставила, в конфиге всё прописала, точно такая же база с которой была снята копия, запускается без проблем, а эта не хочет


--------------------
Скажи миру - НЯ!
PM   Вверх
Akina
Дата 6.9.2012, 15:12 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Советчик
****


Профиль
Группа: Модератор
Сообщений: 20581
Регистрация: 8.4.2004
Где: Зеленоград

Репутация: 106
Всего: 454





--------------------
 О(б)суждение моих действий - в соответствующей теме, пожалуйста. Или в РМ. И высшая инстанция - Администрация форума.

PM MAIL WWW ICQ Jabber   Вверх
animegirl
Дата 6.9.2012, 18:20 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Незнайка на Марсе
**


Профиль
Группа: Участник
Сообщений: 326
Регистрация: 24.7.2011

Репутация: нет
Всего: нет



Всё проставлено как надо, замечено именно тот факт, что после переноса на другой раздел диска, перестало работать :(


--------------------
Скажи миру - НЯ!
PM   Вверх
tzirechnoy
Дата 6.9.2012, 19:24 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Эксперт
***


Профиль
Группа: Завсегдатай
Сообщений: 1173
Регистрация: 30.1.2009

Репутация: 3
Всего: 16



Если бы всё было проставлено как надо -- у Вас бы таких ошыбок не было.
PM MAIL   Вверх
Akina
Дата 6.9.2012, 21:31 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Советчик
****


Профиль
Группа: Модератор
Сообщений: 20581
Регистрация: 8.4.2004
Где: Зеленоград

Репутация: 106
Всего: 454



Чудес не бывает. Ошибка 13 - это именно недостаточно прав. Типа "видит око, да зуб неймёт".

Как именно переносили? вместе с правами доступа, или тупо копированием?

Добавлено через 2 минуты и 21 секунду
Создайте, в конце концов, этот /base/db_tests/db/tmp/ руками с соотв. правами.


--------------------
 О(б)суждение моих действий - в соответствующей теме, пожалуйста. Или в РМ. И высшая инстанция - Администрация форума.

PM MAIL WWW ICQ Jabber   Вверх
animegirl
Дата 7.9.2012, 20:41 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Незнайка на Марсе
**


Профиль
Группа: Участник
Сообщений: 326
Регистрация: 24.7.2011

Репутация: нет
Всего: нет



cp -a
chown -R mysql:mysql
chmod 777


--------------------
Скажи миру - НЯ!
PM   Вверх
animegirl
Дата 7.9.2012, 21:02 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Незнайка на Марсе
**


Профиль
Группа: Участник
Сообщений: 326
Регистрация: 24.7.2011

Репутация: нет
Всего: нет



Вернулась к варианту разрешить всё, всё равно не работает.
Выявился побочный эффект возни с mysql  на клавиатуре перестали работать кнопки ентер контрл esc и другие, но не всегда и не везде, далее, открыто два окна с двумя браузерами, печатаю в одном, потом кликаю внутри другого, пытаюсь печатать туда, но без полезно, он не активный, пока не кликну на его кепку окна. Короче как будто домовой прикалываеться. И как уже сказала, это начинается после проб запускать и перезапускать базы. Сначала не верила, но тест показал. Вот скрин, все права как ест, внутри темпа один файл, создавала сама, поэтому там овнер я.

user posted image


--------------------
Скажи миру - НЯ!
PM   Вверх
animegirl
Дата 7.9.2012, 21:44 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Незнайка на Марсе
**


Профиль
Группа: Участник
Сообщений: 326
Регистрация: 24.7.2011

Репутация: нет
Всего: нет



И так провела повторный эксперемент
root@server:/home/server# cp -a /var/www/db/db /var/www/db/db2
root@server:/home/server# cp -a /var/www/db/tmp /var/www/db/tmp2 
root@server:/home/server# gedit /etc/mysql/my.cnf
root@server:/home/server# /etc/init.d/mysqld_multi start
РАБОТАЕТ!

тестирую дальше
root@server:/home/server# cp -a /var/www/db/tmp2 /base/tests/tmp3
root@server:/home/server# cp -a /var/www/db/db2 /base/tests/db3
с папки /base/tests/ кинула два линка на две эти папки в папку /var/www/db/
root@server:/home/server# gedit /etc/mysql/my.cnf
root@server:/home/server# /etc/init.d/mysqld_multi start
Итог: не работает! Причина - смена раздела. Так как /base это другой раздел моего жесткого диска, просто он туда моунтится

Вопрос: Кто виноват и что делатъ?



--------------------
Скажи миру - НЯ!
PM   Вверх
tzirechnoy
Дата 8.9.2012, 11:21 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Эксперт
***


Профиль
Группа: Завсегдатай
Сообщений: 1173
Регистрация: 30.1.2009

Репутация: 3
Всего: 16



1) С правами нижэ db_tests вроде всё нормально, осталось выяснить права вышэ db_tests.
2) 
Цитата
с папки /base/tests/ кинула два линка на две эти папки в папку /var/www/db/


Как кидали, что получилось, что говорит ls.
3) Вы показали права на db_tests, а копировали в  /base/tests. Разумеется, права на db_tests не имеют никакого отношэния к запуску mysql с базами в /base/tests.

PM MAIL   Вверх
animegirl
Дата 10.9.2012, 18:43 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Незнайка на Марсе
**


Профиль
Группа: Участник
Сообщений: 326
Регистрация: 24.7.2011

Репутация: нет
Всего: нет



Проблема была в /base там стояли права 700


--------------------
Скажи миру - НЯ!
PM   Вверх
  
Ответ в темуСоздание новой темы Создание опроса
0 Пользователей читают эту тему (0 Гостей и 0 Скрытых Пользователей)
0 Пользователей:
« Предыдущая тема | MySQL | Следующая тема »


 




[ Время генерации скрипта: 0.1765 ]   [ Использовано запросов: 22 ]   [ GZIP включён ]


Реклама на сайте     Информационное спонсорство

 
По вопросам размещения рекламы пишите на vladimir(sobaka)vingrad.ru
Отказ от ответственности     Powered by Invision Power Board(R) 1.3 © 2003  IPS, Inc.