Модераторы: LSD
  

Поиск:

Ответ в темуСоздание новой темы Создание опроса
> Ошибка:ORA-01555 snapshot too old 
:(
    Опции темы
Marriage
Дата 22.12.2004, 14:52 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Опытный
**


Профиль
Группа: Участник
Сообщений: 842
Регистрация: 4.5.2004
Где: Таганрог

Репутация: нет
Всего: 2



Помогите плз! Срочно нужен ответ!

Ошибка:
ORA-01555 snapshot too old: rollback segment number with name ""
too small
именно без номера и имени сегмента отката!
Предыстория:
имеется организация с ~100 клиентами,
сервак Oracle 8.1.7.4
ОС: виндовоз 2к-сервер
80 сегментов отката (размер уже unlimited)
у них optimal size был увеличен уже с 4 стандартных метров до 32

сначала возникала ошибка:
ORA-01555 snapshot too old: rollback segment number 19 with name "rbs18"
too small

После продолжительных манипуляций было решено грохнуть к чертям этот сегмент, потому как вел он себя немного странно, тем более что число сегментов отката позволяет. После перезапуска клиентского приложения, при выполнения тех же действий что и раньше вылетела ошибка без имени.

Какие есть предложения по решению?

Оччень надо.


--------------------
Praemonitus, praemunitus
PM MAIL ICQ   Вверх
igon
Дата 22.12.2004, 15:34 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Опытный
**


Профиль
Группа: Участник
Сообщений: 327
Регистрация: 30.10.2004

Репутация: 7
Всего: 21



C 8.1.7 не работал, но вот выдержка из доки для 9.0.1

Цитата
Undo Retention Control
Long-running queries sometimes fail because undo information required for consistent read operations is no longer available. This happens because committed undo blocks are overwritten by active transactions.

Automatic undo management provides a way to explicitly control when undo space can be reused--how long undo information will be retained. A DBA can specify a retention period by using the parameter, UNDO_RETENTION. For example, if UNDO_RETENTION is set to 30 minutes, all committed undo information in the system will be retained for at least 30 minutes. This ensures that all queries running for thirty minutes or less will not get the OER (snapshot too old) error, under normal circumstances.

You can either set UNDO_RETENTION at startup or change it dynamically with the ALTER SYSTEM statement. The following example sets retention to 20 minutes:

ALTER SYSTEM SET UNDO_RETENTION = 1200;

If you do not set the UNDO_RETENTION parameter, Oracle uses a small default value that should be adequate for most OLTP systems, where queries are not usually not very long.


Может, применимо и для 8.1.7 ?



--------------------
Хотите поговорить об этом?
PM   Вверх
Marriage
Дата 22.12.2004, 20:44 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Опытный
**


Профиль
Группа: Участник
Сообщений: 842
Регистрация: 4.5.2004
Где: Таганрог

Репутация: нет
Всего: 2



А почемувыскакивает эта ошибка ????

Цитата

ORA-01555 snapshot too old: rollback segment number 19 with name "rbs18"
too small

После продолжительных манипуляций было решено грохнуть к чертям этот сегмент




Цитата

После перезапуска клиентского приложения, при выполнения тех же действий что и раньше вылетела ошибка без имени.


???????????????????????






--------------------
Praemonitus, praemunitus
PM MAIL ICQ   Вверх
igon
Дата 22.12.2004, 23:41 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Опытный
**


Профиль
Группа: Участник
Сообщений: 327
Регистрация: 30.10.2004

Репутация: 7
Всего: 21



Наиболее вероятная причина, при условии достаточного размера и числа сегментов отката, - слишком малое значение UNDO_RETENTION (см.предыдущий пост), недостаточное для выполнения длительных транзакций.
Имеет смысл:
1. Посмотреть характеристики имеющихся сегментов отката
2. Проанализировать trace и log файлы на момент возникновения ошибки
Возможно, там же можно будет отследить "фантомный" сегмент отката (безымянный).
3. Если ошибка лезет на одной и той же транзакции - назначить ей персональный сегмент отката.
4. Проконсультироваться на месте у опытного системного администратора
5. Полный Export базы, пересоздание всех rollback сегментов, Import

Кстати, вопрос на засыпку: а базу-то перегружали? Или только клиентское приложение? smile


--------------------
Хотите поговорить об этом?
PM   Вверх
Marriage
Дата 24.12.2004, 02:07 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Опытный
**


Профиль
Группа: Участник
Сообщений: 842
Регистрация: 4.5.2004
Где: Таганрог

Репутация: нет
Всего: 2



Цитата

4. Проконсультироваться на месте у опытного системного администратора


У него нет идей. Последняя надежда !!!!!
ХЕлп !!!!


--------------------
Praemonitus, praemunitus
PM MAIL ICQ   Вверх
igon
Дата 24.12.2004, 03:37 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Опытный
**


Профиль
Группа: Участник
Сообщений: 327
Регистрация: 30.10.2004

Репутация: 7
Всего: 21



Цитата
4. Проконсультироваться на месте у опытного системного администратора
У него нет идей.

А по остальным пунктам? Что-то пытались делать? Тогда протокол - в студию. У меня пока тоже никаких идей больше нет smile

Самое главное - UNDO_RETENTION пыталить увеличить?

По пункту 5 вообще-то после экспорта хорошо бы полностью базу переустановить.


--------------------
Хотите поговорить об этом?
PM   Вверх
igon
Дата 24.12.2004, 04:22 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Опытный
**


Профиль
Группа: Участник
Сообщений: 327
Регистрация: 30.10.2004

Репутация: 7
Всего: 21



Цитата
у них optimal size был увеличен уже с 4 стандартных метров до 32

А в http://home.clara.net/dwotton/dba/snapshot.htm рекомендуют
Цитата
Do not specify an OPTIMAL size for your rollback segments


См. также http://www.orafaq.com/msgboard/tuning/messages/1038.htm

А в http://asktom.oracle.com/pls/ask/f?p=4950%...3A1100233456522 рассматривается случай
Цитата
именно без номера и имени сегмента отката


Это сообщение отредактировал(а) igon - 24.12.2004, 05:16


--------------------
Хотите поговорить об этом?
PM   Вверх
Marriage
Дата 25.12.2004, 11:05 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Опытный
**


Профиль
Группа: Участник
Сообщений: 842
Регистрация: 4.5.2004
Где: Таганрог

Репутация: нет
Всего: 2



igon
Спасибо за советы ,будем смотреть...


--------------------
Praemonitus, praemunitus
PM MAIL ICQ   Вверх
  
Ответ в темуСоздание новой темы Создание опроса
Правила форума "Oracle"
Zloxa
LSD

Данный раздел предназначен для обсуждения проблем с Oracle Database, другие продукты Oracle здесь не обсуждаются. Просьба при создании темы, придерживаться следующих правил:

  • при создании темы давайте ей осмысленное название, описывающее суть проблемы
  • указывайте используемую версию базы, способ соединения и язык программирования
  • при ошибках обязательно приводите код ошибки и сообщение сервера
  • приводите код в котором возникла ошибка, по возможности дайте тестовый пример демонстрирующий ошибку
  • при вставке кода используйте соответсвующие теги: [code=sql] [/code] для подсветки SQL и PL/SQL кода, [code=java] [/code] - для Java, и т.д.

  • документация по Oracle: 9i, 10g, 11g
  • книги по Oracle можно поискать здесь
  • действия модераторов можно обсудить здесь

Если Вам понравилась атмосфера форума, заходите к нам чаще! С уважением, Zloxa, LSD.

 
0 Пользователей читают эту тему (0 Гостей и 0 Скрытых Пользователей)
0 Пользователей:
« Предыдущая тема | Oracle | Следующая тема »


 




[ Время генерации скрипта: 0.0541 ]   [ Использовано запросов: 22 ]   [ GZIP включён ]


Реклама на сайте     Информационное спонсорство

 
По вопросам размещения рекламы пишите на vladimir(sobaka)vingrad.ru
Отказ от ответственности     Powered by Invision Power Board(R) 1.3 © 2003  IPS, Inc.