Модераторы: skyboy, MoLeX, Aliance, ksnk
  

Поиск:

Ответ в темуСоздание новой темы Создание опроса
> Не работает PhpMyAdmin 
:(
    Опции темы
usa1450
Дата 7.1.2015, 17:55 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Новичок



Профиль
Группа: Участник
Сообщений: 9
Регистрация: 7.1.2015

Репутация: нет
Всего: нет



Не работает PhpMyAdmin

Захожу на http://localhost/phpmyadmin/ выдает ошибку:

Код

Fatal error: Call to undefined function mb_detect_encoding() in
F:\apache\htdocs\www\phpmyadmin\libraries\php-gettext\gettext.inc on line 177
В папке f:\apache\htdocs\www\phpmyadmin\ лежит PhPMyAdmin



Как исправить ошибку?

user posted image
user posted image
user posted image
user posted image

Это сообщение отредактировал(а) usa1450 - 7.1.2015, 17:56
PM MAIL   Вверх
gami
Дата 7.1.2015, 22:01 (ссылка)    |    (голосов: 0) Загрузка ... Загрузка ... Быстрая цитата Цитата


Unregistered











1. В файле php.ini убрать ; и указать полный путь extension_dir к каталогу ext
2. Там же убрать ; перед командой extension = mb_string
3. Проверить конфигурацию функцией phpinfo() в тестовом php файле
4. Прочитать вывод сообщений в logs/error.log
5. После всех манипуляций необходимо перегрузить сервер Apache

Этот ответ добавлен с нового Винграда - http://vingrad.com
  Вверх
usa1450
Дата 8.1.2015, 14:21 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Новичок



Профиль
Группа: Участник
Сообщений: 9
Регистрация: 7.1.2015

Репутация: нет
Всего: нет



Вроде как прописал, убрал ";" и перезагрузил апач, но ошибка все равно выбивает 
Код


Fatal error: Call to undefined function mb_detect_encoding() in F:\apache\htdocs\www\phpmyadmin\libraries\php-gettext\gettext.inc on line 177


user posted image
PM MAIL   Вверх
Starikan
Дата 8.1.2015, 19:56 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Шустрый
*


Профиль
Группа: Участник
Сообщений: 87
Регистрация: 25.10.2007

Репутация: -4
Всего: -15



убери эту функцию, че ты к ней привязался
PM MAIL   Вверх
usa1450
Дата 9.1.2015, 19:10 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Новичок



Профиль
Группа: Участник
Сообщений: 9
Регистрация: 7.1.2015

Репутация: нет
Всего: нет



Перезалил, скачал новую версию phpMyAdmin-4.3.6-all-languages.zip и разархивировал в папку phpmyadmin F:\apache\htdocs\phpmyadmin.
Настроек в phpmyadmin не менял, запускаю http://localhost/phpmyadmin/
Ошибка:

Код

Fatal error: Call to undefined function mb_detect_encoding() in 
F:\apache\htdocs\phpmyadmin\libraries\php-gettext\gettext.inc on line 177

PM MAIL   Вверх
Sanchezzz
Дата 10.1.2015, 01:54 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Эксперт
***


Профиль
Группа: Завсегдатай
Сообщений: 1670
Регистрация: 19.11.2006
Где: Voronezh

Репутация: 41
Всего: 60



Убедитесь что модуль php_mbstring установлен в 

это файл ...php55/ext/php_mbstring.dll  если у вас его нет скачайте под конкретно вашу версию.
Дальше файл нужно положить в папку ext
В файле php.ini  
добавить в секцию конфига [PHP] строчку 
Код

extension=php_mbstring.dll

ps. динамичное подключение библиотек не использу, только конфиг только хардкор.

Автору посоветую скачать нормальный локальный сервер.
 xampp или winginx где все настроено и большинство модулей есть.


--------------------
Понравился ответ "+" по репе, не забываем закрывать тему, заказы в LS.
PM MAIL Skype GTalk   Вверх
usa1450
Дата 10.1.2015, 02:43 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Новичок



Профиль
Группа: Участник
Сообщений: 9
Регистрация: 7.1.2015

Репутация: нет
Всего: нет



Файл php_mbstring.dll у меня есть и лежит по адресу F:\apache\php\ext
user posted image

Прописал PHPIniDir "F:/apache/php" в httpd.conf

Вот содержимое PATH в переменных среды:
Цитата
%SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem;
%SYSTEMROOT%\System32\WindowsPowerShell\v1.0;f:\apache\php;f:\apache\php;
f:\apache\bin;c:\Program Files\MySQL\MySQL Server 5.5\bin\


Кинул файл php.ini в каталог C:\Windows  и в C:\Windows\system32 и все равно ошибка 

Цитата

Fatal error: Call to undefined function mb_detect_encoding()
 in F:\apache\htdocs\phpmyadmin\libraries\php-gettext\gettext.inc on line 177


user posted image
user posted image
user posted image

Это сообщение отредактировал(а) usa1450 - 10.1.2015, 02:43
PM MAIL   Вверх
whatisnot
Дата 10.1.2015, 11:44 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Шустрый
*


Профиль
Группа: Участник
Сообщений: 130
Регистрация: 14.12.2014

Репутация: 1
Всего: 2



При "всем на месте", необходимо чтобы это "все" было и версии одной. Забудьте пока о РМА, в сриптах эта библиотека работает, проблем нет?

А вообще, что вам надо - крутой сервер и иметь к несу доступ извне, или же удобный и хороший локальный сервер для отладки скриптов? Если последнее, то скачивайте Open Server, это действительно хороший сервер для таких целей. Установки как таковой не требуется. И если в системе не один физический диск, то не распаковывайте его на системный.

Кстати о РМА, вроде бы чем дальше, тем хуже, в последних версих появилсиь такие моменты, которое не радуют. Кроме РМА есть и другие инструменты. 

Это сообщение отредактировал(а) whatisnot - 10.1.2015, 11:46
PM MAIL   Вверх
usa1450
Дата 10.1.2015, 12:05 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Новичок



Профиль
Группа: Участник
Сообщений: 9
Регистрация: 7.1.2015

Репутация: нет
Всего: нет



Ребята, кто-то может подсказать что нужно подправить в каком файле чтобы запустился PhPMyAdmin чтобы заработало?
Скачать готовую сборку я могу в любой момент и здесь не спрашивая, у меня все готово, только не запускается PhPMyAdmin,  выдает ошибку:

Код

Fatal error: Call to undefined function mb_detect_encoding() in F:\apache\htdocs\phpmyadmin\libraries\php-gettext\gettext.inc on line 177


Как исправить?
PM MAIL   Вверх
usa1450
Дата 10.1.2015, 14:10 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Новичок



Профиль
Группа: Участник
Сообщений: 9
Регистрация: 7.1.2015

Репутация: нет
Всего: нет



Перезагрузил компьютер, удалил с диска C\Windows\php.ini и с C:\Windows\system32\php.ini  И в pathу убрал лишнее прописал:

Код
C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32
\WindowsPowerShell\v1.0;f:\apache\php;c:\Program Files\MySQL\MySQL Server 5.5\bin\


Оказывается почему-то фал в Notepad++ после нажатии на иконку "сохранить",не сохранил файл php.ini. Зашел через пункт "Файл"->"Сохранить как" и исправил.
user posted image
PM MAIL   Вверх
Starikan
Дата 11.1.2015, 19:46 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Шустрый
*


Профиль
Группа: Участник
Сообщений: 87
Регистрация: 25.10.2007

Репутация: -4
Всего: -15



ну вот опять ты начинаешь.. нормально же всё объяснил.
PM MAIL   Вверх
  
Ответ в темуСоздание новой темы Создание опроса
Правила форума "PHP"
Aliance
IZ@TOP
skyboy
SamDark
MoLeX

Новичкам:

  • PHP редакторы собираются и обсуждаются здесь
  • Электронные книги по PHP, документацию можно найти здесь
  • Интерпретатор PHP, полную документацию можно скачать на PHP.NET

Важно:

  • Не брезгуйте пользоваться тегами [code=php]КОД[/code] для повышения читабельности текста/кода.
  • Перед созданием новой темы воспользуйтесь поиском и загляните в FAQ
  • Действия модераторов можно обсудить здесь

Внимание:

  • Темы "ищу скрипт", "подскажите скрипт" и т.п. будут переноситься в форум "Web-технологии"
  • Темы с именами: "Срочно", "помогите", "не знаю как делать" будут УДАЛЯТЬСЯ

Если Вам понравилась атмосфера форума, заходите к нам чаще! С уважением, IZ@TOP, skyboy, SamDark, MoLeX, awers.

 
0 Пользователей читают эту тему (0 Гостей и 0 Скрытых Пользователей)
0 Пользователей:
« Предыдущая тема | PHP: Общие вопросы | Следующая тема »


 




[ Время генерации скрипта: 0.0520 ]   [ Использовано запросов: 22 ]   [ GZIP включён ]


Реклама на сайте     Информационное спонсорство

 
По вопросам размещения рекламы пишите на vladimir(sobaka)vingrad.ru
Отказ от ответственности     Powered by Invision Power Board(R) 1.3 © 2003  IPS, Inc.