![]() |
|
Модераторы: skyboy, MoLeX, Aliance, ksnk |
![]()
|
|
| geo000 |
|
|||
|
Новичок Профиль Группа: Участник Сообщений: 1 Регистрация: 22.2.2006 Репутация: нет Всего: нет |
Появляется сообщение:
Fatal error: Allowed memory size of 8388608 bytes exhausted (tried to allocate 20 bytes) попытки изменить php.ini memory_limit ничего не дают. Может ли кто-нибудь объяснить. Спасибо. Apache 1.3 MySQL 3.23 PHP 4.4.0 Ошибка появляется у пользователя. У разработчиков воспроизвести ее не удается. Установки на серверах одинаковые. Это сообщение отредактировал(а) geo000 - 22.2.2006, 16:25 |
|||
|
||||
| IZ@TOP |
|
|||
![]() Панда-бир! ![]() ![]() ![]() ![]() Профиль Группа: Участник Сообщений: 4795 Регистрация: 3.2.2003 Где: Бамбуковый лес Репутация: 1 Всего: 73 |
geo000, можно хотя бы узнать какое ПО на серере и его конфигурацию, а так же что делает сам скрипт?
-------------------- Один из розовых плюшевых-всадников апокалипсиса... очень злой... Семь кругов ада для новых элементов языка Мои разрозненные мысли |
|||
|
||||
| Alone |
|
|||
![]() Опытный ![]() ![]() Профиль Группа: Участник Сообщений: 663 Регистрация: 11.5.2003 Где: Dnepropetrovsk, U A Репутация: нет Всего: 6 |
А разработчики и пользователь обращаются к одному и тому же серверу???
Или (хе-хе, был на практике такой случай) разработчики смотрели на своей девелоперской копии? Вообще, конечно изменение лимита памяти в пхп.ини должно было помочь, но если после изменения лимита памяти фраза осталась такой же как и была (типа "Fatal error: Allowed memory size of 8388608... ") то похоже ребята, вы попросту не перестартовали апач Это конечно справедливо ТОЛЬКО для случая когда пхп работает как модуль. -------------------- |
|||
|
||||
| tolik777 |
|
|||
|
Шустрый ![]() Профиль Группа: Участник Сообщений: 133 Регистрация: 19.6.2006 Репутация: нет Всего: 2 |
У меня тоже почти такая же проблема.
Вообщем стоял у меня Apache 1.3.37, Zend Optimizer 3.2.0 и PHP 4.4.4. Скрипты немного своих, плюс стандартный Invision Power Board 2.1.5 и OsCommerce 2.2. Все отлично работало, никогда ни одной ошибки с памятью не наблюдал. Memory_limit стояло 8Мбайт. Понадобился мне PHP5, в основном из-за XML. Решил поставить PHP 5.2.0. Поставил. На IPB и в OsCommerce начали везде лезть ошибки о нехватке памяти. Установил Memory_limit в 16 МБайт, пока еще не знаю, но к примеру в OsCommerce в скрипте генерирования PDF-каталога ошибка все равно появляется (хотя в PHP 4.4.4 она появлялась когда memory_limit стоял 6 МБайт). А тут пробовал 24 МБайта ставить и все равно PDF не создается, ругается Allowed memory size..... Только при 64 МБайтах создается. Это что они так РНР5.2.0 оптимизировали? Откатываться обратно на РНР 4.4.4? Или попробовать поставить РНР 5.1.х ветку? |
|||
|
||||
| teroni |
|
|||
|
Опытный ![]() ![]() Профиль Группа: Участник Сообщений: 381 Регистрация: 15.5.2007 Где: Днепропетровск Репутация: 1 Всего: 22 |
Не знаю в чём причина у Вас, у меня такие ошибки вылазили: 1) При работе с огромными файлами; 2) при косяках в скрипте (какие-то слишком ресурсоёмкие операции). Решались проблемы соответсвенно пересмотром самих скриптов. Увеличение размера памяти обычно не спасало, т.к. они ели хоть 8, хоть 16 Мб памяти Только надпись менялась Allowed memory size of 8388608 bytes exhausted на Allowed memory size of 16****** bytes exhausted Это сообщение отредактировал(а) teroni - 29.6.2007, 12:21 |
|||
|
||||
![]()
|
| 0 Пользователей читают эту тему (0 Гостей и 0 Скрытых Пользователей) | |
| 0 Пользователей: | |
| « Предыдущая тема | PHP: Для профи | Следующая тема » |
|
|
По вопросам размещения рекламы пишите на vladimir(sobaka)vingrad.ru
Отказ от ответственности Powered by Invision Power Board(R) 1.3 © 2003 IPS, Inc. |