Модераторы: gambit
  

Поиск:

Ответ в темуСоздание новой темы Создание опроса
> Server Application Unavailable+500 ошибка, стандартные похоже грабли... 
V
    Опции темы
Аленка
Дата 9.10.2006, 00:12 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Шустрый
*


Профиль
Группа: Участник
Сообщений: 54
Регистрация: 16.6.2006

Репутация: нет
Всего: нет



Всем привет!

При запуске aspx страницы IE выдает такое сообщение:

Цитата
Server Application Unavailable 
The web application you are attempting to access on this web server is currently unavailable.  Please hit the "Refresh" button in your web browser to retry your request. 

Administrator Note: An error message detailing the cause of this specific request failure can be found in the application event log of the web server. Please review this log entry to discover what caused this error to occur. 


Плюс при создании веб проекта в студии(2003) выдает 500 ошибку. (Создала виртуальную директорию и в нее пытаюсь помещать проект).

У меня  Framework 1.1, IIS 5.1
Ставила все в нужной  последовательности smile
Запускала aspnet_regiis -i
В свойствах веб узла по умолчанию в inetmgr выбирала анонимный доступ, плюс задавала там свое имя пользователя в системе(XP prof) и пароль(я вхожу под учетной записью с правами админа).

В журнале событий по поводу запуска ASP.NET нашла такое-
Цитата

aspnet_wp.exe could not be started. The error code for the failure is 80004005. This error can be caused when the worker process account has insufficient rights to read the .NET Framework files. Please ensure that the .NET Framework is correctly installed and that the ACLs on the installation directory allow access to the configured account.


и такое-
Цитата
aspnet_wp.exe could not be launched because the username and/or password supplied in the processModel section of the config file are invalid.




Есть вопросы smile

1.Где располагается application event log из первой цитаты?

2.Что такое  ACLs on the installation directory? Там что-то про учетные записи?

3.Что бы еще сделать чтоб заработало? smile 


PS. Я правильно поняла что в опере ASP.NET не работает?
И еще- я не поняла, зачем если выбирать анонимный доступ, надо задавать логин и пароль?



PM   Вверх
$tatic
Дата 9.10.2006, 19:09 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Опытный
**


Профиль
Группа: Участник
Сообщений: 651
Регистрация: 28.1.2005

Репутация: нет
Всего: 22



Похоже, что ты что-то перемудрила с правами или неправильно подключила сайт. Попробуй запустить приложение через стандартный для студии способ (Ctrl+F5), если в 2003 такое есть. Я вообще не парюсь при разработке с IIS, а просто создаю проект в файловой системе и запускаю студийный ASP.NET Development Server означенным способом.
1. Application Event Log можно вызвать через Панель управления - Производительность и обслуживание - Администрирование - Просмотр событий.
2. Похоже, что это связано с правами доступа в NTFS.
3. Попробуй сделать как я smile
ЗЫ. Неправильно поняла, веб-сайт - он и в Африке веб-сайт. Его можно в любом браузере открыть (в т.ч. в Opera Mini в моем Siemens CX70 smile).
А вообще если IIS админить не умеешь - лучше с ним не связываться smile.
PM MAIL   Вверх
Аленка
Дата 10.10.2006, 10:34 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Шустрый
*


Профиль
Группа: Участник
Сообщений: 54
Регистрация: 16.6.2006

Репутация: нет
Всего: нет



ACL- список управления доступом к IIS...
это мне опера рассказала...
но это уже неважно, так как у меня все заработало!!! smile 
Вообщем, я включила учетную запись ASPNET... она почему-то по умолчанию отключена была. Как я раньше этого не заметила... smile

$tatic, а как это 
Цитата
создаю проект в файловой системе 
 и запустить через 
Цитата
Ctrl+F5
?
PM   Вверх
$tatic
Дата 11.10.2006, 18:29 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Опытный
**


Профиль
Группа: Участник
Сообщений: 651
Регистрация: 28.1.2005

Репутация: нет
Всего: 22



Цитата(Аленка @  10.10.2006,  11:34 Найти цитируемый пост)
а как это 
Цитата
создаю проект в файловой системе 
 и запустить через 
Цитата
Ctrl+F5
? 

Элементарно. В студии (у меня 2005, не знаю есть ли в 2003) создаешь ASP.NET Web Site. Он в File - New - Web Site... сидит. Студия предложит на выбор место для сайта: файловую систему (по умолчанию в папке Мои Документы\Visual Studio 2005\WebSites\), HTTP или FTP. Я выбираю ФС. Все, теперь можно спокойно проектировать сайт, а для запуска/отладки можно пользоваться теми же командами (Start и Start Without Debugging), что и для настольных приложений. При этом студия сама запускает свой веб-сервер, уже полностью настроенный, и сама же открывает браузер на нужном адресе. Очень удобно.
PM MAIL   Вверх
Аленка
Дата 11.10.2006, 21:31 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Шустрый
*


Профиль
Группа: Участник
Сообщений: 54
Регистрация: 16.6.2006

Репутация: нет
Всего: нет



В 2003, к сожалению, нужно настраивать внешний веб-сервер...
Мне именно нужно было 2003 настроить, а так бы я конечно, не парилась, делала бы все в 2005-й.


Это сообщение отредактировал(а) Аленка - 11.10.2006, 21:32
PM   Вверх
  
Ответ в темуСоздание новой темы Создание опроса
Прежде чем создать тему, посмотрите сюда:
Любитель
Mymik
mr.DUDA

Используйте теги [code=csharp][/code] для подсветки кода. Используйтe чекбокс "транслит" если у Вас нет русских шрифтов.

Если Вам понравилась атмосфера форума, заходите к нам чаще! С уважением, Любитель, Mymik, mr.DUDA.

 
0 Пользователей читают эту тему (0 Гостей и 0 Скрытых Пользователей)
0 Пользователей:
« Предыдущая тема | Разработка под ASP.NET | Следующая тема »


 




[ Время генерации скрипта: 0.0619 ]   [ Использовано запросов: 22 ]   [ GZIP включён ]


Реклама на сайте     Информационное спонсорство

 
По вопросам размещения рекламы пишите на vladimir(sobaka)vingrad.ru
Отказ от ответственности     Powered by Invision Power Board(R) 1.3 © 2003  IPS, Inc.