![]() |
|
|
![]()
|
|
| biZZon |
|
|||
|
Новичок Профиль Группа: Участник Сообщений: 4 Регистрация: 19.6.2007 Репутация: нет Всего: нет |
проблема довольно банальна: решил установить у себя на лаптопе связку "Apache 2.2.4-win32" + "PHP 5.2.3" + "mysql-essential-5.0.41-win32". моя ОС : Windows XP Home.
Апачи и ПХП работают отлично. MySQL упорно не хочет запускаться. просмотрел в Системе службы. нашёл. стартую : выдаётся сообщение (перевод) "служба "MySQL" не может стартовать на "Локальном Компьютере". Ошибка 1067 : процесс неожиданно прерван ". в логах самойго MySQL сообщение : InnoDB: The first specified data file C:\Server\MySQLDB\ibdata1 did not exist: InnoDB: a new database to be created! 070621 14:18:26 InnoDB: Setting file C:\Server\MySQLDB\ibdata1 size to 10 MB InnoDB: Database physically writes the file full: wait... 070621 14:18:26 InnoDB: Log file .\ib_logfile0 did not exist: new to be created InnoDB: Setting log file .\ib_logfile0 size to 10 MB InnoDB: Database physically writes the file full: wait... 070621 14:18:27 InnoDB: Log file .\ib_logfile1 did not exist: new to be created InnoDB: Setting log file .\ib_logfile1 size to 10 MB InnoDB: Database physically writes the file full: wait... InnoDB: Doublewrite buffer not found: creating new InnoDB: Doublewrite buffer created InnoDB: Creating foreign key constraint system tables InnoDB: Foreign key constraint system tables created 070621 14:18:28 InnoDB: Started; log sequence number 0 0 070621 14:18:28 [Note] C:\Server\MySQL Server 5.0\bin\mysqld-nt: ready for connections. Version: '5.0.41-community-nt' socket: '' port: 0 MySQL Community Edition (GPL) 070621 14:23:01 [Note] C:\Server\MySQL Server 5.0\bin\mysqld-nt: Normal shutdown 070621 14:23:02 InnoDB: Starting shutdown... 070621 14:23:04 InnoDB: Shutdown completed; log sequence number 0 43655 070621 14:23:04 [Note] C:\Server\MySQL Server 5.0\bin\mysqld-nt: Shutdown complete InnoDB: The first specified data file .\ibdata1 did not exist: InnoDB: a new database to be created! 070621 14:23:04 InnoDB: Setting file .\ibdata1 size to 10 MB InnoDB: Database physically writes the file full: wait... InnoDB: Error: all log files must be created at the same time. InnoDB: All log files must be created also in database creation. InnoDB: If you want bigger or smaller log files, shut down the InnoDB: database and make sure there were no errors in shutdown. InnoDB: Then delete the existing log files. Edit the .cnf file InnoDB: and start the database again. 070621 14:23:05 [ERROR] Default storage engine (InnoDB) is not available 070621 14:23:05 [ERROR] Aborting в свойствах этой слубжы укащан путь "C:\Server\MySQL Server 5.0\bin\mysqld-nt" --defaults-file="C:\Server\MySQL Server 5.0\my.ini" MySQL". у меня смутный сомнения, что это my.ini прерывает работу своей же службы. отсюда философский вопрос : " на кой именно ЕМУ это надо?". по теме о серверах БД могу добавить, что недавно пытался установить Oracle. проблема была похожей: сервер установился, создание БД невозможно из-за какой-то ошибки в протоколах. с лисенером , судя по всему, тоже косяк. отсюда ещё один риторический вопрос: не в ОСи ли дело? имеет смысл переходить на версию XP Pro?. если с советом тяжело, может кто-то, у кого MySQL работает, распечатает my.ini в целях сравнения? |
|||
|
||||
| mxp100 |
|
|||
|
Шустрый ![]() Профиль Группа: Участник Сообщений: 67 Регистрация: 2.10.2006 Где: Санкт-Петербург Репутация: нет Всего: нет |
проверь стоит ли read only
и правильно ли прописаны пути в my.ini |
|||
|
||||
![]()
|
| 0 Пользователей читают эту тему (0 Гостей и 0 Скрытых Пользователей) | |
| 0 Пользователей: | |
| « Предыдущая тема | Администрирование Web серверов и Web служб | Следующая тема » |
|
|
По вопросам размещения рекламы пишите на vladimir(sobaka)vingrad.ru
Отказ от ответственности Powered by Invision Power Board(R) 1.3 © 2003 IPS, Inc. |