Модераторы: skyboy
  

Поиск:

Ответ в темуСоздание новой темы Создание опроса
> Проблема с установкой 
:(
    Опции темы
KaD
Дата 18.6.2007, 16:50 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Новичок



Профиль
Группа: Участник
Сообщений: 20
Регистрация: 3.4.2007

Репутация: нет
Всего: нет



Всем привет
Решил поставить mysql 5.0 
Конфиг такой:
Код

./configure --prefix=/opt/mysql \
    --with-client-ldflags=-all-static \
    --with-mysqld-ldflags=-all-static \
    --enable-assembler

Пытался запустить mysql_safe & а он только ошибку выдает и в процессах только mysqld_safe. Логии при этом пустые. 
При выполнении просто mysql_safe запускается все вроде нормально сокет создает, pid-file тоже. Только в логе пишет 
Код

070618 17:44:51  mysqld started
InnoDB: No valid checkpoint found.
InnoDB: If this error appears when you are creating an InnoDB database,
InnoDB: the problem may be that during an earlier attempt you managed
InnoDB: to create the InnoDB data files, but log file creation failed.
InnoDB: If that is the case, please refer to
InnoDB: http://dev.mysql.com/doc/refman/5.0/en/error-creating-innodb.html

И доступа по сокету нету. Mysql при обрашении просто зависает.
Права доступа ко всей папке mysql (rwxrwxrwx).
Самое интересное на другой машине этот же бинарник запускается без проблем.
Кто знает в чем может быть дело или в какую сторону копать а то что-то совсем запутался.
OS Slackware.

PM MAIL   Вверх
KaD
Дата 20.6.2007, 08:47 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Новичок



Профиль
Группа: Участник
Сообщений: 20
Регистрация: 3.4.2007

Репутация: нет
Всего: нет



Проблему исправил на тестируемой машине server-id поставил 2.

При переносе на сервер такая же ситуация появилась и изменение server-id не помогает.
Не могу понять почему после старта сервиса к нему не кто не может законектится. Т.е. как бы коннект происходит но клиент просто подвисает и никаких признаков жизни. В процессах он есть, сокет создает, pid файл тоже создает, только в логе пишет 
070628 17:55:51  mysqld started
а должен писать еще версию, какой порт слушает, и какой локальный сокет открыл.
Еще проблема с запуском InnoDB. Тоже не как не хочет работать с этими таблицами. 
Хотя их (файлы) создает а работать с ними не хочет. Проблему с InnoDB решил с использованием skip-innodb.
Сам сервер запускается вторым т.к. стоит 4.1 и с ним  постоянно работают, поэтому для тестирования 5.0 запускается на другом порту.

my.cnf :
Код

[client]
port        = 3300
socket        = /opt/mysql/var/mysql.sock 
[mysqld]
port        = 3300
socket        = /opt/mysql/var/mysql.sock 
log-bin = /opt/mysql/var/ns
skip-locking
key_buffer = 128M
max_allowed_packet = 1M
table_cache = 512
sort_buffer_size = 2M
read_buffer_size = 2M
read_rnd_buffer_size = 8M
myisam_sort_buffer_size = 64M
thread_cache_size = 8
query_cache_size = 32M
thread_concurrency = 8
server-id    = 1
skip-innodb


запускаю mysql через скрипт:
Код

#!/bin/sh
USER="--user=mysql"
PID_FILE="--pid-file=/opt/mysql/var/mysql.pid"
MY_CNF="--defaults-file=/etc/my.cnf"
/opt/mysql/bin/mysqld_safe $MY_CNF $USER $PID_FILE &

Права доступа к  /opt/mysql/var/ - rwx rwx rwx


Это сообщение отредактировал(а) KaD - 29.6.2007, 09:35
PM MAIL   Вверх
KaD
Дата 29.6.2007, 09:37 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Новичок



Профиль
Группа: Участник
Сообщений: 20
Регистрация: 3.4.2007

Репутация: нет
Всего: нет



Вопрос актуален!!!
 smile 
PM MAIL   Вверх
KaD
Дата 2.7.2007, 11:28 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Новичок



Профиль
Группа: Участник
Сообщений: 20
Регистрация: 3.4.2007

Репутация: нет
Всего: нет



Такую штуку обнаружил.
Запускаю mysql командой:
Код

root@ns:/# /opt/mysql/bin/mysqld_safe --defaults-file=/opt/mysql/etc/my.cnf
Starting mysqld daemon with databases from /opt/mysql/var

В процессах появляется 
Код

root@ns:/opt/mysql/var# ps -e | grep my
 3577 ?        00:00:00 mysqld_safe
 3603 ?        07:24:12 mysqld
 8176 pts/1    00:00:00 mysqld_safe
 8205 pts/1    00:00:00 mysqld
 8206 pts/1    00:00:00 mysqld
 8208 pts/1    00:00:00 mysqld

В логах 
Код

070702 12:32:38  mysqld started

при запуске /opt/mysql/bin/mysql просто подвисает.
При выполнении kill -9 8208
Mysql перезагружается 
Код

/opt/mysql/bin/mysqld_safe: line 388:  8205 Killed                  nohup /opt/mysql/libexec/mysqld --defaults-file=/opt/mysql/etc/my.cnf --basedir=/opt/mysql --datadir=/opt/mysql/var --user=mysql --pid-file=/opt/mysql/var/ns.pid --skip-external-locking --port=3300 --socket=/opt/mysql/var/mysql2.sock >>/opt/mysql/var/ns.err 2>&1

Number of processes running now: 0
070702 12:40:04  mysqld restarted

В логах:
Код

Number of processes running now: 0
070702 12:40:04  mysqld restarted
070702 12:40:04 [Note] /opt/mysql/libexec/mysqld: ready for connections.
Version: '5.0.41-log'  socket: '/opt/mysql/var/mysql2.sock'  port: 3300  Source distribution

И после этого можно законектится  через /opt/mysql/bin/mysql, т.е. выдает приглашение 
mysql > 

Только вот после выхода mysql > quit пытаюсь опять зайти через /opt/mysql/bin/mysql он подвисает. 

Бред какой то.  

PM MAIL   Вверх
mahoro
Дата 7.7.2007, 19:13 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Новичок



Профиль
Группа: Участник
Сообщений: 24
Регистрация: 1.7.2007

Репутация: нет
Всего: нет



А mysql_install_db нормально отработал? Из первого сообщения у меня сложилось впечатление, что нет. 

И еще, я обычно прописываю в configure дефолтные кодировки, чтобы потом с ними меньше заморачиваться..
PM MAIL   Вверх
KaD
Дата 9.7.2007, 09:10 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Новичок



Профиль
Группа: Участник
Сообщений: 20
Регистрация: 3.4.2007

Репутация: нет
Всего: нет



mysql_install_db отработал нормально.
Кодировка не должна влиять на работоспособность mysql.
А то что он постоянно слетает не понятно почему

После компиляции выполняю make test а он выдает:
Код

root@ns:/usr/src/mysql-5.0.41# make test
cd mysql-test ; \
/usr/bin/perl ./mysql-test-run.pl
Logging: ./mysql-test-run.pl
MySQL Version 5.0.41
Skipping ndbcluster, mysqld not compiled with ndbcluster
Skipping SSL, mysqld not compiled with SSL
Using MTR_BUILD_THREAD      = 0
Using MASTER_MYPORT         = 9306
Using MASTER_MYPORT1        = 9307
Using SLAVE_MYPORT          = 9308
Using SLAVE_MYPORT1         = 9309
Using SLAVE_MYPORT2         = 9310
Using IM_PORT               = 9312
Using IM_MYSQLD1_PORT       = 9313
Using IM_MYSQLD2_PORT       = 9314
Killing Possible Leftover Processes
Removing Stale Files
Creating Directories
Installing Master Database
Installing Master Database
Installing Slave1 Database
Creating IM password file (/usr/src/mysql-5.0.41/mysql-test/var/im.passwd)
Installing Im_mysqld_1 Database
Installing Im_mysqld_2 Database
mysql-test-run: WARNING: running this script as _root_ will cause some tests to be skipped
=======================================================
Starting Tests in the 'main' suite

TEST                           RESULT         TIME (ms)
-------------------------------------------------------

mysql-test-run: WARNING: Process 5563 died
alias                          [ fail ]

ERROR: Failed to start master mysqld 0

Aborting: alias failed in default mode. To continue, re-run with '--force'.
Stopping All Servers
Shutting-down Instance Manager
make: *** [test-ns] Ошибка 1
root@ns:/usr/src/mysql-5.0.41#

PM MAIL   Вверх
  
Ответ в темуСоздание новой темы Создание опроса
0 Пользователей читают эту тему (0 Гостей и 0 Скрытых Пользователей)
0 Пользователей:
« Предыдущая тема | MySQL | Следующая тема »


 




[ Время генерации скрипта: 0.0481 ]   [ Использовано запросов: 22 ]   [ GZIP включён ]


Реклама на сайте     Информационное спонсорство

 
По вопросам размещения рекламы пишите на vladimir(sobaka)vingrad.ru
Отказ от ответственности     Powered by Invision Power Board(R) 1.3 © 2003  IPS, Inc.