Модераторы: powerfox, ZeeLax

Поиск:

Ответ в темуСоздание новой темы Создание опроса
> Поднимаю накрывшуюся сеть...нужна помощь! Наотрез отказывается работать почта! 
V
    Опции темы
St. Andrew
Дата 26.10.2007, 15:56 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Шустрый
*


Профиль
Группа: Участник
Сообщений: 142
Регистрация: 28.3.2005
Где: Санкт-Петербург

Репутация: 1
Всего: 8



Всем добрый день! По непредусмотрительности мы с коллегами оставили фрагмент сети незащищенным на ночь, вот и поплатились...утром оказалось, что не пашут dhcp, squid и почта. Ну, с первыми двумя я вроде как разобрался, но вот с почтой творится что-то не то и очень нужна помощь...иначе в самое ближайшее время мне будет очень грустно.
В общем, MTA - sendmail, POP3-сервер тоже какой-то стандартный, но вот как называется точно сказать не могу, не сам все эту дрянь ставил. Но в процессах висит popper, возможно это он.

Раньше все было следующим образом - каждый новый пользователь системы (ОС Linux RH 7.2) автоматически  получал почтовый аккаунт в системе. Почта приходил в /var/spool/mail (ну или просто var/mail), где лежали файлы, одноименные с файлами пользователей системы. А когда юзер скачивал почту себе на комп почтовой программой в этой директории временно появлялся файлик ".имя юзера".pop. Ну вот, собственно и все, что было...более подробно я не вдавался - работает - и хорошо.

После того, как система была подвергнута стороннему воздействию, Бат начал при получении почты всем юзерам выдавать сообщение вида:
Код

!26.10.2007, 15:34:40: FETCH - Сервер сообщает об ошибке: -ERR [SYS/TEMP] Failed to create /var/mail/.netm.pop with uid 540, gid 12.  Change permissions.


А при попытке почту отправить:
Код

!26.10.2007, 14:57:37: SEND  - Сервер сообщает об ошибке: 5.7.1 <[email protected]>... Command rejected


Очень прошу - выручайте...хотя бы куда копать!!!  Начальство скоро совсем озвереет, а жить хочется!!
--------------------
Оглянитесь вокруг! В мире так много прекрасного!
PM MAIL WWW ICQ   Вверх
Imple
Дата 26.10.2007, 17:03 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Эксперт
***


Профиль
Группа: Завсегдатай
Сообщений: 1546
Регистрация: 14.9.2007
Где: Алма-Ата

Репутация: 18
Всего: 87



Для начала убедитесь что дырка через которую проникли закрыта, и не осталось вредного ПО на сервере. По сути проблемы - демон не может создать файл в директории /var/mail. Убедитесь что эта директория существует, убедитесь что у нее есть права записи пользователя, под которым запущен демон. По поводу отправки почты - дайте больший кусок лога.


--------------------
Не шалю, никого не трогаю, починяю сервер.
PM WWW ICQ Skype GTalk Jabber   Вверх
St. Andrew
Дата 26.10.2007, 17:55 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Шустрый
*


Профиль
Группа: Участник
Сообщений: 142
Регистрация: 28.3.2005
Где: Санкт-Петербург

Репутация: 1
Всего: 8



Дырка закрыта, свитчи переключили обратно.
Демон sendmail запущен от имени root, директория /var/mail имеет владельцем root, группу mail. Каждый файл в папке имеет владельцем соответствующего юзера, а группу - mail.

Получается, что вроде как писать root туда может.

Однако, вот пробую это сделать

Код

root@tpark: /var/mail# touch test.test
touch: creating `test.test': No space left on device


То есть - он пишет, что нет места на винче.

Хотя по команде df место есть (оно там действительно раньше-то было!):
Код

/dev/sda5              2016016   1144368    769236  60% /var


Вот такая бадяга...
А вот кусок лога, я внимательно просмотрел - там тоже в основном глюк с местом, и только в нескольких местах трабл как у меня с uid и gid. 
Код

Oct 26 16:27:08 tpark sm-mta[2180]: l9QCR8i5002180: Milter: connect to filters
Oct 26 16:27:09 tpark drweb-smf: [l9QCR8i5002180]: can not create temporary file /var/drweb/spool/drweb.tmp_ErgoxS - No space left on device
Oct 26 16:27:09 tpark sm-mta[2180]: l9QCR8i5002180: Milter: reject, senders
Oct 26 16:27:09 tpark sm-mta[2180]: l9QCR8i5002180: Milter: from=<[email protected]>, reject=550 5.7.1 Command rejected
Oct 26 16:27:09 tpark sm-mta[2180]: l9QCR8i5002180: from=<[email protected]>, size=0, class=0, nrcpts=0, proto=ESMTP, daemon=MTA, relay=24-182-41-190.static.lnbh.ca.charter.com [24.182.41.190]
Oct 26 16:27:11 tpark popper[2183]: (v4.0.3) Unable to get canonical name of client 192.168.0.23: Unknown host (1)
Oct 26 16:27:11 tpark popper[2183]: [SYS/TEMP] Unable to open temporary maildrop '/var/mail/.an.pop': No space left on device (28)
Oct 26 16:27:11 tpark popper[2183]: an at 192.168.0.23 (192.168.0.23): -ERR [SYS/TEMP] Failed to create /var/mail/.an.pop with uid 524, gid 12.  Change permissions.
Oct 26 16:27:13 tpark sm-mta[2184]: NOQUEUE: connect from 194.187.207.250.inetcom.ru [194.187.207.250] (may be forged)
Oct 26 16:27:13 tpark sm-mta[2184]: l9QCRDi5002184: Milter (drweb-filter): init success to negotiate
Oct 26 16:27:13 tpark sm-mta[2184]: l9QCRDi5002184: Milter: connect to filters
Oct 26 16:27:13 tpark sm-mta[2182]: NOQUEUE: connect from [81.90.17.5]
Oct 26 16:27:13 tpark sm-mta[2182]: l9QCRDi5002182: Milter (drweb-filter): init success to negotiate
Oct 26 16:27:13 tpark sm-mta[2182]: l9QCRDi5002182: Milter: connect to filters
Oct 26 16:27:15 tpark drweb-smf: [l9QCRDi5002182]: can not create temporary file /var/drweb/spool/drweb.tmp_4z6vX1 - No space left on device
Oct 26 16:27:15 tpark sm-mta[2182]: l9QCRDi5002182: Milter: reject, senders
Oct 26 16:27:15 tpark sm-mta[2182]: l9QCRDi5002182: Milter: from=<[email protected]>, reject=550 5.7.1 Command rejected
Oct 26 16:27:15 tpark sm-mta[2182]: l9QCRDi5002182: from=<[email protected]>, size=753, class=0, nrcpts=0, proto=ESMTP, daemon=MTA, relay=[81.90.17.5]
Oct 26 16:27:27 tpark sm-mta[2187]: NOQUEUE: connect from host-80-95-35-150.dialup.sura.ru [80.95.35.150]
Oct 26 16:27:27 tpark sm-mta[2187]: l9QCRRi5002187: Milter (drweb-filter): init success to negotiate
Oct 26 16:27:27 tpark sm-mta[2187]: l9QCRRi5002187: Milter: connect to filters
Oct 26 16:27:32 tpark drweb-smf: [l9QCRRi5002187]: can not create temporary file /var/drweb/spool/drweb.tmp_2QSXxp - No space left on device
Oct 26 16:27:32 tpark sm-mta[2187]: l9QCRRi5002187: Milter: reject, senders
Oct 26 16:27:32 tpark sm-mta[2187]: l9QCRRi5002187: Milter: from=<[email protected]>, reject=550 5.7.1 Command rejected
Oct 26 16:27:35 tpark sm-mta[2187]: l9QCRRi5002187: from=<[email protected]>, size=0, class=0, nrcpts=0, proto=SMTP, daemon=MTA, relay=host-80-95-35-150.dialup.sura.ru [80.95.35.150]
Oct 26 16:27:38 tpark sm-mta[2191]: NOQUEUE: connect from [194.46.109.103]
Oct 26 16:27:38 tpark sm-mta[2191]: l9QCRci5002191: Milter (drweb-filter): init success to negotiate
Oct 26 16:27:38 tpark sm-mta[2191]: l9QCRci5002191: Milter: connect to filters
Oct 26 16:27:39 tpark sm-mta[2193]: NOQUEUE: connect from [194.46.109.103]
Oct 26 16:27:39 tpark sm-mta[2193]: l9QCRdi5002193: Milter (drweb-filter): init success to negotiate
Oct 26 16:27:39 tpark sm-mta[2193]: l9QCRdi5002193: Milter: connect to filters
Oct 26 16:27:40 tpark drweb-smf: [l9QCRci5002191]: can not create temporary file /var/drweb/spool/drweb.tmp_KMxa5S - No space left on device
Oct 26 16:27:40 tpark sm-mta[2191]: l9QCRci5002191: Milter: reject, senders
Oct 26 16:27:40 tpark sm-mta[2191]: l9QCRci5002191: Milter: from=<[email protected]>, reject=550 5.7.1 Command rejected
Oct 26 16:27:40 tpark sm-mta[2191]: l9QCRci5002191: from=<[email protected]>, size=0, class=0, nrcpts=0, proto=SMTP, daemon=MTA, relay=[194.46.109.103]
Oct 26 16:27:40 tpark sm-mta[2193]: l9QCRdi5002193: [194.46.109.103] did not issue MAIL/EXPN/VRFY/ETRN during connection to MTA
Oct 26 16:27:41 tpark sm-mta[2190]: NOQUEUE: connect from [77.241.33.29]
Oct 26 16:27:41 tpark sm-mta[2190]: l9QCRfi5002190: Milter (drweb-filter): init success to negotiate
Oct 26 16:27:41 tpark sm-mta[2190]: l9QCRfi5002190: Milter: connect to filters
Oct 26 16:27:46 tpark sm-mta[2196]: NOQUEUE: connect from [87.70.12.89]
Oct 26 16:27:46 tpark sm-mta[2196]: l9QCRki5002196: Milter (drweb-filter): init success to negotiate
Oct 26 16:27:46 tpark sm-mta[2196]: l9QCRki5002196: Milter: connect to filters
Oct 26 16:27:46 tpark sm-mta[2197]: NOQUEUE: connect from [87.70.12.89]
Oct 26 16:27:46 tpark sm-mta[2197]: l9QCRki5002197: Milter (drweb-filter): init success to negotiate
Oct 26 16:27:46 tpark sm-mta[2197]: l9QCRki5002197: Milter: connect to filters
Oct 26 16:27:46 tpark sm-mta[2198]: NOQUEUE: connect from [87.70.12.89]
Oct 26 16:27:46 tpark sm-mta[2198]: l9QCRki5002198: Milter (drweb-filter): init success to negotiate
Oct 26 16:27:46 tpark sm-mta[2198]: l9QCRki5002198: Milter: connect to filters
Oct 26 16:27:55 tpark sm-mta[2190]: l9QCRfi5002190: [77.241.33.29] did not issue MAIL/EXPN/VRFY/ETRN during connection to MTA
Oct 26 16:27:57 tpark sm-mta[2202]: NOQUEUE: connect from amantech.net [213.8.34.179] (may be forged)
Oct 26 16:27:57 tpark sm-mta[2202]: l9QCRvi5002202: Milter (drweb-filter): init success to negotiate
Oct 26 16:27:57 tpark sm-mta[2202]: l9QCRvi5002202: Milter: connect to filters
Oct 26 16:28:01 tpark drweb-smf: [l9QCRvi5002202]: can not create temporary file /var/drweb/spool/drweb.tmp_nKrrMD - No space left on device
Oct 26 16:28:01 tpark sm-mta[2202]: l9QCRvi5002202: Milter: reject, senders
Oct 26 16:28:01 tpark sm-mta[2202]: l9QCRvi5002202: Milter: from=<[email protected]>, reject=550 5.7.1 Command rejected
Oct 26 16:28:02 tpark sm-mta[2202]: l9QCRvi5002202: from=<[email protected]>, size=0, class=0, nrcpts=0, proto=ESMTP, daemon=MTA, relay=amantech.net [213.8.34.179] (may be forged)
Oct 26 16:28:07 tpark sm-mta[2204]: NOQUEUE: connect from [201.73.228.3]
Oct 26 16:28:07 tpark sm-mta[2204]: l9QCS7i5002204: Milter (drweb-filter): init success to negotiate
Oct 26 16:28:07 tpark sm-mta[2204]: l9QCS7i5002204: Milter: connect to filters
Oct 26 16:28:11 tpark popper[2207]: (v4.0.3) Unable to get canonical name of client 192.168.0.23: Unknown host (1)
Oct 26 16:28:11 tpark popper[2207]: [SYS/TEMP] Unable to open temporary maildrop '/var/mail/.an.pop': No space left on device (28)
Oct 26 16:28:11 tpark popper[2207]: an at 192.168.0.23 (192.168.0.23): -ERR [SYS/TEMP] Failed to create /var/mail/.an.pop with uid 524, gid 12.  Change permissions.
Oct 26 16:28:12 tpark drweb-smf: [l9QCS7i5002204]: can not create temporary file /var/drweb/spool/drweb.tmp_eDKpnx - No space left on device
Oct 26 16:28:12 tpark sm-mta[2204]: l9QCS7i5002204: Milter: reject, senders
Oct 26 16:28:12 tpark sm-mta[2204]: l9QCS7i5002204: Milter: from=<[email protected]>, reject=550 5.7.1 Command rejected
Oct 26 16:28:13 tpark sm-mta[2184]: l9QCRDi5002184: 194.187.207.250.inetcom.ru [194.187.207.250] (may be forged) did not issue MAIL/EXPN/VRFY/ETRN during connection to MTA
Oct 26 16:28:13 tpark sm-mta[2204]: l9QCS7i5002204: from=<[email protected]>, size=0, class=0, nrcpts=0, proto=ESMTP, daemon=MTA, relay=[201.73.228.3]
Oct 26 16:28:13 tpark sm-mta[2209]: NOQUEUE: connect from 194.187.207.250.inetcom.ru [194.187.207.250] (may be forged)
Oct 26 16:28:13 tpark sm-mta[2209]: l9QCSDi5002209: Milter (drweb-filter): init success to negotiate
Oct 26 16:28:13 tpark sm-mta[2209]: l9QCSDi5002209: Milter: connect to filters
Oct 26 16:28:14 tpark sm-mta[2208]: NOQUEUE: connect from ppp-124.120.204.92.revip2.asianet.co.th [124.120.204.92]
Oct 26 16:28:14 tpark sm-mta[2208]: l9QCSEi5002208: Milter (drweb-filter): init success to negotiate
Oct 26 16:28:14 tpark sm-mta[2208]: l9QCSEi5002208: Milter: connect to filters
Oct 26 16:28:18 tpark popper[2214]: (v4.0.3) Unable to get canonical name of client 192.168.0.2: Unknown host (1)
Oct 26 16:28:18 tpark popper[2214]: [SYS/TEMP] Unable to open temporary maildrop '/var/mail/.netm.pop': No space left on device (28)
Oct 26 16:28:18 tpark popper[2214]: netm at 192.168.0.2 (192.168.0.2): -ERR [SYS/TEMP] Failed to create /var/mail/.netm.pop with uid 540, gid 12.  Change permissions.
Oct 26 16:28:19 tpark drweb-smf: [l9QCSEi5002208]: can not create temporary file /var/drweb/spool/drweb.tmp_wfvjEw - No space left on device
Oct 26 16:28:19 tpark sm-mta[2208]: l9QCSEi5002208: Milter: reject, senders
Oct 26 16:28:19 tpark sm-mta[2208]: l9QCSEi5002208: Milter: from=<[email protected]>, reject=550 5.7.1 Command rejected
Oct 26 16:28:19 tpark sm-mta[2213]: NOQUEUE: connect from ppp-124.120.204.92.revip2.asianet.co.th [124.120.204.92]
Oct 26 16:28:19 tpark sm-mta[2213]: l9QCSJi5002213: Milter (drweb-filter): init success to negotiate
Oct 26 16:28:19 tpark sm-mta[2213]: l9QCSJi5002213: Milter: connect to filters
Oct 26 16:28:22 tpark sm-mta[2219]: NOQUEUE: connect from ppp-124.120.204.92.revip2.asianet.co.th [124.120.204.92]
Oct 26 16:28:22 tpark sm-mta[2219]: l9QCSMi5002219: Milter (drweb-filter): init success to negotiate
Oct 26 16:28:22 tpark sm-mta[2219]: l9QCSMi5002219: Milter: connect to filters
Oct 26 16:28:24 tpark drweb-smf: [l9QCSJi5002213]: can not create temporary file /var/drweb/spool/drweb.tmp_R6be0z - No space left on device
Oct 26 16:28:24 tpark sm-mta[2213]: l9QCSJi5002213: Milter: reject, senders
Oct 26 16:28:24 tpark sm-mta[2213]: l9QCSJi5002213: Milter: from=<[email protected]>, reject=550 5.7.1 Command rejected
Oct 26 16:28:28 tpark sm-mta[2221]: NOQUEUE: connect from net174-115.e-kirov.ru [91.144.174.115] (may be forged)
Oct 26 16:28:28 tpark sm-mta[2221]: l9QCSSi5002221: Milter (drweb-filter): init success to negotiate
Oct 26 16:28:28 tpark sm-mta[2221]: l9QCSSi5002221: Milter: connect to filters
Oct 26 16:28:29 tpark drweb-smf: [l9QCSSi5002221]: can not create temporary file /var/drweb/spool/drweb.tmp_9D5eVG - No space left on device
Oct 26 16:28:29 tpark sm-mta[2221]: l9QCSSi5002221: Milter: reject, senders
Oct 26 16:28:29 tpark sm-mta[2221]: l9QCSSi5002221: Milter: from=<[email protected]>, reject=550 5.7.1 Command rejected 


Только вот неясно, что случилось с местом и что делать.
Возможно в системе что-то и осталось...можно ли это как-то выяснить? В голову приходят только антивирусы, но я их под  линукс ни разу не ставил...не успел, все лицензию от начальства ждал. Дождался...

--------------------
Оглянитесь вокруг! В мире так много прекрасного!
PM MAIL WWW ICQ   Вверх
Imple
Дата 26.10.2007, 18:13 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Эксперт
***


Профиль
Группа: Завсегдатай
Сообщений: 1546
Регистрация: 14.9.2007
Где: Алма-Ата

Репутация: 18
Всего: 87



Видно, что и то и другое, вылетает изза одной и той же ошибки. Дайте вывод команды mount.


--------------------
Не шалю, никого не трогаю, починяю сервер.
PM WWW ICQ Skype GTalk Jabber   Вверх
St. Andrew
Дата 26.10.2007, 18:18 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Шустрый
*


Профиль
Группа: Участник
Сообщений: 142
Регистрация: 28.3.2005
Где: Санкт-Петербург

Репутация: 1
Всего: 8



Вот, пожалуйста:

Код

root@tpark: /# mount
/dev/sda6 on / type ext2 (rw)
none on /proc type proc (rw)
usbdevfs on /proc/bus/usb type usbdevfs (rw)
/dev/sda1 on /boot type ext2 (rw)
/dev/sda9 on /home type ext2 (rw)
/dev/sda7 on /usr type ext2 (rw)
/dev/sda5 on /var type ext2 (rw)
none on /dev/pts type devpts (rw,gid=5,mode=620)
/dev/sdb1 on /home/ftp type ext2 (rw)
/dev/sdc2 on /usr/local/ext type ext2 (rw)
/dev/sdc5 on /home/new type ext2 (rw)
automount(pid722) on /misc type autofs (rw,fd=5,pgrp=722,minproto=2,maxproto=3)

--------------------
Оглянитесь вокруг! В мире так много прекрасного!
PM MAIL WWW ICQ   Вверх
Imple
Дата 26.10.2007, 20:48 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Эксперт
***


Профиль
Группа: Завсегдатай
Сообщений: 1546
Регистрация: 14.9.2007
Где: Алма-Ата

Репутация: 18
Всего: 87



Проверьте фс на ошибки. (команда fsck). Может быть, это принесет какие-либо результаты.


--------------------
Не шалю, никого не трогаю, починяю сервер.
PM WWW ICQ Skype GTalk Jabber   Вверх
St. Andrew
Дата 26.10.2007, 23:38 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Шустрый
*


Профиль
Группа: Участник
Сообщений: 142
Регистрация: 28.3.2005
Где: Санкт-Петербург

Репутация: 1
Всего: 8



Проверил. Выдаю лог команды:

Код

root@tpark: ~# fsck /var
Parallelizing fsck version 1.19 (13-Jul-2000)
e2fsck 1.19, 13-Jul-2000 for EXT2 FS 0.5b, 95/08/09
/dev/sda5 is mounted.

WARNING!!!  Running e2fsck on a mounted filesystem may cause
SEVERE filesystem damage.

Do you really want to continue (y/n)? yes

/var was not cleanly unmounted, check forced.
Pass 1: Checking inodes, blocks, and sizes
Inode 12101, i_blocks is 64, should be 8.  Fix<y>? yes

Inode 12118, i_blocks is 104, should be 64.  Fix<y>? yes

Inode 12102, i_size is 10519839, should be 10534912.  Fix<y>? yes

Inode 12102, i_blocks is 20640, should be 20608.  Fix<y>? yes

Inode 12113, i_blocks is 3128, should be 3112.  Fix<y>? yes

Inode 12114, i_size is 25856965, should be 25870336.  Fix<y>? yes

Inode 12114, i_blocks is 50584, should be 50592.  Fix<y>? yes

Inode 14, i_blocks is 384, should be 376.  Fix<y>? yes

Inode 12119, i_blocks is 456, should be 432.  Fix<y>? yes

Inode 32097, i_blocks is 64, should be 8.  Fix<y>? yes

Inode 96245, i_blocks is 64, should be 48.  Fix<y>? yes

Inode 144389, i_blocks is 72, should be 16.  Fix<y>? yes

Inode 176368, i_blocks is 64, should be 8.  Fix<y>? yes

Inode 208444, i_blocks is 112, should be 88.  Fix<y>? yes

Inode 208447, i_blocks is 64, should be 8.  Fix<y>? yes

Inode 208481, i_blocks is 64, should be 8.  Fix<y>? yes

Inode 224669, i_blocks is 128, should be 72.  Fix<y>? yes

Inode 224682, i_blocks is 80, should be 24.  Fix<y>? yes

Pass 2: Checking directory structure
Pass 3: Checking directory connectivity
Pass 4: Checking reference counts
yPass 5: Checking group summary information
Block bitmap differences:  -1914 -1915 -1916 -1917 -1918 -2762 -2763 -2764 -2765 -2766 -2767 -2768 -2770 -2771 -2772 -2773 -2774 -2775 -2776 -2816 -2817 -2818 -2819 -2820 -2821 -2822 -10036 -10037 -17154 -17155 -17156 -30374 -30375 -30376 -30377 -56429 -66192 -66193 -66194 -66195 -66196 -66197 -66198 -199586 -199587 -360983 -360984 -360985 -360986 -360987 -360988 -360989 -427064 -427065 -427066 -427068 -427069 -427070 -427071 -427072 -427073 -427074 -427076 -427077 -427078 -427079 -427080 -427081 -427082 -471618 -471619 -471620 -471621 -471622 -471623 -471624
Fix<y>? yes

Free blocks count wrong for group #0 (6003, counted=6035).
Fix<y>? yes

Free blocks count wrong for group #1 (19931, counted=19932).
Fix<y>? yes

Free blocks count wrong for group #2 (18832, counted=18839).
Fix<y>? yes

Free blocks count wrong for group #6 (11023, counted=11025).
Fix<y>? yes

Free blocks count wrong for group #11 (14814, counted=14821).
Fix<y>? yes

Free blocks count wrong for group #13 (21313, counted=21329).
Fix<y>? yes

Free blocks count wrong for group #14 (19894, counted=19901).
Fix<y>? yes

Free blocks count wrong (217192, counted=217264).
Fix<y>? yes


/var: ***** FILE SYSTEM WAS MODIFIED *****
/var: 256512/256512 files (0.1% non-contiguous), 294800/512064 blocks


Потом перезагрузил сервак, но вот опять же в /var писать по той же причине не хочет.
Однако, что-то явно исправилось))
--------------------
Оглянитесь вокруг! В мире так много прекрасного!
PM MAIL WWW ICQ   Вверх
ZeeLax
Дата 27.10.2007, 05:41 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Эксперт
****


Профиль
Группа: Модератор
Сообщений: 4388
Регистрация: 20.8.2006
Где: Алма-Ата

Репутация: 7
Всего: 88



Код

df
после проверки.


--------------------
Utility is when you have one telephone, luxury is when you have two, opulence is when you have three — and paradise is when you have none.
— Doug Larson
PM MAIL WWW ICQ Skype Jabber   Вверх
St. Andrew
Дата 27.10.2007, 10:51 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Шустрый
*


Профиль
Группа: Участник
Сообщений: 142
Регистрация: 28.3.2005
Где: Санкт-Петербург

Репутация: 1
Всего: 8



Да, в общем-то все то же:

Код

root@tpark: ~# df
Filesystem           1k-blocks      Used Available Use% Mounted on
/dev/sda6              2016016    911020   1002584  48% /
/dev/sda1               132207      6431    118950   6% /boot
/dev/sda9             11432608   5451924   5399936  51% /home
/dev/sda7              1517920   1364892     75920  95% /usr
/dev/sda5              2016016   1151812    761792  61% /var
/dev/sdb1             17639220  12721332   4021868  76% /home/ftp
/dev/sdc2              2016044     85416   1828216   5% /usr/local/ext
/dev/sdc5             24509912         8  23264872   1% /home/new

--------------------
Оглянитесь вокруг! В мире так много прекрасного!
PM MAIL WWW ICQ   Вверх
ZeeLax
Дата 27.10.2007, 11:07 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Эксперт
****


Профиль
Группа: Модератор
Сообщений: 4388
Регистрация: 20.8.2006
Где: Алма-Ата

Репутация: 7
Всего: 88



Перепроверьте /dev/sda5 в отмонтированном состоянии.


--------------------
Utility is when you have one telephone, luxury is when you have two, opulence is when you have three — and paradise is when you have none.
— Doug Larson
PM MAIL WWW ICQ Skype Jabber   Вверх
bilbobagginz
Дата 27.10.2007, 15:40 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Naughtius Maximus
****


Профиль
Группа: Экс. модератор
Сообщений: 8813
Регистрация: 2.3.2004
Где: Israel

Репутация: 34
Всего: 317



зайдите в /var и напишите:
Код

touch xxxx
ls -l / | grep var
lsattr / | grep var
getfacl /var

результат сюда.

файл /var/xxxx можно будет стереть, если получилось его создать.



--------------------
Я ещё не демон. Я только учусь.
PM WWW   Вверх
St. Andrew
Дата 28.10.2007, 16:02 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Шустрый
*


Профиль
Группа: Участник
Сообщений: 142
Регистрация: 28.3.2005
Где: Санкт-Петербург

Репутация: 1
Всего: 8



bilbobagginz, вот, что получилось (файл не создается):
Код

root@tpark: /var# touch xxxx
touch: creating `xxxx': No space left on device
root@tpark: /var# ls -l / | grep var
drwxr-xr-x   27 root     root         4096 Окт 22 17:34 var
root@tpark: /var# lsattr / | grep var
lsattr: Inappropriate ioctl for device While reading flags on //proc
lsattr: Inappropriate ioctl for device While reading flags on //misc
------------ //var
root@tpark: /var# getfacl /var
bash: getfacl: command not found


ZeeLax, сейчас отмонтировать не получается, т.к. пишет, что device is busy. Чтобы отмонтировать - нужно убить всех демонов, работающих с данным разделом? Или еще что-нибудь?
--------------------
Оглянитесь вокруг! В мире так много прекрасного!
PM MAIL WWW ICQ   Вверх
bilbobagginz
Дата 28.10.2007, 17:23 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Naughtius Maximus
****


Профиль
Группа: Экс. модератор
Сообщений: 8813
Регистрация: 2.3.2004
Где: Israel

Репутация: 34
Всего: 317



вопрос: это ваш физический сервер, или это какой-то виртуальный сервер ?
( через Xen/vmware )



вы должны сообщить пользователям об отказе сервиса на час-другой.
лучше конечно запустить пока вспомогательный сервант, но я так понимаю его нет... иначе не потели бы у вас уши.

насчет /var

что-то неладно там.


нужно убить всех пользователей /var ( а в этом числе - syslog и т.д. )
т.е. оптимальнее было бы перезагрузиться в режим single 

после этого проверьте несмонтированный раздел, который монируется на /var

потом наберите 
Код

df

и посмотрите что получилось.
после этого думаю всё прояснится.
нужно посмотреть что именно занимает больше всего места:
Код

du -sk /var/* | sort -nr


И рассказать нам.



удачи.




--------------------
Я ещё не демон. Я только учусь.
PM WWW   Вверх
St. Andrew
Дата 28.10.2007, 18:55 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Шустрый
*


Профиль
Группа: Участник
Сообщений: 142
Регистрация: 28.3.2005
Где: Санкт-Петербург

Репутация: 1
Всего: 8



bilbobagginz, это обычный физический SOHO-сервер, резервного нет.

Завтра обязательно напишу результат проверки. Все-таки хорошо, что  сегодня воскресенье)). Я из дома как раз зашел в однопользовательский режим...по ssh...теперь придется завтра рано утром ехать на работу...)))

Ну ничего, любая глупость ведет к опыту  smile 
--------------------
Оглянитесь вокруг! В мире так много прекрасного!
PM MAIL WWW ICQ   Вверх
St. Andrew
Дата 29.10.2007, 15:01 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Шустрый
*


Профиль
Группа: Участник
Сообщений: 142
Регистрация: 28.3.2005
Где: Санкт-Петербург

Репутация: 1
Всего: 8



Очень забавно, но проблему мы все-таки решили)))
В общем, знакомые инженеры где-то нашли команду df -i , которая говорит о свободном месте с точки зрения индексных дескрипторов. В результате этой команды:

Код

Filesystem            Inodes   IUsed   IFree IUse% Mounted on
/dev/sda6             256512   40065  216447   16% /
/dev/sda1              34136      30   34106    1% /boot
/dev/sda9            1452480  526704  925776   37% /home
/dev/sda7             193152   88275  104877   46% /usr
/dev/sda5             256512  256512   0   100% /var
/dev/sdb1            2240224   85108 2155116    4% /home/ftp
/dev/sdc2             256512   13498  243014    6% /usr/local/ext
/dev/sdc5            3112960      11 3112949    1% /home/new


Оказалось, что sendmail уже долгое время складывал в папку /var/spool/mqueue какие-то файлы с непонятными именами, которые не учитываются командой df . Файлов этих сотни тысяч...как только процентов пять на /var таким образом расчистили, то сразу почта начала работать!!!

Теперь буду учиться писать скрипты и бороться с Cron, чтобы логами и всякой статистикой винт не захламляло!!

Всем - огромное спасибо за участие!!! Было очень приятно пообщаться с профессионалами!


--------------------
Оглянитесь вокруг! В мире так много прекрасного!
PM MAIL WWW ICQ   Вверх
Ответ в темуСоздание новой темы Создание опроса
Правила форума "Linux/UNIX: Администрирование"
ZeeLax
Imple
nerezus
Этот форум предназначен для решения вопросов по администрации *n?x-систем, в частности по настройке сложных сетей и обслуживанию серверного оборудования.

  • Вы должны соблюдать правила форума.
  • Помните: какой вопрос, такой и ответ. Прежде чем задать вопрос прочитайте вот эту статью на форуме CIT.
  • Оскорблять запрещается.
  • Религиозные войны в Религиозных войнах.
  • Общение "просто так" в Клубе юнуксоидов. В отличие от многих других разделов, здесь разрешается сдержанно оффтопить и юморить в тему.

За интересные статьи, находки, решения, программы и просто реальную помощь будут ставиться + в репу).


В данный момент этот раздел модерируют nerezus, nickless, powerfox, pythonwin, Imple и ZeeLax. Если вы хотите помочь нам, пишите в ПМ и мы обсудим.


Спасибо. И use UNIX or die; С уважением, nerezus, nickless, powerfox, pythonwin, Imple, ZeeLax.

 
0 Пользователей читают эту тему (0 Гостей и 0 Скрытых Пользователей)
0 Пользователей:
« Предыдущая тема | Администрирование *NIX систем | Следующая тема »


 




[ Время генерации скрипта: 0.0882 ]   [ Использовано запросов: 22 ]   [ GZIP включён ]


Реклама на сайте     Информационное спонсорство

 
По вопросам размещения рекламы пишите на vladimir(sobaka)vingrad.ru
Отказ от ответственности     Powered by Invision Power Board(R) 1.3 © 2003  IPS, Inc.