Модераторы: LSD
  

Поиск:

Ответ в темуСоздание новой темы Создание опроса
> Ошибка ORA-01034, ORA-27101 
V
    Опции темы
Lingrin
Дата 10.11.2007, 02:37 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Новичок



Профиль
Группа: Участник
Сообщений: 2
Регистрация: 10.11.2007

Репутация: нет
Всего: нет



Суть такова. Oracle 10.2.0.1, установленный на ОС Windows XP SP2 жил себе спокойно, пока не пришла пора ставить на него патч 10.2.0.3.   Установка прошла успешно, но после нее при коннекте выдается ошибка 
ORA-01034: Oracle not available
ORA-27101: Shared memory realm does not exists 
При коннекте sys'ом   - то же самое  

Я нашла оракловое описание этой ошибки. Но не понятно, почему она (ошибка) возникает - ведь в Винде shared выделяется автоматически. Подскажите, пожалуйста, в чем может быть проблема. 
PM MAIL   Вверх
avvo
Дата 10.11.2007, 16:24 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Шустрый
*


Профиль
Группа: Участник
Сообщений: 60
Регистрация: 11.9.2007

Репутация: 2
Всего: 4



Скорее всего просто не запущен экземпляр оракл. Или не открыта база данных.
Надо проверить работает ли в винде сервис Oracle<имя экземпляра>.
Вообще все процессы начинающиеся на Oracle должны работать.

Или можно Ctrl-Alt-Del запустить диспетчер задач и посмотреть есть там процесс Oracle.
И если есть, то сколько он скушал памяти. Если памяти мало (<10-20 Mb) значит сервис запущен, а экземпляр нет.
Надо сделать startup и немного подождать.
Если не запустится или опять упадет, надо смотреть логи.
PM MAIL   Вверх
Lingrin
Дата 14.11.2007, 00:03 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Новичок



Профиль
Группа: Участник
Сообщений: 2
Регистрация: 10.11.2007

Репутация: нет
Всего: нет



avvo, спасибо за ответ!
 Действительно, процесс занимал мало памяти оттого, что криво стартовал. А это произошло потому, чтоя после установки патча не проапдейтила базу с помощью Database Assistance (или какой-то спецовой оракловой тулзовины). В alert.log так и было написано=) Ко всему прочему, после установки патча странно изменился tnslistener, но это уже совсем другая история.
PM MAIL   Вверх
  
Ответ в темуСоздание новой темы Создание опроса
Правила форума "Oracle"
Zloxa
LSD

Данный раздел предназначен для обсуждения проблем с Oracle Database, другие продукты Oracle здесь не обсуждаются. Просьба при создании темы, придерживаться следующих правил:

  • при создании темы давайте ей осмысленное название, описывающее суть проблемы
  • указывайте используемую версию базы, способ соединения и язык программирования
  • при ошибках обязательно приводите код ошибки и сообщение сервера
  • приводите код в котором возникла ошибка, по возможности дайте тестовый пример демонстрирующий ошибку
  • при вставке кода используйте соответсвующие теги: [code=sql] [/code] для подсветки SQL и PL/SQL кода, [code=java] [/code] - для Java, и т.д.

  • документация по Oracle: 9i, 10g, 11g
  • книги по Oracle можно поискать здесь
  • действия модераторов можно обсудить здесь

Если Вам понравилась атмосфера форума, заходите к нам чаще! С уважением, Zloxa, LSD.

 
0 Пользователей читают эту тему (0 Гостей и 0 Скрытых Пользователей)
0 Пользователей:
« Предыдущая тема | Oracle | Следующая тема »


 




[ Время генерации скрипта: 0.0391 ]   [ Использовано запросов: 22 ]   [ GZIP включён ]


Реклама на сайте     Информационное спонсорство

 
По вопросам размещения рекламы пишите на vladimir(sobaka)vingrad.ru
Отказ от ответственности     Powered by Invision Power Board(R) 1.3 © 2003  IPS, Inc.