![]() |
|
Модераторы: skyboy |
![]()
|
|
| Firebird |
|
|||
|
Шустрый ![]() Профиль Группа: Участник Сообщений: 139 Регистрация: 30.3.2007 Репутация: нет Всего: нет |
Привет!
Есть MySQL версии 5.0.45, установлен на сервере. Клиенты не могут соединиться, выдается ошибка ERROR 2003: Can not connect to MySQL Server on 'IP' (10060) Это сообщение отредактировал(а) Firebird - 31.1.2008, 07:59 |
|||
|
||||
| admsasha |
|
|||
|
Опытный ![]() ![]() Профиль Группа: Участник Сообщений: 763 Регистрация: 28.1.2005 Репутация: нет Всего: 6 |
причин много...
1. включен skip-networking 2. закрыт firewall`ом 3. Сервер не запущен и т.д. |
|||
|
||||
| Firebird |
|
|||
|
Шустрый ![]() Профиль Группа: Участник Сообщений: 139 Регистрация: 30.3.2007 Репутация: нет Всего: нет |
Вообщем помоему брандмауэр блокировал. Отключил брандмауэр на сервере и на клиентских машинах, соединение выполнилось. Да есть еще один момент. По умолчанию на сервере нет пользователя, для которого разрешен доступ не с локального, а с удаленного компьютера. По этому нужно его создать. Если соединение с сервером выполнилось, но нет доступа для пользователя, то выйдет уже друга ошибка:
Access denied for user... Чтобы создать пользователя для доступа с любого удаленного компьютера, необходимо при создании или редактировании пользователя указать парметр host = % |
|||
|
||||
![]()
|
| 0 Пользователей читают эту тему (0 Гостей и 0 Скрытых Пользователей) | |
| 0 Пользователей: | |
| « Предыдущая тема | MySQL | Следующая тема » |
|
|
По вопросам размещения рекламы пишите на vladimir(sobaka)vingrad.ru
Отказ от ответственности Powered by Invision Power Board(R) 1.3 © 2003 IPS, Inc. |