![]() |
|
Модераторы: skyboy |
![]()
|
|
| gordvm |
|
|||
|
Новичок Профиль Группа: Участник Сообщений: 2 Регистрация: 18.5.2008 Репутация: нет Всего: нет |
Доброе время суток... Видел что эта тему существует, но суть вопроса другая...
У меня есть бесконечный цикл и по запросу я цепляюсь к базе, выполнив необходимые действия, отрубаюсь... Так вот при повторном соединении вылетает ошибка MySQL server has gone away. Перезапустив скрипт, снова один раз конектится и все... Может кто сталкивался с такой проблемкой? |
|||
|
||||
| skyboy |
|
|||
|
неОпытный ![]() ![]() ![]() ![]() Профиль Группа: Модератор Сообщений: 9820 Регистрация: 18.5.2006 Где: Днепропетровск Репутация: 41 Всего: 260 |
вот тебе описание возможных причин:
http://dev.mysql.com/doc/refman/5.0/en/gone-away.html как по мне, при том, что код ты не привел, самым вероятным мне кажется:
Сам признался, что закрываешь соединение. Видимо, подключение/открытие соединение у тебя только при запуске скрипта. А после отключения заново не подключаешься... |
|||
|
||||
| gordvm |
|
|||
|
Новичок Профиль Группа: Участник Сообщений: 2 Регистрация: 18.5.2008 Репутация: нет Всего: нет |
забыл добавить, что на локалке все работает...
|
|||
|
||||
| skyboy |
|
|||
|
неОпытный ![]() ![]() ![]() ![]() Профиль Группа: Модератор Сообщений: 9820 Регистрация: 18.5.2006 Где: Днепропетровск Репутация: 41 Всего: 260 |
забыл добавить, что проверил все указанные в мануале причины появления данного сообщения об ошибке. что все учтено, но все равно не работает.
забыл привести исходный код, вычистив его от всего, что не относится к работе с БД. Добавлено через 18 секунд забыл указать версию СУБД. |
|||
|
||||
![]()
|
| 0 Пользователей читают эту тему (0 Гостей и 0 Скрытых Пользователей) | |
| 0 Пользователей: | |
| « Предыдущая тема | MySQL | Следующая тема » |
|
|
По вопросам размещения рекламы пишите на vladimir(sobaka)vingrad.ru
Отказ от ответственности Powered by Invision Power Board(R) 1.3 © 2003 IPS, Inc. |