Модераторы: skyboy
  

Поиск:

Ответ в темуСоздание новой темы Создание опроса
> ошибка: MySQL server has gone away, Соединение с базой при бесконечном цикле 
:(
    Опции темы
gordvm
Дата 18.5.2008, 23:00 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Новичок



Профиль
Группа: Участник
Сообщений: 2
Регистрация: 18.5.2008

Репутация: нет
Всего: нет



Доброе время суток... Видел что эта тему существует, но суть вопроса другая...

У меня есть бесконечный цикл и по запросу я цепляюсь к базе, выполнив необходимые действия, отрубаюсь... Так вот при повторном соединении вылетает ошибка  MySQL server has gone away. 
Перезапустив скрипт, снова один раз конектится и все...
Может кто сталкивался с такой проблемкой?

PM MAIL   Вверх
skyboy
Дата 18.5.2008, 23:18 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


неОпытный
****


Профиль
Группа: Модератор
Сообщений: 9820
Регистрация: 18.5.2006
Где: Днепропетровск

Репутация: 41
Всего: 260



вот тебе описание возможных причин:
http://dev.mysql.com/doc/refman/5.0/en/gone-away.html
как по мне, при том, что код ты не привел, самым вероятным мне кажется:
Цитата(dev.mysql.com)

You tried to run a query after closing the connection to the server. This indicates a logic error in the application that should be corrected.

Сам признался, что закрываешь соединение. Видимо, подключение/открытие соединение у тебя только при запуске скрипта. А после отключения заново не подключаешься...
PM MAIL   Вверх
gordvm
Дата 18.5.2008, 23:30 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Новичок



Профиль
Группа: Участник
Сообщений: 2
Регистрация: 18.5.2008

Репутация: нет
Всего: нет



забыл добавить, что на локалке все работает...
PM MAIL   Вверх
skyboy
Дата 18.5.2008, 23:39 (ссылка) |    (голосов:1) Загрузка ... Загрузка ... Быстрая цитата Цитата


неОпытный
****


Профиль
Группа: Модератор
Сообщений: 9820
Регистрация: 18.5.2006
Где: Днепропетровск

Репутация: 41
Всего: 260



забыл добавить, что проверил все указанные в мануале причины появления данного сообщения об ошибке. что все учтено, но все равно не работает.
забыл привести исходный код, вычистив его от всего, что не относится к работе с БД.

Добавлено через 18 секунд
забыл указать версию СУБД.
PM MAIL   Вверх
  
Ответ в темуСоздание новой темы Создание опроса
0 Пользователей читают эту тему (0 Гостей и 0 Скрытых Пользователей)
0 Пользователей:
« Предыдущая тема | MySQL | Следующая тема »


 




[ Время генерации скрипта: 0.0884 ]   [ Использовано запросов: 22 ]   [ GZIP включён ]


Реклама на сайте     Информационное спонсорство

 
По вопросам размещения рекламы пишите на vladimir(sobaka)vingrad.ru
Отказ от ответственности     Powered by Invision Power Board(R) 1.3 © 2003  IPS, Inc.