Модераторы: gambit
  

Поиск:

Ответ в темуСоздание новой темы Создание опроса
> The virtual path maps to another application, Не "видно" MasterPage  
:(
    Опции темы
Leonid1611
Дата 29.8.2008, 11:00 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Новичок



Профиль
Группа: Участник
Сообщений: 19
Регистрация: 2.4.2008

Репутация: нет
Всего: 1



Не получается добавить MasterPage из каталога уровнем выше.
Корневая папка WebPortalNew в ней находится Template.master ей соответствует вирт. каталог IIS WebPortalNew. Есть подкаталог Subdirectory (является приложением IIS), к примеру, он содержит файл default.aspx:

Код

<%@ Page Language="C#" MasterPageFile="../Template.master" AutoEventWireup="true" Codefile="~/default.aspx.cs" Inherits="WebPortal.Fmain"%>                
<asp:Content  runat="server" ID="Content1" ContentPlaceHolderID="ContentPlaceHolder1">
</aspContent>


при запросе к странице в браузере  выдается сообщение:
Код

The virtual path '/WebPortalNew/Template.master' maps to another application, which is not allowed.


А при компиляции такая:
Код

Error    3    It is an error to use a section registered as allowDefinition='MachineToApplication' beyond application level.  This error can be caused by a virtual directory not being configured as an application in IIS.    D:\WebPortal_new\Subdirectory\Web.config    26


В web.config на строке 26  <authentication mode="Windows"/>.

Подскажите как правильно сконфигурировать приложение для использования эталонной страницы из корневого каталога  в подкаталогах.

Спасибо
PM MAIL   Вверх
Idsa
Дата 29.8.2008, 11:45 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Эксперт
****


Профиль
Группа: Участник
Сообщений: 2086
Регистрация: 5.12.2006
Где: Томск

Репутация: 15
Всего: 62



Leonid1611, с такими вопросами - в гугл: http://www.google.ru/search?q=allowDefinit...lient=firefox-a


--------------------
Мой блог: alexidsa.blogspot.com
PM MAIL ICQ   Вверх
Leonid1611
Дата 29.8.2008, 12:49 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Новичок



Профиль
Группа: Участник
Сообщений: 19
Регистрация: 2.4.2008

Репутация: нет
Всего: 1



Спасибо.
 Не по той ошибке искал. Думал надо что то в web.config править оказалось его надо просто удалить из подкаталога.
Т.е. надо все странички конфигурировать в корневом файле web.config?

Теперь компилируется но в запросе браузером выводит ту же ошибку:
Код

The virtual path '/WebPortalNew/Template.master' maps to another application, which is not allowed.


В коде:
Код

<%@ Page Language="C#" MasterPageFile="../Template.master" AutoEventWireup="true" CodeFile="Default.aspx.cs" Inherits="_Default" Title="Untitled Page" %>


Это сообщение отредактировал(а) Leonid1611 - 29.8.2008, 13:10
PM MAIL   Вверх
Leonid1611
Дата 29.8.2008, 13:20 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Новичок



Профиль
Группа: Участник
Сообщений: 19
Регистрация: 2.4.2008

Репутация: нет
Всего: 1



Удалил в IIS приложение для подкаталога, теперь работает.
PM MAIL   Вверх
  
Ответ в темуСоздание новой темы Создание опроса
Прежде чем создать тему, посмотрите сюда:
Любитель
Mymik
mr.DUDA

Используйте теги [code=csharp][/code] для подсветки кода. Используйтe чекбокс "транслит" если у Вас нет русских шрифтов.

Если Вам понравилась атмосфера форума, заходите к нам чаще! С уважением, Любитель, Mymik, mr.DUDA.

 
0 Пользователей читают эту тему (0 Гостей и 0 Скрытых Пользователей)
0 Пользователей:
« Предыдущая тема | Разработка под ASP.NET | Следующая тема »


 




[ Время генерации скрипта: 0.0441 ]   [ Использовано запросов: 22 ]   [ GZIP включён ]


Реклама на сайте     Информационное спонсорство

 
По вопросам размещения рекламы пишите на vladimir(sobaka)vingrad.ru
Отказ от ответственности     Powered by Invision Power Board(R) 1.3 © 2003  IPS, Inc.