Модераторы: powerfox, ZeeLax

Поиск:

Ответ в темуСоздание новой темы Создание опроса
> Проблема с apt-get в Ubuntu 
V
    Опции темы
Aliance
Дата 18.9.2008, 21:07 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


I ♥ <script>
****


Профиль
Группа: Модератор
Сообщений: 6418
Регистрация: 2.8.2004
Где: spb

Репутация: нет
Всего: 137



Доброго всем времени суток!

Давно не запускал Ubuntu на лэп-топе, когда же недавно сделал это, естественно оказалось что есть куча обновлений к её компонентам и даже к ней самой (система предлагает скачать новую версию, 7.04 кажется). Но сделать это не выходит никакими путями. Соединение с интернетом установлено, в браузерах проверил - работает. В терминале пингуется все. Но при нажатии на кнопку обновить или запуске команды apt-get install *** (под rootом естественно) пишет что-то типо такого:
Failed to fetch http://ru.archive.ubuntu.com/***

Что сделать?
PM MAIL WWW ICQ Skype   Вверх
Fin
Дата 18.9.2008, 21:45 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Дракон->Спать();
**


Профиль
Группа: Участник
Сообщений: 687
Регистрация: 4.1.2006

Репутация: нет
Всего: 10



Aliance, Ну первый вопрос, какая текушая версия Ubuntu установлена на компе?
Почитай тут https://help.ubuntu.com/community/UpgradeNotes Как правильно апгрейдится с версии на другую версию.


--------------------
Пролетал мимо.
PM MAIL   Вверх
Imple
Дата 19.9.2008, 06:19 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Эксперт
***


Профиль
Группа: Завсегдатай
Сообщений: 1546
Регистрация: 14.9.2007
Где: Алма-Ата

Репутация: 21
Всего: 87



Дайте нам ваш /etc/apt/sources.list


--------------------
Не шалю, никого не трогаю, починяю сервер.
PM WWW ICQ Skype GTalk Jabber   Вверх
Aliance
Дата 19.9.2008, 14:18 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


I ♥ <script>
****


Профиль
Группа: Модератор
Сообщений: 6418
Регистрация: 2.8.2004
Где: spb

Репутация: нет
Всего: 137



Версия Ubuntu: Ubuntu 6.10 Edgy Eft

Вот мой /etc/apt/sources.list:
Цитата

# deb cdrom:[Ubuntu 6.10 _Edgy Eft_ - Release i386 (20061025)]/ edgy main restricted
deb-src http://archive.ubuntu.com/ubuntu/ edgy main restricted #Added by software-properties

deb http://archive.ubuntu.com/ubuntu/ edgy main restricted
deb-src http://archive.ubuntu.com/ubuntu/ edgy restricted main universe #Added by software-properties

## Major bug fix updates produced after the final release of the
## distribution.
deb http://archive.ubuntu.com/ubuntu/ edgy-updates main restricted
deb-src http://archive.ubuntu.com/ubuntu/ edgy-updates main restricted #Added by software-properties

## Uncomment the following two lines to add software from the 'universe'
## repository.
## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## universe WILL NOT receive any review or updates from the Ubuntu security
## team.
deb http://archive.ubuntu.com/ubuntu/ edgy universe

## Uncomment the following two lines to add software from the 'backports'
## repository.
## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb http://archive.ubuntu.com/ubuntu/ edgy-backports main restricted universe multiverse
deb-src http://archive.ubuntu.com/ubuntu/ edgy-backports main restricted universe multiverse #Added by software-properties

deb http://security.ubuntu.com/ubuntu edgy-security main restricted
deb-src http://security.ubuntu.com/ubuntu edgy-security main restricted #Added by software-properties
# deb http://security.ubuntu.com/ubuntu edgy-security universe
# deb-src http://security.ubuntu.com/ubuntu edgy-security universe
deb http://www.getautomatix.com/apt edgy main

#AUTOMATIX REPOS START

deb http://archive.canonical.com/ubuntu dapper-commercial main

deb http://archive.ubuntu.com/ubuntu/ edgy-updates universe multiverse
deb-src http://archive.ubuntu.com/ubuntu/ edgy-updates universe multiverse #Added by software-properties

deb http://archive.ubuntu.com/ubuntu/ edgy-security main restricted universe multiverse
deb-src http://archive.ubuntu.com/ubuntu/ edgy-security main restricted universe multiverse #Added by software-properties

deb http://archive.ubuntu.com/ubuntu/ edgy multiverse
deb-src http://archive.ubuntu.com/ubuntu/ edgy multiverse #Added by software-properties
#AUTOMATIX REPOS END

PM MAIL WWW ICQ Skype   Вверх
Aliance
Дата 19.9.2008, 15:50 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


I ♥ <script>
****


Профиль
Группа: Модератор
Сообщений: 6418
Регистрация: 2.8.2004
Где: spb

Репутация: нет
Всего: 137



В общем-то я изменил его до такого:
Цитата

# deb cdrom:[Ubuntu 6.10 _Edgy Eft_ - Release i386 (20061025)]/ edgy main restricted
deb-src http://old-releases.ubuntu.com/ubuntu/ edgy main restricted #Added by software-properties

deb http://old-releases.ubuntu.com/ubuntu/ edgy main restricted
deb-src http://old-releases.ubuntu.com/ubuntu/ edgy restricted main universe #Added by software-properties

## Major bug fix updates produced after the final release of the
## distribution.
deb http://old-releases.ubuntu.com/ubuntu/ edgy-updates main restricted
deb-src http://old-releases.ubuntu.com/ubuntu/ edgy-updates main restricted #Added by software-properties

## Uncomment the following two lines to add software from the 'universe'
## repository.
## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## universe WILL NOT receive any review or updates from the Ubuntu security
## team.
deb http://old-releases.ubuntu.com/ubuntu/ edgy universe

## Uncomment the following two lines to add software from the 'backports'
## repository.
## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb http://old-releases.ubuntu.com/ubuntu/ edgy-backports main restricted universe multiverse
deb-src http://old-releases.ubuntu.com/ubuntu/ edgy-backports main restricted universe multiverse #Added by software-properties

deb http://old-releases.ubuntu.com/ubuntu edgy-security main restricted
deb-src http://old-releases.ubuntu.com/ubuntu edgy-security main restricted #Added by software-properties
# deb http://old-releases.ubuntu.com/ubuntu edgy-security universe
# deb-src http://old-releases.ubuntu.com/ubuntu edgy-security universe
# deb http://www.getautomatix.com/apt edgy main

#AUTOMATIX REPOS START

deb http://archive.canonical.com/ubuntu dapper-commercial main

deb http://old-releases.ubuntu.com/ubuntu/ edgy-updates universe multiverse
deb-src http://old-releases.ubuntu.com/ubuntu/ edgy-updates universe multiverse #Added by software-properties

deb http://old-releases.ubuntu.com/ubuntu/ edgy-security main restricted universe multiverse
deb-src http://old-releases.ubuntu.com/ubuntu/ edgy-security main restricted universe multiverse #Added by software-properties

deb http://old-releases.ubuntu.com/ubuntu/ edgy multiverse
deb-src http://old-releases.ubuntu.com/ubuntu/ edgy multiverse #Added by software-properties
#AUTOMATIX REPOS END


Тем самым я избавился от этих ошибок, и загрузил все обновления, кроме одного - mysql-server-5.0 (с версии 5.0.24a-9 до 5.0.24a-9ubuntu2.4)
Когда загружаю его пишет такое:
Цитата

E: /var/cache/apt/archives/mysql-server-5.0_5.0.24a-9ubuntu2.4_i386.deb: подпроцесс новый скрипт, выполняемый pre-removal возвратил код ошибки 1

Как это решить?
PM MAIL WWW ICQ Skype   Вверх
Fin
Дата 19.9.2008, 16:39 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Дракон->Спать();
**


Профиль
Группа: Участник
Сообщений: 687
Регистрация: 4.1.2006

Репутация: нет
Всего: 10



Убить в кеше пакет и попробовать его загрузить с инета заново. У меня такое было пару раз, помогало.

Это сообщение отредактировал(а) Fin - 19.9.2008, 16:40


--------------------
Пролетал мимо.
PM MAIL   Вверх
Aliance
Дата 19.9.2008, 17:41 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


I ♥ <script>
****


Профиль
Группа: Модератор
Сообщений: 6418
Регистрация: 2.8.2004
Где: spb

Репутация: нет
Всего: 137



Как именно? Так?
Код

rm /var/cache/apt/archives/mysql-server-5.0_5.0.24a-9ubuntu2.4_i386.deb


А загрузить как? Через apt-get? А что именно написать в терминале?
PM MAIL WWW ICQ Skype   Вверх
Fin
Дата 19.9.2008, 20:08 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Дракон->Спать();
**


Профиль
Группа: Участник
Сообщений: 687
Регистрация: 4.1.2006

Репутация: нет
Всего: 10



При удалении тебе понадобятся права root, поэтому через sudo
Код

sudo apt-get update
sudo apt-get upgrade

Тогда у тебя полностью система обновится до новых версий текушей ветки.


--------------------
Пролетал мимо.
PM MAIL   Вверх
Aliance
Дата 20.9.2008, 21:30 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


I ♥ <script>
****


Профиль
Группа: Модератор
Сообщений: 6418
Регистрация: 2.8.2004
Где: spb

Репутация: нет
Всего: 137



При выполнении команды:
Код

sudo apt-get update

все прошло удачно, но при выполнении второй:
Код

sudo apt-get upgrade

система вернула следующее:
Цитата

Чтение списков пакетов... Готово
Построение дерева зависимостей       
Чтение информации о состоянии... Готово
Пакеты, которые будут обновлены:
  mysql-server-5.0
обновлено 1, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.
Необходимо скачать 0B/24,9MB архивов.
После распаковки объем занятого дискового пространства возрастёт на 20,5kB.
Хотите продолжить [Д/н]? д
Предварительная настройка пакетов ...
(Чтение базы данных... на данный момент установлено 131378 файлов и каталогов.)
Подготовка к замене пакета mysql-server-5.0 5.0.24a-9 (используется файл .../mysql-server-5.0_5.0.24a-9ubuntu2.4_i386.deb)...
 * Stopping MySQL database server mysqld                                                                               [fail] 
invoke-rc.d: initscript mysql, action "stop" failed.
dpkg: предупреждение -- старый скрипт, выполняемый pre-removal возвратил код ошибки 1
dpkg: попытка использовать скрипт из нового пакета...
 * Stopping MySQL database server mysqld                                                                               [fail] 
invoke-rc.d: initscript mysql, action "stop" failed.
dpkg: не удалось обработать параметр /var/cache/apt/archives/mysql-server-5.0_5.0.24a-9ubuntu2.4_i386.deb (--unpack):
 подпроцесс новый скрипт, выполняемый pre-removal возвратил код ошибки 1
 * Stopping MySQL database server mysqld                                                                               [fail] 
invoke-rc.d: initscript mysql, action "stop" failed.
 * Starting MySQL database server mysqld                                                                               [ ok ] 
/usr/bin/mysqladmin: connect to server at 'localhost' failed
error: 'Access denied for user 'debian-sys-maint'@'localhost' (using password: YES)'
При обработке следующих пакетов произошли ошибки:
 /var/cache/apt/archives/mysql-server-5.0_5.0.24a-9ubuntu2.4_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


Может просто снести сервер БД и заного потом его поставить? Это вариант? Если да - то как правильно реализовать?
PM MAIL WWW ICQ Skype   Вверх
Fin
Дата 21.9.2008, 01:06 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Дракон->Спать();
**


Профиль
Группа: Участник
Сообщений: 687
Регистрация: 4.1.2006

Репутация: нет
Всего: 10



У тебя падает остановка MySQL сервера. 
Попробуй остановить его вручную
Код

 sudo /etc/init.d/mysql stop


Если получится, то установить новый пакет
Код

dpkg -i /var/cache/apt/archives/mysql-server-5.0_5.0.24a-9ubuntu2.4_i386.deb



Это сообщение отредактировал(а) Fin - 21.9.2008, 01:08


--------------------
Пролетал мимо.
PM MAIL   Вверх
Aliance
Дата 21.9.2008, 13:39 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


I ♥ <script>
****


Профиль
Группа: Модератор
Сообщений: 6418
Регистрация: 2.8.2004
Где: spb

Репутация: нет
Всего: 137



Не получается остановить:
Цитата

# etc/init.d/mysql stop
 * Stopping MySQL database server mysqld                                                                               [fail]


Кстати, в ответ на команду статус вот что возвращается:
Цитата

# etc/init.d/mysql status
/usr/bin/mysqladmin: connect to server at 'localhost' failed
error: 'Access denied for user 'debian-sys-maint'@'localhost' (using password: YES)'
 *


Может быть БД чем-то занята, поэтому нельзя ее остановить?
PM MAIL WWW ICQ Skype   Вверх
Vaulter
Дата 21.9.2008, 14:36 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Эксперт
***


Профиль
Группа: Участник Клуба
Сообщений: 1724
Регистрация: 30.12.2002
Где: бункер

Репутация: 3
Всего: 22



Тут я бы проверил пользователей mysql.
Остановил бы его сам. 
Попробовал бы обновится.
Если бы опять НЕ, 
Код

$ sudo apt-get purge mysql-server-5.0

уж тогда уж! что???  smile 


--------------------
PM MAIL WWW ICQ   Вверх
Fin
Дата 21.9.2008, 18:04 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Дракон->Спать();
**


Профиль
Группа: Участник
Сообщений: 687
Регистрация: 4.1.2006

Репутация: нет
Всего: 10



Есть утилита sysv-rc-conf, тут http://ubuntuforums.org/showthread.php?t=89491 есть описание, как ей пользоваться. Установи и запусти ее. Убери полностью с запуска MySQL Демона. Перезапусти систему. И тогда можно будет устанавливать новый пакет.


--------------------
Пролетал мимо.
PM MAIL   Вверх
Aliance
Дата 21.9.2008, 21:27 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


I ♥ <script>
****


Профиль
Группа: Модератор
Сообщений: 6418
Регистрация: 2.8.2004
Где: spb

Репутация: нет
Всего: 137



Удалить не получается тоже :(

Вот что пишет терминал:
Цитата

$ sudo apt-get --purge remove mysql-server-5.0
Чтение списков пакетов... Готово
Построение дерева зависимостей       
Чтение информации о состоянии... Готово
Следующие пакеты были установлены автоматически но более не требуются:
  libnet-daemon-perl libdbi-perl libdbd-mysql-perl mysql-server-5.0 mysql-client-5.0 libplrpc-perl
Используйте команду 'apt-get autoremove' для их удаления.
Пакеты, которые будут УДАЛЕНЫ:
  mysql-server-5.0*
обновлено 0, установлено 0 новых пакетов, для удаления отмечено 1 пакетов, и 0 пакетов не обновлено.
Необходимо скачать 0Б архивов.
После распаковки объем занятого дискового пространства уменьшится на 67,4MB.
Хотите продолжить [Д/н]? Д
(Чтение базы данных... на данный момент установлено 131377 файлов и каталогов.)
Удаляется пакет mysql-server-5.0...
 * Stopping MySQL database server mysqld                                                                               [fail] 
invoke-rc.d: initscript mysql, action "stop" failed.
dpkg: не удалось обработать параметр mysql-server-5.0 (--purge):
 подпроцесс pre-removal script возвратил код ошибки 1
 * Stopping MySQL database server mysqld                                                                               [fail] 
invoke-rc.d: initscript mysql, action "stop" failed.
 * Starting MySQL database server mysqld                                                                               [ ok ] 
/usr/bin/mysqladmin: connect to server at 'localhost' failed
error: 'Access denied for user 'debian-sys-maint'@'localhost' (using password: YES)'
При обработке следующих пакетов произошли ошибки:
 mysql-server-5.0
E: Sub-process /usr/bin/dpkg returned an error code (1)


Это сообщение отредактировал(а) Aliance - 21.9.2008, 21:27
PM MAIL WWW ICQ Skype   Вверх
Aliance
Дата 21.9.2008, 21:52 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


I ♥ <script>
****


Профиль
Группа: Модератор
Сообщений: 6418
Регистрация: 2.8.2004
Где: spb

Репутация: нет
Всего: 137



Цитата(Vaulter @  21.9.2008,  15:36 Найти цитируемый пост)
Тут я бы проверил пользователей mysql.

То есть?
У меня в таблице mysql.user 3 пользователя: localhost@root, имяКомпьютера@root, localhost@имяПользователя (последний с паролем).
Может тут что не так?
PM MAIL WWW ICQ Skype   Вверх
Ответ в темуСоздание новой темы Создание опроса
Правила форума "Linux/UNIX: Oбщие вопросы"
nickless
Imple
nerezus

В тему здесь вопросы общие - не привязанные к определенному ПО или дистрибутиву BSD/Linux/UNIX.
Например вопросы о выборе ОС для определенных задач (но если Вы просто хотите узнать "Какой дистрибутив лучше", то для этого есть Клуб юнуксоидов).
Общие вопросы по shell-программированию тоже лучше задавать здесь.


  • Вопросы мобильной разработки тут
  • Вы должны соблюдать правила форума.
  • Помните: какой вопрос, такой и ответ. Прежде чем задать вопрос прочитайте вот эту статью на форуме CIT.
  • Оскорблять запрещается.
  • Религиозные войны в Религиозных войнах.
  • Общение "просто так" в Клубе юнуксоидов. В отличие от многих других разделов, здесь разрешается сдержанно оффтопить и юморить в тему.

За интересные статьи, находки, решения, программы и просто реальную помощь будут ставиться + в репу).


В данный момент этот раздел модерируют nerezus, nickless, powerfox, pythonwin, Imple и ZeeLax. Если вы хотите помочь нам, пишите в ПМ и мы обсудим.


Спасибо. И use UNIX or die; С уважением, nerezus, nickless, powerfox, pythonwin, Imple, ZeeLax.

 
0 Пользователей читают эту тему (0 Гостей и 0 Скрытых Пользователей)
0 Пользователей:
« Предыдущая тема | *NIX системы: Общие вопросы | Следующая тема »


 




[ Время генерации скрипта: 0.0659 ]   [ Использовано запросов: 22 ]   [ GZIP включён ]


Реклама на сайте     Информационное спонсорство

 
По вопросам размещения рекламы пишите на vladimir(sobaka)vingrad.ru
Отказ от ответственности     Powered by Invision Power Board(R) 1.3 © 2003  IPS, Inc.