![]() |
|
|
![]()
|
|
| Хоббит |
|
|||
|
Эксперт ![]() ![]() ![]() Профиль Группа: Завсегдатай Сообщений: 1263 Регистрация: 6.11.2005 Репутация: нет Всего: 1 |
Падает апач.
Freebsd 7.0 Apache 2.2.9 Php 5.2.6 В логе Segmentation fault (11) В чем причина не знаю. Либо в апаче либо в пхп. Пробывал поставить apache 2.0 с тем же пхп, ошибка та же. Так что наверно не апаче. Версию пхп понижать не пробывал. Пересобирал все порты несколько раз. В сайте сделал так, чтобы при старте и окончании обработки запроса записывалась строчка в файл. Происходит следующее Запрос стартует, обрабатывается, возвращает результат, после процес умирает Segmentation fault. То есть вроде, нормально не завершается Может ошибка с памятью сервера? |
|||
|
||||
| Exaktus |
|
|||
![]() Шустрый ![]() Профиль Группа: Участник Сообщений: 135 Регистрация: 15.4.2007 Репутация: 3 Всего: 4 |
mpm - ?
--------------------
Ничто так не бодрит по утрам, как свежеупавший сервер |
|||
|
||||
| Хоббит |
|
|||
|
Эксперт ![]() ![]() ![]() Профиль Группа: Завсегдатай Сообщений: 1263 Регистрация: 6.11.2005 Репутация: нет Всего: 1 |
mpm prefork
сейчас стоя дефолтовые опции, пробовал их менять в большую сторону, ничего не дало.. сервер не загружен ... 1 запрос в 2 секунды загрузка цп 0.1% памяти еще пару гигов свободных |
|||
|
||||
| Exaktus |
|
|||
![]() Шустрый ![]() Профиль Группа: Участник Сообщений: 135 Регистрация: 15.4.2007 Репутация: 3 Всего: 4 |
Попробуйте register_long_arrays = On
На самом деле так сложно сказать в чем может быть проблема. Брать gdb и в путь... --------------------
Ничто так не бодрит по утрам, как свежеупавший сервер |
|||
|
||||
| Хоббит |
|
|||
|
Эксперт ![]() ![]() ![]() Профиль Группа: Завсегдатай Сообщений: 1263 Регистрация: 6.11.2005 Репутация: нет Всего: 1 |
gdb это дебагер?
а где взять файл, который дебажить? |
|||
|
||||
| Хоббит |
|
|||
|
Эксперт ![]() ![]() ![]() Профиль Группа: Завсегдатай Сообщений: 1263 Регистрация: 6.11.2005 Репутация: нет Всего: 1 |
Помогло downgrade порта php до версии 5.2.1... при переходе на 5.2.2 появляется злосчастная ошибка.
|
|||
|
||||
![]()
|
| 0 Пользователей читают эту тему (0 Гостей и 0 Скрытых Пользователей) | |
| 0 Пользователей: | |
| « Предыдущая тема | Администрирование Web серверов и Web служб | Следующая тема » |
|
|
По вопросам размещения рекламы пишите на vladimir(sobaka)vingrad.ru
Отказ от ответственности Powered by Invision Power Board(R) 1.3 © 2003 IPS, Inc. |