Модераторы: marykone
  

Поиск:

Ответ в темуСоздание новой темы Создание опроса
> Адреса и маски. 
:(
    Опции темы
Orthenner
Дата 23.5.2004, 15:40 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Любитель
*


Профиль
Группа: Участник
Сообщений: 57
Регистрация: 22.5.2004
Где: Мытищи

Репутация: нет
Всего: нет



Значит так, задача такая:
Имеется адрес и маска, например: 62.118.0.0/16
Необходимо проверить, попадает ли в эту сеть адрес, ну например 62.118.0.58.
Не могли бы подсказать алгоритм этой проверки - чем детальнее, тем лучше.
Заранее спасибо.
Orthenner.
PM MAIL ICQ   Вверх
Secandr
Дата 23.5.2004, 15:55 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Связист
****


Профиль
Группа: Экс. модератор
Сообщений: 4043
Регистрация: 3.8.2003
Где: Russia, Volgograd

Репутация: 8
Всего: 39



маска - это способ разделить IP на две области - сеть и адрес машины.
маска - совокупность бит:11111100000

где первые единицы - сеть, последнии нули - компьютер.
насколько я помню 16 - количество еиниц.

Тоесть где стоят 11111 - нужно брать байты из IP, где 0000 - можно ставить любой.

Пример:
IP = 101100111***101(в двоичной форме)
маска=1111111***100 (все 1, кроме последних двух)
тогда диапазон ip:
101100111***100
101100111***111

Для того чтобы определить диапазон нужно перевести IP в двоичную систему, взять первых 16 битов, дополнить остаток нулями(по идеи ip - 4 байта = 32 бита) - в твоём случае 16 нулей, и перевести обратно в десятичную запись. Получим первый IP диапазона

Затем берём первых 16 байт из IP, и добавляем 1 (16 штук) - получаем последний
Пример:
62 =
118=
тогда ip=00111110011101100000000000000000
маска = 11111111111111110000000000000000

тогда диапазон от 00111110011101100000000000000000 до 00111110011101101111111111111111
в десятичной записи:
62.118.0.0
62.118.255.255


--------------------
Мышки плакали, кололись, но продолжали жрать кактусы (с) cisco
PM ICQ AOL   Вверх
Orthenner
Дата 23.5.2004, 16:20 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Любитель
*


Профиль
Группа: Участник
Сообщений: 57
Регистрация: 22.5.2004
Где: Мытищи

Репутация: нет
Всего: нет



Спасибо большое. Теперь разобрался smile.gif.
Т.е. биты адресов, которые попадают в данную сеть - последние (32-маска).
Если маска - 19, то в данную сеть попадает 11111.11111111 адресов или
8191 адресов.
PM MAIL ICQ   Вверх
Secandr
Дата 23.5.2004, 23:47 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Связист
****


Профиль
Группа: Экс. модератор
Сообщений: 4043
Регистрация: 3.8.2003
Где: Russia, Volgograd

Репутация: 8
Всего: 39



Orthenner Я сам разобрался, вспомнить бы ещё, что есть сети класса A,B,C smile.gif


--------------------
Мышки плакали, кололись, но продолжали жрать кактусы (с) cisco
PM ICQ AOL   Вверх
dwr_budr
Дата 4.6.2004, 07:18 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Шустрый
*


Профиль
Группа: Участник
Сообщений: 100
Регистрация: 11.4.2004

Репутация: нет
Всего: 2



Secandr

Дык A, B и C это оч просто smile.gif

Просто псевдонимы сетей разных размерностей
A это ххх.ххх.ххх.ххх/24
B это ххх.ххх.ххх.ххх/16
C это ххх.ххх.ххх.ххх/8
PM MAIL   Вверх
Akina
Дата 4.6.2004, 07:28 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Советчик
****


Профиль
Группа: Модератор
Сообщений: 20581
Регистрация: 8.4.2004
Где: Зеленоград

Репутация: 22
Всего: 454



dwr_budr
Цитата
Просто псевдонимы сетей разных размерностей
A это ххх.ххх.ххх.ххх/24
B это ххх.ххх.ххх.ххх/16
C это ххх.ххх.ххх.ххх/8

Наоборот biggrin.gif
A это ххх.ххх.ххх.ххх/8
B это ххх.ххх.ххх.ххх/16
C это ххх.ххх.ххх.ххх/24

И вообще с учетом того что CIDR теперь стандарт, надо бы забыть о классах.


--------------------
 О(б)суждение моих действий - в соответствующей теме, пожалуйста. Или в РМ. И высшая инстанция - Администрация форума.

PM MAIL WWW ICQ Jabber   Вверх
dwr_budr
Дата 4.6.2004, 08:48 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Шустрый
*


Профиль
Группа: Участник
Сообщений: 100
Регистрация: 11.4.2004

Репутация: нет
Всего: 2



Akina

Блин точно smile.gif
PM MAIL   Вверх
ida
Дата 21.7.2004, 16:35 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


замужем
****


Профиль
Группа: Завсегдатай
Сообщений: 2277
Регистрация: 14.5.2002
Где: Санкт-Петербург

Репутация: нет
Всего: 58



Народ, можно поподробнее о безклассовой междоменной маршрутизации (CIDR)? Насколько я понимаю, в такой записи число после слэша - это количество разрядов, которые предназначены для идентификации хоста внутри сети?... А все остальные разряды перед ними - это адрес сети?...

Akina, а когда CIDR стал стандартом (дай сцылочку на RFC, если знаешь, плиз)?

Это сообщение отредактировал(а) ida - 21.7.2004, 16:38
PM WWW   Вверх
MuToGeN
Дата 23.7.2004, 11:00 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Лесник
****


Профиль
Группа: Модератор
Сообщений: 4379
Регистрация: 15.8.2002
Где: Москва

Репутация: 7
Всего: 32



Число после слеша - это кол-во единиц, если взять маску в двоичном виде.


--------------------
Three pings for the token rings,
Five pings for the UNIX machines,
Hundred pings for the broken links,
One special ping to check them all
Through Simple Network Management Protocol!
PM MAIL ICQ   Вверх
Akina
Дата 23.7.2004, 15:22 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Советчик
****


Профиль
Группа: Модератор
Сообщений: 20581
Регистрация: 8.4.2004
Где: Зеленоград

Репутация: 22
Всего: 454



ida
RFC - не стандарт. Стандарт - STDxxx.
Насчет конкретных документов - http://www.faqs.org/rfcs/index.html
Первый (кажется) документ касательно стандартизации CIDR - это "RFC 1817 - CIDR and Classful Routing". Можешь искать по обратным ссылкам на него.

PS. Кстати, бывают еще и "дырявые" маски... biggrin.gif


--------------------
 О(б)суждение моих действий - в соответствующей теме, пожалуйста. Или в РМ. И высшая инстанция - Администрация форума.

PM MAIL WWW ICQ Jabber   Вверх
ida
Дата 26.7.2004, 14:11 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


замужем
****


Профиль
Группа: Завсегдатай
Сообщений: 2277
Регистрация: 14.5.2002
Где: Санкт-Петербург

Репутация: нет
Всего: 58



Всем спасибо, все нашла, толстые книжки forever. Цитирую, господа:

Цитата
В 1993 году группа IETF приняла стандарт CIDR (Classless Inter-Domain Routing - безклассовая внутридоменная маршрутизация). Данный стандарт (RFC 1519) позволяет использовать сетевую часть адреса любой длины, не обязательно кратной 8 бит. Сетевой адрес стандарта CIDR записывается четырьмя десятичными числами, разделенными точками, например а.б.в.г/д, где д указывает количество разрядов в сетевой части адреса.


А я думала, что после слэша количество разрядов хостовой части адреса. Пэрэпутала.

Это сообщение отредактировал(а) ida - 26.7.2004, 14:14
PM WWW   Вверх
Akina
Дата 26.7.2004, 16:04 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Советчик
****


Профиль
Группа: Модератор
Сообщений: 20581
Регистрация: 8.4.2004
Где: Зеленоград

Репутация: 22
Всего: 454



ida
В принципе все началось с супернеттинга (RFC 1338)...


--------------------
 О(б)суждение моих действий - в соответствующей теме, пожалуйста. Или в РМ. И высшая инстанция - Администрация форума.

PM MAIL WWW ICQ Jabber   Вверх
  
Ответ в темуСоздание новой темы Создание опроса
0 Пользователей читают эту тему (0 Гостей и 0 Скрытых Пользователей)
0 Пользователей:
« Предыдущая тема | Сетевые технологии | Следующая тема »


 




[ Время генерации скрипта: 0.0546 ]   [ Использовано запросов: 21 ]   [ GZIP включён ]


Реклама на сайте     Информационное спонсорство

 
По вопросам размещения рекламы пишите на vladimir(sobaka)vingrad.ru
Отказ от ответственности     Powered by Invision Power Board(R) 1.3 © 2003  IPS, Inc.