Модераторы: powerfox, ZeeLax
  

Поиск:

Ответ в темуСоздание новой темы Создание опроса
> bacula и HP StorageWorks Ultrium 448 
:(
    Опции темы
student80
Дата 19.11.2009, 15:50 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Абучю рускаму язаку
**


Профиль
Группа: Awaiting Authorisation
Сообщений: 504
Регистрация: 18.4.2006

Репутация: 1
Всего: 7



Здравствуйте.
Подключил я к дебиану дынное устройство записи на ленты.
система устройство видит.
Код

$ sudo tapeinfo -f /dev/sg6
Product Type: Tape Drive
Vendor ID: 'HP      '
Product ID: 'Ultrium 2-SCSI  '
Revision: 'S63D'
Attached Changer API: No
SerialNumber: 'HUE0828E2L'
MinBlock: 1
MaxBlock: 16777215
SCSI ID: 3
SCSI LUN: 0
Ready: yes
BufferedMode: yes
Medium Type: Not Loaded
Density Code: 0x42
BlockSize: 0
DataCompEnabled: yes
DataCompCapable: yes
DataDeCompEnabled: yes
CompType: 0x1
DeCompType: 0x1
BOP: yes
Block Position: 0
Partition 0 Remaining Kbytes: 200448
Partition 0 Size in Kbytes: 200448
ActivePartition: 0
EarlyWarningSize: 0
NumPartitions: 0
MaxPartitions: 0

а вот baculs не хочет с ним работать, точнее не видит его. в настройках bacula-sd указал
Код

Device {
Name = DDS-4
Media Type = DDS-4
и т. д.

там еще разные типы устройств есть, но точно не знаю какое нужно выбирать.
и вот что мне выдает btape
Код

Tape block granularity is 1024 bytes.
btape: butil.c:285 Using device: "/dev/sg6" for writing.
19-Ноя 15:49 btape: Fatal Error at device.c:290 because:
dev open failed: dev.c:432 Unable to open device "DDS-4" (/dev/sg6): ERR=Операция не позволяется

19-Ноя 15:49 btape JobId 0: Fatal error: butil.c:194 Cannot open "DDS-4" (/dev/sg6)


как мне правильно указать устройство в файле конфигурации?
PM MAIL   Вверх
bilbobagginz
Дата 19.11.2009, 17:49 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Naughtius Maximus
****


Профиль
Группа: Экс. модератор
Сообщений: 8813
Регистрация: 2.3.2004
Где: Israel

Репутация: 34
Всего: 317



всё классно. 

версии ОС и бакулы - в студию. каждый раз с тобой одно и тоже smile


--------------------
Я ещё не демон. Я только учусь.
PM WWW   Вверх
student80
Дата 24.11.2009, 08:31 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Абучю рускаму язаку
**


Профиль
Группа: Awaiting Authorisation
Сообщений: 504
Регистрация: 18.4.2006

Репутация: 1
Всего: 7



да. вот версии.
Debian 5.0.3
bacula 2.4.4-1

но я уже подключился.
нужно указывать устройство /dev/st0, и тип устройства у меня не DDS-4, а LTO-2
btape подключается и тесты проводит.
так что сейчас читаю, как бакулу правильно настроить.
будут вопросы - напишу.
спасибо!

Это сообщение отредактировал(а) student80 - 24.11.2009, 08:32
PM MAIL   Вверх
bilbobagginz
Дата 24.11.2009, 09:38 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Naughtius Maximus
****


Профиль
Группа: Экс. модератор
Сообщений: 8813
Регистрация: 2.3.2004
Где: Israel

Репутация: 34
Всего: 317



smile
OK


--------------------
Я ещё не демон. Я только учусь.
PM WWW   Вверх
student80
Дата 26.11.2009, 10:03 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Абучю рускаму язаку
**


Профиль
Группа: Awaiting Authorisation
Сообщений: 504
Регистрация: 18.4.2006

Репутация: 1
Всего: 7



А вот и вопрос созрел.
Retention Period
бывают FIle, Job и Volume
запутался я в них.
у меня 4 картриджа для ежедневного бэкапа (вторник, среда, четверг и пятница)
и 4 еженедельных картриджа (по понедельникам)
т. е. максимальный срок хранения данных получается 27 дней

Вот, к примеру, выбираю я схему ротации FileRetentionPeriod=27
значит у меня в каталоге будут храниться данные о бэкапах за 27 дней (еженедельные + ежедневные), но ежедневные актуальны только на прошлую неделю, а в каталоге будут и ежедневные на позапрошлую неделю и позапозапрошлую, а картриджи уже перезаписанные, и не нужно в каталоге хранить ежедневные дольше 7 дней, но еженедельные требую 27 дней. непонятно вобщем.

нужно как-то выбирать VolumeRetentionPeriod
только не пойму, как это правильно записать.
помогите, пожалуйста.
PM MAIL   Вверх
student80
Дата 4.12.2009, 16:19 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Абучю рускаму язаку
**


Профиль
Группа: Awaiting Authorisation
Сообщений: 504
Регистрация: 18.4.2006

Репутация: 1
Всего: 7



ладно. с периодами пока можно подождать. вот такой вопрос тогда.
все настроил, подключил.
запускаю тестовый бэкап.
вот лог
Код

04-Дек 16:15 debian JobId 9: Start Backup JobId 9, Job=daily_debian.2009-12-04_16.15.00_02
04-Дек 16:15 debian JobId 9: Fatal error: Device reservation failed for JobId=9:
04-Дек 16:15 debian JobId 9: Fatal error:
     Storage daemon didn't accept Device "Tape" because:
     3924 Device "Tape" not in SD Device resources.
04-Дек 16:15 debian JobId 9: Error: Bacula debian 3.0.2 (18Jul09): 04-Дек-2009 16:15:02
  Build OS:               i486-pc-linux-gnu debian 5.0.3
  JobId:                  9
  Job:                    daily_debian.2009-12-04_16.15.00_02
  Backup Level:           Full
  Client:                 "debian"
  FileSet:                "debian" 2009-12-04 15:13:00
  Pool:                   "friday" (From Run pool override)
  Catalog:                "MyCatalog" (From Client resource)
  Storage:                "debian" (From Job resource)
  Scheduled time:         04-Дек-2009 16:15:00
  Start time:             04-Дек-2009 16:15:02
  End time:               04-Дек-2009 16:15:02
  Elapsed time:           0 secs
  Priority:               10
  FD Files Written:       0
  SD Files Written:       0
  FD Bytes Written:       0 (0 B)
  SD Bytes Written:       0 (0 B)
  Rate:                   0.0 KB/s
  Software Compression:   None
  VSS:                    no
  Encryption:             no
  Accurate:               no
  Volume name(s):
  Volume Session Id:      3
  Volume Session Time:    1259930982
  Last Volume Bytes:      0 (0 B)
  Non-fatal FD errors:    0
  SD Errors:              0
  FD termination status:
  SD termination status:
  Termination:            *** Backup Error ***

а вот кусок конфига директора
Код

Storage {
    Name = debian
    Address = debian
    SDPort = 9103
    Password = "Password"
    Device = Tape
    Media Type = LTO-2
}

и sd.conf
Код

Device {
    Name = tape
    Archive Device = /dev/st0
    Device Type = Tape
    Media Type = LTO-2
    Autochanger = No
    Automatic Mount = yes
    Always Open = No
    Removable media = Yes
    Random access = No
    Requires Mount = No

вот кусок лога, где и кроется вся ошибка
3924 Device "Tape" not in SD Device resources
в конфиге директора пробовал разные значения ставить у Device=Tape
но ничего не помогает.
В чем ошибка-то?
PM MAIL   Вверх
bilbobagginz
Дата 7.12.2009, 19:29 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Naughtius Maximus
****


Профиль
Группа: Экс. модератор
Сообщений: 8813
Регистрация: 2.3.2004
Где: Israel

Репутация: 34
Всего: 317



думаю проблема может быть из-за того, что Device имеет название "tape",
a в конфигурации указано "Tape" (с большой буквы).



--------------------
Я ещё не демон. Я только учусь.
PM WWW   Вверх
student80
Дата 8.12.2009, 08:06 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Абучю рускаму язаку
**


Профиль
Группа: Awaiting Authorisation
Сообщений: 504
Регистрация: 18.4.2006

Репутация: 1
Всего: 7



точно smile
поправил - ошибка исчезла... зато другая появилась... на fd что-то ругается. но это я сам попробую решить.
вопрос только про retention period остается.
объясните, пожалуйста, как с периоджами обращаться.
PM MAIL   Вверх
student80
Дата 17.12.2009, 12:53 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Абучю рускаму язаку
**


Профиль
Группа: Awaiting Authorisation
Сообщений: 504
Регистрация: 18.4.2006

Репутация: 1
Всего: 7



вот еще неполадка одна.
ставлю запланированный бэкап.
задача бэкапа висит долгое время как Running
на ленту ничего не пишется.
в лог вот чтовыдается
Код

16-Дек 10:30 debian JobId 21: Fatal error: sql_update.c:123 Update failed: affected_rows=0 for UPDATE Job SET JobStatus='R',Level='F',StartTime='2009-12-16 10:30:27',ClientId=1,JobTDate=1260948627,PoolId=3,FileSetId=1 WHERE JobId=21
16-Дек 10:30 debian JobId 21: Fatal error: sql_update.c:123 Update failed: affected_rows=0 for UPDATE Job SET JobStatus='f',Level='F',StartTime='2009-12-16 10:30:27',ClientId=1,JobTDate=1260948627,PoolId=3,FileSetId=1 WHERE JobId=21
16-Дек 10:30 debian JobId 21: Warning: Error updating job record. sql_update.c:196 Update failed: affected_rows=0 for UPDATE Job SET JobStatus='E',EndTime='2009-12-16 10:30:27',ClientId=1,JobBytes=0,ReadBytes=0,JobFiles=0,JobErrors=0,VolSessionId=0,VolSessionTime=0,PoolId=3,FileSetId=1,JobTDate=1260948627,RealEndTime='2009-12-16 10:30:27',PriorJobId=0 WHERE JobId=21
16-Дек 10:30 debian JobId 21: Warning: Error getting Job record for Job report: ERR=sql_get.c:316 No Job found for JobId 21
16-Дек 10:30 debian JobId 21: Error: Bacula debian 3.0.2 (18Jul09): 16-Дек-2009 10:30:27
  Build OS:               i486-pc-linux-gnu debian 5.0.3
  JobId:                  21
  Job:                    daily_debian.2009-12-16_08.57.49_05
  Backup Level:           Full
  Client:                 "debian" 3.0.2 (18Jul09) i486-pc-linux-gnu,debian,5.0.3
  FileSet:                "debian" 2009-12-04 15:13:00
  Pool:                   "wednesday" (From User input)
  Catalog:                "MyCatalog" (From Client resource)
  Storage:                "debian" (From command line)
  Scheduled time:         16-Дек-2009 08:57:30
  Start time:             16-Дек-2009 10:30:27
  End time:               16-Дек-2009 10:30:27
  Elapsed time:           0 secs
  Priority:               10
  FD Files Written:       0
  SD Files Written:       0
  FD Bytes Written:       0 (0 B)
  SD Bytes Written:       0 (0 B)
  Rate:                   0.0 KB/s
  Software Compression:   None
  VSS:                    no
  Encryption:             no
  Accurate:               no
  Volume name(s):
  Volume Session Id:      0
  Volume Session Time:    0
  Last Volume Bytes:      0 (0 B)
  Non-fatal FD errors:    0
  SD Errors:              0
  FD termination status:
  SD termination status:
  Termination:            *** Backup Error ***


что-то с mysql не так?
PM MAIL   Вверх
  
Ответ в темуСоздание новой темы Создание опроса
Правила форума "Linux/UNIX: Администрирование"
ZeeLax
Imple
nerezus
Этот форум предназначен для решения вопросов по администрации *n?x-систем, в частности по настройке сложных сетей и обслуживанию серверного оборудования.

  • Вы должны соблюдать правила форума.
  • Помните: какой вопрос, такой и ответ. Прежде чем задать вопрос прочитайте вот эту статью на форуме CIT.
  • Оскорблять запрещается.
  • Религиозные войны в Религиозных войнах.
  • Общение "просто так" в Клубе юнуксоидов. В отличие от многих других разделов, здесь разрешается сдержанно оффтопить и юморить в тему.

За интересные статьи, находки, решения, программы и просто реальную помощь будут ставиться + в репу).


В данный момент этот раздел модерируют nerezus, nickless, powerfox, pythonwin, Imple и ZeeLax. Если вы хотите помочь нам, пишите в ПМ и мы обсудим.


Спасибо. И use UNIX or die; С уважением, nerezus, nickless, powerfox, pythonwin, Imple, ZeeLax.

 
0 Пользователей читают эту тему (0 Гостей и 0 Скрытых Пользователей)
0 Пользователей:
« Предыдущая тема | Администрирование *NIX систем | Следующая тема »


 




[ Время генерации скрипта: 0.0530 ]   [ Использовано запросов: 22 ]   [ GZIP включён ]


Реклама на сайте     Информационное спонсорство

 
По вопросам размещения рекламы пишите на vladimir(sobaka)vingrad.ru
Отказ от ответственности     Powered by Invision Power Board(R) 1.3 © 2003  IPS, Inc.