Модераторы: LSD
  

Поиск:

Ответ в темуСоздание новой темы Создание опроса
> Перенос БД Oracle 9.2 на другую машину в лок. сети, Не стартует процесс 
V
    Опции темы
Lamya
Дата 19.4.2010, 11:11 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Новичок



Профиль
Группа: Участник
Сообщений: 8
Регистрация: 22.4.2009

Репутация: нет
Всего: нет



Добрый день.

Возможно, кто-то сталкивался с проблемой, описанной ниже.

Необходимо перенести БД на другую машину в той же локальной сети. Версия Oracle 9.2.0.1, на обеих машинах Win 2003 Server. СУБД установлена, перенос осуществлен физическим копированием файлов (по этой статье http://www.sql.ru/forum/actualthread.aspx?tid=240418). Служба создана, сеть настроена, сиды совпадают.

Проблема в следующем: после перезапуска системы не стартует процесс oracle.exe. При попытке соединения выдает ошибку Oracle not available ORA-01034. После ручного startup все работает, но процесса oracle.exe в диспетчере задач все равно нет. На исходной машине процесс запускается автоматически и ошибки нет. Как устранить ошибку копии?
PM MAIL   Вверх
ToshaCh
Дата 19.4.2010, 11:25 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Опытный
**


Профиль
Группа: Участник
Сообщений: 555
Регистрация: 10.11.2005
Где: Москва, РФ

Репутация: 12
Всего: 26



Посмотрите настройки созданной службы в винде. Там, по всей видимости, не поставлена опция автостарта (не помню как оно в винде точно называется).


--------------------
Slackware 12.2 | Linux 2.6.27 | Fluxbox 1.1.1 | Wmii 3 | Opera 9.63 
--
Oracle это не только способ отмывания денег, но и вполне себе преличная база данных.
PM MAIL Jabber   Вверх
Lamya
Дата 19.4.2010, 11:32 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Новичок



Профиль
Группа: Участник
Сообщений: 8
Регистрация: 22.4.2009

Репутация: нет
Всего: нет



Служба находится в автоматическом режиме со строкой d:\oracle\ora92\bin\ORACLE.EXE <сид базы>. Файл alert.log ошибок при запуске не содержит. До ручного запуска базы в него вообще ничего не пишется.
PM MAIL   Вверх
Lamya
Дата 20.4.2010, 09:38 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Новичок



Профиль
Группа: Участник
Сообщений: 8
Регистрация: 22.4.2009

Репутация: нет
Всего: нет



Неожиданно нашлось решение проблемы: автостарт службы Windows был выставлен, а oracle - нет. Нужно проверить в реестре, чтобы параметр ORA_<sid>_AUTOSTART был true и настроить автозапуск через Oracle Administration Assistant: ... -> Databases -> <sid> -> Startup/Stutdown Options -> Start up instance when service is started.
PM MAIL   Вверх
  
Ответ в темуСоздание новой темы Создание опроса
Правила форума "Oracle"
Zloxa
LSD

Данный раздел предназначен для обсуждения проблем с Oracle Database, другие продукты Oracle здесь не обсуждаются. Просьба при создании темы, придерживаться следующих правил:

  • при создании темы давайте ей осмысленное название, описывающее суть проблемы
  • указывайте используемую версию базы, способ соединения и язык программирования
  • при ошибках обязательно приводите код ошибки и сообщение сервера
  • приводите код в котором возникла ошибка, по возможности дайте тестовый пример демонстрирующий ошибку
  • при вставке кода используйте соответсвующие теги: [code=sql] [/code] для подсветки SQL и PL/SQL кода, [code=java] [/code] - для Java, и т.д.

  • документация по Oracle: 9i, 10g, 11g
  • книги по Oracle можно поискать здесь
  • действия модераторов можно обсудить здесь

Если Вам понравилась атмосфера форума, заходите к нам чаще! С уважением, Zloxa, LSD.

 
0 Пользователей читают эту тему (0 Гостей и 0 Скрытых Пользователей)
0 Пользователей:
« Предыдущая тема | Oracle | Следующая тема »


 




[ Время генерации скрипта: 0.0422 ]   [ Использовано запросов: 22 ]   [ GZIP включён ]


Реклама на сайте     Информационное спонсорство

 
По вопросам размещения рекламы пишите на vladimir(sobaka)vingrad.ru
Отказ от ответственности     Powered by Invision Power Board(R) 1.3 © 2003  IPS, Inc.