![]() |
|
Модераторы: Akina |
![]()
|
|
| Hypertonyc |
|
|||
|
Шустрый ![]() Профиль Группа: Участник Сообщений: 68 Регистрация: 19.10.2008 Репутация: нет Всего: нет |
Есть служба, которая при старте подключается к MSSQL. Когда служба стартует вместе с виндой это подключение обламывается с ошибкой:
Login failed for user 'NT AUTHORITY\SYSTEM' Если тупо вставить перед подключением к БД задержку ~15сек, ошибка исчезает. Ну и естественно если тормозить/запускать службу руками — тоже все OK. Зависимость от SQLServer у службы есть. Служба запускается под LocalSystem. Строка подключения: "Data Source=.\SQLEXPRESS;Initial Catalog=dbname;Integrated Security=True;" Явно нужна зависимость еще от чего-то, вот только от чего? |
|||
|
||||
| Hypertonyc |
|
|||
|
Шустрый ![]() Профиль Группа: Участник Сообщений: 68 Регистрация: 19.10.2008 Репутация: нет Всего: нет |
Это лог. Насколько я понял служба пытается подключиться к базе SQLсервера(^^blablaDB) до того как это база "2010-05-22 10:20:32.79 spid19s Starting up database '^^blablaDB'."...можно ли эту базу заставить стартовать раньше? вместе с master...ну или чтонибудь подобное...? P.S. надеюсь понятно что ^^blabla это вымышленная строка...так...для конспирации |
|||
|
||||
| kobra |
|
|||
|
Опытный ![]() ![]() Профиль Группа: Участник Сообщений: 730 Регистрация: 15.6.2005 Где: Грузия, Тбилиси Репутация: 5 Всего: 9 |
при старте упомянутая служба запускается ранше службы SQLServer, со всеми вытекающими.
варианты решения: службе включить повторные запуски в случае останоки. проверять запущен ли SQLServer. |
|||
|
||||
| Hypertonyc |
|
|||
|
Шустрый ![]() Профиль Группа: Участник Сообщений: 68 Регистрация: 19.10.2008 Репутация: нет Всего: нет |
я ж писал тоесть поидее служба ждет когда SQL загрузится...вот только я так понял MSSQL дает знать, что он готов еще до того как загрузит все свои БД. Как это избежать? только перезапуском службы в случае остановки? |
|||
|
||||
| kobra |
|
|||
|
Опытный ![]() ![]() Профиль Группа: Участник Сообщений: 730 Регистрация: 15.6.2005 Где: Грузия, Тбилиси Репутация: 5 Всего: 9 |
перезапуск нужно включить в любом случае, служба может грохнутся и по другим причинам. смысл этой фразы я истолкавал иначе. подобные службы я всегда деляю цикличними, т.е. если контакт не удалос установить, то включается задежка, и попытка повтарается. Это сообщение отредактировал(а) kobra - 23.5.2010, 11:30 |
|||
|
||||
![]()
|
| Правила форума "MS SQL" | |
|
|
Запрещается! Публиковать ссылки и обсуждать взлом чего бы то ни было.
Если Вам понравилась атмосфера форума, заходите к нам чаще! С уважением, Zloxa, Akina. |
| 0 Пользователей читают эту тему (0 Гостей и 0 Скрытых Пользователей) | |
| 0 Пользователей: | |
| « Предыдущая тема | MS SQL Server | Следующая тема » |
|
|
По вопросам размещения рекламы пишите на vladimir(sobaka)vingrad.ru
Отказ от ответственности Powered by Invision Power Board(R) 1.3 © 2003 IPS, Inc. |