Модераторы: powerfox, ZeeLax
  

Поиск:

Ответ в темуСоздание новой темы Создание опроса
> Улучшить работу POSTFIX 
:(
    Опции темы
mihanik
Дата 22.11.2010, 12:00 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


-=Белый Медведь=-
****


Профиль
Группа: Комодератор
Сообщений: 4054
Регистрация: 24.4.2006
Где: г. Тверь

Репутация: 1
Всего: 109



Привет!

Настраиваю тут свой почтовый сервачок. Пытаюсь немного оптимизировать производительность/трафик/спам...
Как-то сбалансированно хочется...

Если у кого-нибудь есть боевой опыт использования Postfix, прошу высказать свои замечания.
Может, я чего-то не учитываю, чего-то не доглядел и т.п.
Короче, хочется получить отзывы, замечания, пожелания. smile

Вот мои конфиги

main.cf

Код

# Максимальный размер почтового ящика 2 Гигабайта
mailbox_size_limit = 2147483648

# Максимальный размер письма 20 Мегабайт
message_size_limit = 20971520

# Все проходящие письма копировать на адрес [email protected]
always_bcc = [email protected]

broken_sasl_auth_clients = yes
smtp_sasl_auth_enable = yes
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
smtpd_sasl_local_domain = $mydestination
smtpd_sasl_path = smtpd
smtpd_sasl_type = cyrus
smtp_sasl_password_maps = hash:/etc/postfix/sasl/sasl_passwd

# Требуем наличие команды HELO/EHLO
smtpd_helo_required = yes

# smtpd_delay_reject - приостановим проверку письма до тех пор, пока не получим хотя бы один адрес получателя.
smtpd_delay_reject = yes

# регулируем степень терпимости Postfix к ошибкам в адресах, указанных в команде MAIL FROM или RCPT TO
strict_rfc821_envelopes = yes

# smtpd_recipient_restrictions - обработаем ограничения на адрес получателя
smtpd_recipient_restrictions =    reject_non_fqdn_sender
                reject_unknown_sender_domain
                reject_invalid_hostname
                reject_non_fqdn_recipient
                reject_unknown_recipient_domain
                reject_unauth_pipelining
                permit_mynetworks
                permit_sasl_authenticated
                reject_unauth_destination
                check_helo_access pcre:/etc/postfix/helo_checks.pcre
                reject_rbl_client cbl.abuseat.org
                reject_rbl_client sbl.spamhaus.org
                reject_rbl_client xbl.spamhaus.org
                reject_rbl_client opm.blitzed.org
                reject_rbl_client dnsbl.njabl.org
                reject_unverified_sender

header_checks = pcre:/etc/postfix/header_checks.pcre


header_checks = pcre:/etc/postfix/header_checks.pcre - там анализ на спам
check_helo_access pcre:/etc/postfix/helo_checks.pcre - там отвергаются почтовые системы, которые представляются как localhost, MyLocalIpAddress и т.п...




--------------------
Программистами не рождаются, - это родовая травма...
user posted imageuser posted image
PM MAIL WWW ICQ   Вверх
mihanik
Дата 23.11.2010, 23:41 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


-=Белый Медведь=-
****


Профиль
Группа: Комодератор
Сообщений: 4054
Регистрация: 24.4.2006
Где: г. Тверь

Репутация: 1
Всего: 109



Пришлось отказаться от параметра
Цитата(mihanik @  22.11.2010,  12:00 Найти цитируемый пост)
                reject_unverified_sender


А знаете причину?  smile 
Письма от Майкрософтовских специалистов стали отвергаться моим сервером.  smile 
Double-Bonce проверку сервера Майкрософта не выдерживают...  smile  smile 


--------------------
Программистами не рождаются, - это родовая травма...
user posted imageuser posted image
PM MAIL WWW ICQ   Вверх
mihanik
Дата 6.12.2010, 22:58 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


-=Белый Медведь=-
****


Профиль
Группа: Комодератор
Сообщений: 4054
Регистрация: 24.4.2006
Где: г. Тверь

Репутация: 1
Всего: 109



Обкурился манами.
Вывел вполне работоспособный конфиг (очевидную часть конфига не привожу)

Код

# Максимальный размер почтового ящика 2 Гигабайта
mailbox_size_limit = 2147483648

# Максимальный размер письма 20 Мегабайт
message_size_limit = 20971520

# Все проходящие письма копировать на адрес [email protected]
always_bcc = [email protected]

broken_sasl_auth_clients = yes
smtp_sasl_auth_enable = yes
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
smtpd_sasl_local_domain = $mydestination
smtpd_sasl_path = smtpd
smtpd_sasl_type = cyrus
smtp_sasl_password_maps = hash:/etc/postfix/sasl/sasl_passwd

# Требуем наличие команды HELO/EHLO
smtpd_helo_required = yes

# smtpd_delay_reject - приостановим проверку письма до тех пор, пока не получим хотя бы один адрес получателя.
smtpd_delay_reject = yes

# регулируем степень терпимости Postfix к ошибкам в адресах, указанных в команде MAIL FROM или RCPT TO
strict_rfc821_envelopes = yes

# smtpd_recipient_restrictions - обработаем ограничения на адрес получателя
smtpd_recipient_restrictions =    reject_multi_recipient_bounce
                reject_non_fqdn_sender
                reject_unknown_sender_domain
                reject_invalid_hostname
                reject_non_fqdn_recipient
                reject_unknown_recipient_domain
                reject_unauth_pipelining
                permit_mynetworks
                permit_sasl_authenticated
                reject_unauth_destination
                check_recipient_access hash:/etc/postfix/role_account_exceptions
                check_sender_access hash:/etc/postfix/rhsbl_sender_exceptiions
                check_helo_access pcre:/etc/postfix/helo_checks.pcre
                reject_rbl_client cbl.abuseat.org
                reject_rbl_client sbl.spamhaus.org
                reject_rbl_client xbl.spamhaus.org
                reject_rbl_client opm.blitzed.org
                reject_rbl_client dnsbl.njabl.org
                reject_unverified_sender

header_checks = pcre:/etc/postfix/header_checks.pcre
default_process_limit = 50


Каждый параметр могу обоснованно аргументировать


Это сообщение отредактировал(а) mihanik - 6.12.2010, 22:59


--------------------
Программистами не рождаются, - это родовая травма...
user posted imageuser posted image
PM MAIL WWW ICQ   Вверх
  
Ответ в темуСоздание новой темы Создание опроса
Правила форума "Linux/UNIX: Администрирование"
ZeeLax
Imple
nerezus
Этот форум предназначен для решения вопросов по администрации *n?x-систем, в частности по настройке сложных сетей и обслуживанию серверного оборудования.

  • Вы должны соблюдать правила форума.
  • Помните: какой вопрос, такой и ответ. Прежде чем задать вопрос прочитайте вот эту статью на форуме CIT.
  • Оскорблять запрещается.
  • Религиозные войны в Религиозных войнах.
  • Общение "просто так" в Клубе юнуксоидов. В отличие от многих других разделов, здесь разрешается сдержанно оффтопить и юморить в тему.

За интересные статьи, находки, решения, программы и просто реальную помощь будут ставиться + в репу).


В данный момент этот раздел модерируют nerezus, nickless, powerfox, pythonwin, Imple и ZeeLax. Если вы хотите помочь нам, пишите в ПМ и мы обсудим.


Спасибо. И use UNIX or die; С уважением, nerezus, nickless, powerfox, pythonwin, Imple, ZeeLax.

 
0 Пользователей читают эту тему (0 Гостей и 0 Скрытых Пользователей)
0 Пользователей:
« Предыдущая тема | Администрирование *NIX систем | Следующая тема »


 




[ Время генерации скрипта: 0.0416 ]   [ Использовано запросов: 22 ]   [ GZIP включён ]


Реклама на сайте     Информационное спонсорство

 
По вопросам размещения рекламы пишите на vladimir(sobaka)vingrad.ru
Отказ от ответственности     Powered by Invision Power Board(R) 1.3 © 2003  IPS, Inc.