Модераторы: powerfox, ZeeLax
  

Поиск:

Ответ в темуСоздание новой темы Создание опроса
> NFS удалённо... 
:(
    Опции темы
gloomen1
Дата 18.2.2012, 12:40 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Шустрый
*


Профиль
Группа: Участник
Сообщений: 132
Регистрация: 16.9.2009

Репутация: нет
Всего: нет



Всем доброго дня/вечера



Есть комп с centos5 делаю на нём 
# mount backup:/base/ /home/oracle/base
всё примонтировалось, без проблем в /etc/fstab

backup:/c/base         /home/oracle/base nfs     rw,hard,tcp,nolock,noatime,rsize=32768,wsize=32768,timeo=600    0 0
березагрузил ПК всё опять примонтировалось

# yum list *nfs*
nfs-utils.x86_64                          1:1.0.9-54.el5               installed
nfs-utils-lib.x86_64                      1.0.8-7.6.el5                installed



теперь делаю это в окружении openvz, где у меня Тоже centos5
# ping backup
64 bytes from backup.lan (192.168.10.11): icmp_seq=1 ttl=62 time=2.31 ms
64 bytes from backup.lan (192.168.10.11): icmp_seq=2 ttl=63 time=0.207 ms

# mount backup:/base/ /home/oracle/base
mount: mount to NFS server 'backup' failed: System Error: Connection refused.

# yum list *nfs*
nfs-utils.x86_64                          1:1.0.9-54.el5               installed
nfs-utils-lib.x86_64                      1.0.8-7.6.el5                installed
Available Packages
nfs-utils-lib.i386                        1.0.8-7.6.el5                os
nfs-utils-lib-devel.i386                  1.0.8-7.6.el5                os
nfs-utils-lib-devel.x86_64                1.0.8-7.6.el5                os
nfs4-acl-tools.x86_64                     0.3.3-1.el5                  os
sblim-cmpi-nfsv3.x86_64                   1.1.0-47.el5                 os
sblim-cmpi-nfsv3-test.x86_64              1.1.0-47.el5                 os
sblim-cmpi-nfsv4.x86_64                   1.1.0-47.el5                 os
sblim-cmpi-nfsv4-test.x86_64              1.1.0-47.el5                 os
system-config-nfs.noarch                  1.3.23-1.el5                 os


Может кто подскажет как примонтировать NFS???
и что тогда надо будет прописать в /etc/fstab???

Это сообщение отредактировал(а) gloomen1 - 18.2.2012, 12:43
PM MAIL   Вверх
gloomen1
Дата 19.2.2012, 02:31 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Шустрый
*


Профиль
Группа: Участник
Сообщений: 132
Регистрация: 16.9.2009

Репутация: нет
Всего: нет



В виртуальной машине сделал
vim /etc/export
/home/oracle/base     192.168.10.0/25(rw,sync)

vzctl set 210 --features "nfs:on" --save
vzctl restart 210

права на backup'e все есть.
ошибка осталась преждней
PM MAIL   Вверх
gloomen1
Дата 19.2.2012, 12:09 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Шустрый
*


Профиль
Группа: Участник
Сообщений: 132
Регистрация: 16.9.2009

Репутация: нет
Всего: нет



chkconfig portmap on
chkconfig nfs on
service portmap start
отработали без ошибок
----------------------------------

# service nfs restart
Shutting down NFS mountd: [FAILED]
Shutting down NFS daemon: [FAILED]
Shutting down NFS quotas: [ OK ]
Shutting down NFS services: [ OK ]
Starting NFS services: [ OK ]
Starting NFS quotas: [ OK ]
Starting NFS daemon: [FAILED]

---------------------------------
# showmount -e backup
mount clntudp_create: RPC: Port mapper failure - RPC: Unable to receive

# rpcinfo -p backup
rpcinfo: can't contact portmapper: RPC: Remote system error - Connection refused
---------------------------------
Народ помогите пожалуйста, что за фигня твориться...

PM MAIL   Вверх
gloomen1
Дата 19.2.2012, 13:57 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Шустрый
*


Профиль
Группа: Участник
Сообщений: 132
Регистрация: 16.9.2009

Репутация: нет
Всего: нет



# /etc/init.d/nfs start
Starting NFS services:                                     [  OK  ]
Starting NFS quotas:                                       [  OK  ]
Starting NFS daemon:                                       [FAILED]

# tail -f /var/log/messages
Feb 19 03:21:21 210 avahi-daemon[3190]: Successfully dropped root privileges.
Feb 19 03:21:21 210 avahi-daemon[3190]: avahi-daemon 0.6.16 starting up.
Feb 19 03:21:21 210 avahi-daemon[3190]: WARNING: No NSS support for mDNS detected, consider installing nss-mdns!
Feb 19 03:21:21 210 avahi-daemon[3190]: dbus_bus_get(): Failed to connect to socket /var/run/dbus/system_bus_socket: No such file or directory
Feb 19 03:21:21 210 avahi-daemon[3190]: WARNING: Failed to contact D-Bus daemon.
Feb 19 03:21:21 210 init: no more processes left in this runlevel
Feb 19 03:32:16 210 portmap[3335]: cannot bind udp: Address already in use
Feb 19 03:32:21 210 nfsd[3361]: nfssvc: No such device
Feb 19 03:36:50 210 nfsd[3400]: nfssvc: No such device
Feb 19 03:53:47 210 nfsd[3519]: nfssvc: No such device

Делаю всё по инструкции
http://phpsuxx.blogspot.com/2011/03/nfs-openvz.html
http://phpsuxx.blogspot.com/2009/12/nfs.html
PM MAIL   Вверх
  
Ответ в темуСоздание новой темы Создание опроса
Правила форума "Linux/UNIX: Oбщие вопросы"
nickless
Imple
nerezus

В тему здесь вопросы общие - не привязанные к определенному ПО или дистрибутиву BSD/Linux/UNIX.
Например вопросы о выборе ОС для определенных задач (но если Вы просто хотите узнать "Какой дистрибутив лучше", то для этого есть Клуб юнуксоидов).
Общие вопросы по shell-программированию тоже лучше задавать здесь.


  • Вопросы мобильной разработки тут
  • Вы должны соблюдать правила форума.
  • Помните: какой вопрос, такой и ответ. Прежде чем задать вопрос прочитайте вот эту статью на форуме CIT.
  • Оскорблять запрещается.
  • Религиозные войны в Религиозных войнах.
  • Общение "просто так" в Клубе юнуксоидов. В отличие от многих других разделов, здесь разрешается сдержанно оффтопить и юморить в тему.

За интересные статьи, находки, решения, программы и просто реальную помощь будут ставиться + в репу).


В данный момент этот раздел модерируют nerezus, nickless, powerfox, pythonwin, Imple и ZeeLax. Если вы хотите помочь нам, пишите в ПМ и мы обсудим.


Спасибо. И use UNIX or die; С уважением, nerezus, nickless, powerfox, pythonwin, Imple, ZeeLax.

 
0 Пользователей читают эту тему (0 Гостей и 0 Скрытых Пользователей)
0 Пользователей:
« Предыдущая тема | *NIX системы: Общие вопросы | Следующая тема »


 




[ Время генерации скрипта: 0.0406 ]   [ Использовано запросов: 22 ]   [ GZIP включён ]


Реклама на сайте     Информационное спонсорство

 
По вопросам размещения рекламы пишите на vladimir(sobaka)vingrad.ru
Отказ от ответственности     Powered by Invision Power Board(R) 1.3 © 2003  IPS, Inc.