Добрый день. Собственно проблема. Есть проект, рабочий (на другом компьютере под виндой). Я же не могу его запустить у себя на убунте. Проект билдится вроде бы успешно, кроме вот этого: | Код | SLF4J: Failed to load class "org.slf4j.impl.StaticLoggerBinder". SLF4J: Defaulting to no-operation (NOP) logger implementation SLF4J: See http://www.slf4j.org/codes.html#StaticLoggerBinder for further details.
|
Однако при попытке запуска с еклипса вываливается следующее: | Код | Dec 20, 2013 11:34:27 AM org.apache.catalina.core.AprLifecycleListener init INFO: The APR based Apache Tomcat Native library which allows optimal performance in production environments was not found on the java.library.path: /usr/lib/jvm/jdk1.7.0_17/jre/lib/i386/client:/usr/lib/jvm/jdk1.7.0_17/jre/lib/i386::/usr/java/packages/lib/i386:/lib:/usr/lib Dec 20, 2013 11:34:27 AM org.apache.tomcat.util.digester.SetPropertiesRule begin WARNING: [SetPropertiesRule]{Server/Service/Engine/Host/Context} Setting property 'source' to 'org.eclipse.jst.jee.server:etms-server' did not find a matching property. Dec 20, 2013 11:34:28 AM org.apache.coyote.AbstractProtocol init INFO: Initializing ProtocolHandler ["http-bio-8080"] Dec 20, 2013 11:34:28 AM org.apache.coyote.AbstractProtocol init INFO: Initializing ProtocolHandler ["ajp-bio-8009"] Dec 20, 2013 11:34:28 AM org.apache.catalina.startup.Catalina load INFO: Initialization processed in 2385 ms Dec 20, 2013 11:34:28 AM org.apache.catalina.core.StandardService startInternal INFO: Starting service Catalina Dec 20, 2013 11:34:28 AM org.apache.catalina.core.StandardEngine startInternal INFO: Starting Servlet Engine: Apache Tomcat/7.0.47 Dec 20, 2013 11:34:30 AM org.apache.catalina.core.StandardContext listenerStart SEVERE: Error configuring application listener of class org.springframework.web.context.ContextLoaderListener java.lang.ClassNotFoundException: org.springframework.web.context.ContextLoaderListener at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1702) at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1547) at org.apache.catalina.core.DefaultInstanceManager.loadClass(DefaultInstanceManager.java:532) at org.apache.catalina.core.DefaultInstanceManager.loadClassMaybePrivileged(DefaultInstanceManager.java:514) at org.apache.catalina.core.DefaultInstanceManager.newInstance(DefaultInstanceManager.java:142) at org.apache.catalina.core.StandardContext.listenerStart(StandardContext.java:4854) at org.apache.catalina.core.StandardContext.startInternal(StandardContext.java:5434) at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:150) at org.apache.catalina.core.ContainerBase$StartChild.call(ContainerBase.java:1559) at org.apache.catalina.core.ContainerBase$StartChild.call(ContainerBase.java:1549) at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334) at java.util.concurrent.FutureTask.run(FutureTask.java:166) at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145) at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615) at java.lang.Thread.run(Thread.java:722)
Dec 20, 2013 11:34:30 AM org.apache.catalina.core.StandardContext listenerStart SEVERE: Skipped installing application listeners due to previous error(s) Dec 20, 2013 11:34:30 AM org.apache.catalina.core.StandardContext startInternal SEVERE: Error listenerStart Dec 20, 2013 11:34:30 AM org.apache.catalina.core.StandardContext startInternal SEVERE: Context [/etms-server] startup failed due to previous errors Dec 20, 2013 11:34:30 AM org.apache.catalina.startup.HostConfig deployDirectory INFO: Deploying web application directory /home/apache-tomcat/webapps/host-manager Dec 20, 2013 11:34:30 AM org.apache.catalina.startup.HostConfig deployDirectory INFO: Deploying web application directory /home/apache-tomcat/webapps/manager Dec 20, 2013 11:34:31 AM org.apache.catalina.startup.HostConfig deployDirectory INFO: Deploying web application directory /home/apache-tomcat/webapps/ROOT Dec 20, 2013 11:34:31 AM org.apache.catalina.startup.HostConfig deployDirectory INFO: Deploying web application directory /home/apache-tomcat/webapps/examples Dec 20, 2013 11:34:32 AM org.apache.catalina.core.ApplicationContext log INFO: ContextListener: contextInitialized() Dec 20, 2013 11:34:32 AM org.apache.catalina.core.ApplicationContext log INFO: SessionListener: contextInitialized() Dec 20, 2013 11:34:32 AM org.apache.catalina.core.ApplicationContext log INFO: ContextListener: attributeAdded('org.apache.jasper.compiler.TldLocationsCache', 'org.apache.jasper.compiler.TldLocationsCache@1dad48d') Dec 20, 2013 11:34:32 AM org.apache.catalina.startup.HostConfig deployDirectory INFO: Deploying web application directory /home/apache-tomcat/webapps/docs Dec 20, 2013 11:34:32 AM org.apache.coyote.AbstractProtocol start INFO: Starting ProtocolHandler ["http-bio-8080"] Dec 20, 2013 11:34:32 AM org.apache.coyote.AbstractProtocol start INFO: Starting ProtocolHandler ["ajp-bio-8009"] Dec 20, 2013 11:34:32 AM org.apache.catalina.startup.Catalina start INFO: Server startup in 3965 ms
|
Если добавить в classpath томката, как некоторые советуют, commons-logging.jar и spring-web.jar, то стектрейс меняется, но не в лучшую сторону. | Код | Dec 20, 2013 11:33:27 AM org.apache.catalina.core.AprLifecycleListener init INFO: The APR based Apache Tomcat Native library which allows optimal performance in production environments was not found on the java.library.path: /usr/lib/jvm/jdk1.7.0_17/jre/lib/i386/client:/usr/lib/jvm/jdk1.7.0_17/jre/lib/i386::/usr/java/packages/lib/i386:/lib:/usr/lib Dec 20, 2013 11:33:27 AM org.apache.tomcat.util.digester.SetPropertiesRule begin WARNING: [SetPropertiesRule]{Server/Service/Engine/Host/Context} Setting property 'source' to 'org.eclipse.jst.jee.server:etms-server' did not find a matching property. Dec 20, 2013 11:33:28 AM org.apache.coyote.AbstractProtocol init INFO: Initializing ProtocolHandler ["http-bio-8080"] Dec 20, 2013 11:33:28 AM org.apache.coyote.AbstractProtocol init INFO: Initializing ProtocolHandler ["ajp-bio-8009"] Dec 20, 2013 11:33:28 AM org.apache.catalina.startup.Catalina load INFO: Initialization processed in 1933 ms Dec 20, 2013 11:33:28 AM org.apache.catalina.core.StandardService startInternal INFO: Starting service Catalina Dec 20, 2013 11:33:28 AM org.apache.catalina.core.StandardEngine startInternal INFO: Starting Servlet Engine: Apache Tomcat/7.0.47 Dec 20, 2013 11:33:29 AM org.apache.catalina.core.StandardContext listenerStart SEVERE: Error configuring application listener of class org.springframework.web.context.ContextLoaderListener java.lang.NoClassDefFoundError: javax/servlet/ServletContextListener at java.lang.ClassLoader.findBootstrapClass(Native Method) at java.lang.ClassLoader.findBootstrapClassOrNull(ClassLoader.java:1061) at java.lang.ClassLoader.loadClass(ClassLoader.java:412) at java.lang.ClassLoader.loadClass(ClassLoader.java:410) at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:308) at java.lang.ClassLoader.loadClass(ClassLoader.java:356) at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1617) at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1547) at org.apache.catalina.core.DefaultInstanceManager.loadClass(DefaultInstanceManager.java:532) at org.apache.catalina.core.DefaultInstanceManager.loadClassMaybePrivileged(DefaultInstanceManager.java:514) at org.apache.catalina.core.DefaultInstanceManager.newInstance(DefaultInstanceManager.java:142) at org.apache.catalina.core.StandardContext.listenerStart(StandardContext.java:4854) at org.apache.catalina.core.StandardContext.startInternal(StandardContext.java:5434) at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:150) at org.apache.catalina.core.ContainerBase$StartChild.call(ContainerBase.java:1559) at org.apache.catalina.core.ContainerBase$StartChild.call(ContainerBase.java:1549) at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334) at java.util.concurrent.FutureTask.run(FutureTask.java:166) at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145) at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615) at java.lang.Thread.run(Thread.java:722)
Dec 20, 2013 11:33:29 AM org.apache.catalina.core.StandardContext listenerStart SEVERE: Skipped installing application listeners due to previous error(s) Dec 20, 2013 11:33:29 AM org.apache.catalina.core.StandardContext startInternal SEVERE: Error listenerStart Dec 20, 2013 11:33:30 AM org.apache.catalina.util.SessionIdGenerator createSecureRandom INFO: Creation of SecureRandom instance for session ID generation using [SHA1PRNG] took [1,455] milliseconds. Dec 20, 2013 11:33:30 AM org.apache.catalina.core.StandardContext startInternal SEVERE: Context [/etms-server] startup failed due to previous errors Dec 20, 2013 11:33:30 AM org.apache.catalina.startup.HostConfig deployDirectory INFO: Deploying web application directory /home/apache-tomcat/webapps/host-manager Dec 20, 2013 11:33:31 AM org.apache.catalina.startup.HostConfig deployDirectory INFO: Deploying web application directory /home/apache-tomcat/webapps/manager Dec 20, 2013 11:33:31 AM org.apache.catalina.startup.HostConfig deployDirectory INFO: Deploying web application directory /home/apache-tomcat/webapps/ROOT Dec 20, 2013 11:33:31 AM org.apache.catalina.startup.HostConfig deployDirectory INFO: Deploying web application directory /home/apache-tomcat/webapps/examples Dec 20, 2013 11:33:32 AM org.apache.catalina.core.ApplicationContext log INFO: ContextListener: contextInitialized() Dec 20, 2013 11:33:32 AM org.apache.catalina.core.ApplicationContext log INFO: SessionListener: contextInitialized() Dec 20, 2013 11:33:32 AM org.apache.catalina.core.ApplicationContext log INFO: ContextListener: attributeAdded('org.apache.jasper.compiler.TldLocationsCache', 'org.apache.jasper.compiler.TldLocationsCache@10d0ce5') Dec 20, 2013 11:33:32 AM org.apache.catalina.startup.HostConfig deployDirectory INFO: Deploying web application directory /home/infotouch/apache-tomcat/webapps/docs Dec 20, 2013 11:33:32 AM org.apache.coyote.AbstractProtocol start INFO: Starting ProtocolHandler ["http-bio-8080"] Dec 20, 2013 11:33:32 AM org.apache.coyote.AbstractProtocol start INFO: Starting ProtocolHandler ["ajp-bio-8009"] Dec 20, 2013 11:33:32 AM org.apache.catalina.startup.Catalina start INFO: Server startup in 4859 ms
|
Гугление ничего толком не дало, т.к. большинство ограничиваются советом почистить директорию томката.
|