Модераторы: gambit
  

Поиск:

Ответ в темуСоздание новой темы Создание опроса
> Проблемма с запуском/созданием ASp.NET приложений 
:(
    Опции темы
alir
Дата 1.11.2005, 18:29 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Опытный
**


Профиль
Группа: Участник
Сообщений: 383
Регистрация: 19.3.2005

Репутация: 1
Всего: 4



Поставил новую систему, IIS, VS.NET.
Пытаюсь создать новый asp.net-проект и сразу вылетает ошибка:
Цитата
The Web server reported the following error when attempting to ctreate or open the web project located at the following URL : "http://localhost/web1". HTTP/1.1 500 Internal Server Error


А если попытаться запустить существующий проект, то генерируется следующая страница:
Цитата
Server Application Unavailable
The web application you are attempting to access on this web server is currently unavailable.  Please hit the "Refresh" button in your web browser to retry your request.

Administrator Note: An error message detailing the cause of this specific request failure can be found in the application event log of the web server. Please review this log entry to discover what caused this error to occur.



В чем проблема? Помогите плз!!!
PM MAIL ICQ   Вверх
alir
Дата 1.11.2005, 19:49 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Опытный
**


Профиль
Группа: Участник
Сообщений: 383
Регистрация: 19.3.2005

Репутация: 1
Всего: 4



Минимизировал проблему до следущей:
теперь новые приложения прекрасно создаются и работают, а вот перенесенные со старой системы пока нет.

После запуска такого вылетает страница с ошибкой:
Цитата
Server Error in '/' Application.
--------------------------------------------------------------------------------

Configuration Error
Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: The XML file c:\inetpub\wwwroot\Store\web.config could not be loaded. Access to the path "c:\inetpub\wwwroot\Store\web.config" is denied.

Source Error:


[No relevant source lines]


Source File: c:\inetpub\wwwroot\Store\web.config    Line: 0


В чем теперь дело? Подскажите плз!!!

PM MAIL ICQ   Вверх
Domestic Cat
Дата 2.11.2005, 09:29 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Эксперт
****


Профиль
Группа: Экс. модератор
Сообщений: 5452
Регистрация: 3.5.2004
Где: Dallas, US

Репутация: 1
Всего: 172





--------------------

PM   Вверх
alir
Дата 2.11.2005, 17:55 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Опытный
**


Профиль
Группа: Участник
Сообщений: 383
Регистрация: 19.3.2005

Репутация: 1
Всего: 4



Цитата
The bug report stated: to work around this problem, ensure
that hte accounts under which you may run code have Read
access to the configuration files in the application
hierarchy. After you apply the read permissions, restart
Microsoft Internet Information Server (IIS).


Чего-то не понимаю: ведь мой текущий аккаунт - админ, а asp.net-приложение и так работает через своего юзера. Где ставится разрешение на чтение config-файла? Вроде же и так все по умолчанию стоит. Вообще где это чтение настраивается?

Как решить проблему?
PM MAIL ICQ   Вверх
alir
Дата 2.11.2005, 21:10 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Опытный
**


Профиль
Группа: Участник
Сообщений: 383
Регистрация: 19.3.2005

Репутация: 1
Всего: 4



Тааак...
После перезапуска сервера вылетела новая ошибка:

Цитата
Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: It is an error to use a section registered as allowDefinition='MachineToApplication' beyond application level. This error can be caused by a virtual directory not being configured as an application in IIS.


и вылетает на 46 строчке стандартного файла web.config:
Цитата
<authentication mode="Windows" />


Как это исправить? (эта ошибка по-моему более распространена)

PM MAIL ICQ   Вверх
alir
Дата 7.11.2005, 12:11 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Опытный
**


Профиль
Группа: Участник
Сообщений: 383
Регистрация: 19.3.2005

Репутация: 1
Всего: 4



О! Наконец дошло как исправить:
для любого asp.net приложения, перенесенного с другой винды нужно создать индивидуальные application settings. Делается это очень просто: в свойствах виртуального каталога текущего приложения во вкладке directory создаем эти самы settings'ы.
И все работает!
PM MAIL ICQ   Вверх
  
Ответ в темуСоздание новой темы Создание опроса
Прежде чем создать тему, посмотрите сюда:
Любитель
Mymik
mr.DUDA

Используйте теги [code=csharp][/code] для подсветки кода. Используйтe чекбокс "транслит" если у Вас нет русских шрифтов.

Если Вам понравилась атмосфера форума, заходите к нам чаще! С уважением, Любитель, Mymik, mr.DUDA.

 
0 Пользователей читают эту тему (0 Гостей и 0 Скрытых Пользователей)
0 Пользователей:
« Предыдущая тема | Разработка под ASP.NET | Следующая тема »


 




[ Время генерации скрипта: 0.0454 ]   [ Использовано запросов: 22 ]   [ GZIP включён ]


Реклама на сайте     Информационное спонсорство

 
По вопросам размещения рекламы пишите на vladimir(sobaka)vingrad.ru
Отказ от ответственности     Powered by Invision Power Board(R) 1.3 © 2003  IPS, Inc.