![]() |
|
Модераторы: korob2001, ginnie |
![]()
|
|
| DanP |
|
|||
|
Новичок Профиль Группа: Участник Сообщений: 1 Регистрация: 8.2.2006 Репутация: нет Всего: нет |
Ситуация.
На некотором хостинге работали скрипты, которые пользовали ImageMagick. Работали нормально и без проблем. Вчера перестали работать. Хотя никаких изменений я не вносил. Просто скрипты стали валиться на строке: use Image::Magick; С ошибкой: Can't load '/usr/lib/perl5/vendor_perl/5.8.6/i386-linux-thread-multi/auto/Image/Magick/Magick.so' for module Image::Magick: libkrb5.so.3: failed to map segment from shared object: Cannot allocate memory at /usr/lib/perl5/5.8.6/i386-linux-thread-multi/DynaLoader.pm line 230. at /www/i.pl line 14 Хостер молчит... гад... Даже такой простой скрипт вылетает с той же ошибкой: #!/usr/bin/perl -w use CGI::Carp "fatalsToBrowser"; use CGI qw(:standard); use Time::Local; use Image::Magick; print "Content-type: text/html\n\n"; print "OK<br>"; exit; Если выкинуть строчку use Image::Magick; ...то всё работает. Господа, где грабли? В чём проблема? Заранее благодарен |
|||
|
||||
| korob2001 |
|
|||
![]() Эксперт ![]() ![]() ![]() ![]() Профиль Группа: Комодератор Сообщений: 2871 Регистрация: 29.12.2002 Репутация: 31 Всего: 61 |
Думаю, что хостеры твои удалили Image::Magick, тебе нужно связаться с ними и попросить, что бы они установили его обратно.
Модератор: для вставки кода пользуйся кнопкой КОД -------------------- "Время проходит", - привыкли говорить вы по неверному пониманию. "Время стоит - проходите вы". |
|||
|
||||
![]()
|
| Правила форума "Perl" | |
|
|
Если Вам понравилась атмосфера форума, заходите к нам чаще! С уважением, korob2001, sharq. |
| 0 Пользователей читают эту тему (0 Гостей и 0 Скрытых Пользователей) | |
| 0 Пользователей: | |
| « Предыдущая тема | Perl: Общие вопросы | Следующая тема » |
|
|
По вопросам размещения рекламы пишите на vladimir(sobaka)vingrad.ru
Отказ от ответственности Powered by Invision Power Board(R) 1.3 © 2003 IPS, Inc. |