![]() |
|
Модераторы: skyboy, MoLeX, Aliance, ksnk |
![]()
|
|
| dizel |
|
|||
|
Новичок Профиль Группа: Участник Сообщений: 15 Регистрация: 2.12.2005 Репутация: нет Всего: нет |
Мир вам!
У меня такой трабл: Имеется скрипт регистрации. На домашнем компе стоит apache сервак. В настройке php.ini есть параметр session.save который у меня выглядит так: ;session.save_path = /tmp тоесть его значение "no value" При этом регистрация работает как положено. А вот на хостинге в php.ini записано следующее session.save_path = /tmp и параметр session.save_path соответственно равет /tmp. И вот здесь мой скрипт выдает ошибку You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near ' 1, 0, 0, 0, '2006-03-26 18:51:30', 0, '2006-03-26 18:51:30', В скрипте я пробовал указывать указывать путь для сохранения сессий
Но ничего не получается. Давал полные права доступа к директории /home/dizel/public_html/tmp Но сесии все равно не записываются, а если и срабатывает скрипт нормально то один раз из 20. Подскажите кто-нибудь в чем проблема. Заранее благодарен! |
|||
|
||||
| awers |
|
|||
![]() Эксперт ![]() ![]() ![]() Профиль Группа: Участник Сообщений: 1465 Регистрация: 22.3.2006 Где: Россия, Таганрог Репутация: 21 Всего: 31 |
Причем тут ошибка mysql и сессии
Дай пример кода |
|||
|
||||
| dizel |
|
|||
|
Новичок Профиль Группа: Участник Сообщений: 15 Регистрация: 2.12.2005 Репутация: нет Всего: нет |
Я же говорю, что проблема не в скрипте, он дома работает без проблем. А эта ошибка, которую выдает mysql никак не в синтаксисе написания кода. Код просто слишком большой чтобы его писать, да и он работает 100%. А проблема как я вижу именно в сессиях. Ну эт я так думаю. У меня была подобная ошибка выдаваемая mysql, но тогда была проблема в в том что нужно было register_globals включить. Это сообщение отредактировал(а) dizel - 26.3.2006, 20:25 |
|||
|
||||
| dizel |
|
||||
|
Новичок Профиль Группа: Участник Сообщений: 15 Регистрация: 2.12.2005 Репутация: нет Всего: нет |
Ситуация несколько изменилась.
Я вставил код, перед тем как создается сессия
Все работает замечательно, но когда я прописываю следующее
По какой-то непонятной мне причине скрипт не пашет (новая дериктория существует) |
||||
|
|||||
| Ciber SLasH |
|
|||
![]() Эксперт ![]() ![]() ![]() Профиль Группа: Участник Клуба Сообщений: 1813 Регистрация: 9.11.2004 Где: С.-Петербург Репутация: 3 Всего: 67 |
Попробуй путь написать так: c:\server\Apache2\www\tmp
|
|||
|
||||
| Darhazer |
|
|||
![]() Опытный ![]() ![]() Профиль Группа: Участник Сообщений: 429 Регистрация: 28.9.2005 Где: HellCity (Sofia, Bulgaria) Репутация: 7 Всего: 29 |
А ты уверен, что на сервере и дома одна и тоже версия MySQL-а...
Не нужно показивать вес PHP код, покажи только запроса, на котором делает ошибку -------------------- I'm a wheel, I'm a wheel, I can roll, I can feel But you can't stop me turning 'Cause I'm the sun, I'm the sun, I can move, I can run But you'll never stom me burning |
|||
|
||||
| awers |
|
||||
![]() Эксперт ![]() ![]() ![]() Профиль Группа: Участник Сообщений: 1465 Регистрация: 22.3.2006 Где: Россия, Таганрог Репутация: 21 Всего: 31 |
А ты попробуй ещё в начале скрипта создать массив $arr();
А потом сделай так:
В конце скрипта print_r($arr); И поменяй местами
Вот и посмотришь в чем трабл... |
||||
|
|||||
| dizel |
|
||||
|
Новичок Профиль Группа: Участник Сообщений: 15 Регистрация: 2.12.2005 Репутация: нет Всего: нет |
Так вообще ругается, что мол не правильный путь Добавлено @ 02:41
Версии разные, у меня стоит 4.3.11, а на серваке 4.3.25 |
||||
|
|||||
![]()
|
| Правила форума "PHP" | |
|
|
Новичкам:
Важно:
Внимание:
Если Вам понравилась атмосфера форума, заходите к нам чаще! С уважением, IZ@TOP, skyboy, SamDark, MoLeX, awers. |
| 0 Пользователей читают эту тему (0 Гостей и 0 Скрытых Пользователей) | |
| 0 Пользователей: | |
| « Предыдущая тема | PHP: Общие вопросы | Следующая тема » |
|
|
По вопросам размещения рекламы пишите на vladimir(sobaka)vingrad.ru
Отказ от ответственности Powered by Invision Power Board(R) 1.3 © 2003 IPS, Inc. |