| Версия для печати темы
Нажмите сюда для просмотра этой темы в оригинальном формате |
| Форум программистов > Java tools & IDE's > Sun Java System Application Server и NetBeans |
| Автор: evropa 4.9.2007, 13:44 |
| Здравствуйте. Вопрос от новичка. В NetBeans 5.5 создаю File > New Project > Web > Web Application Мне нужно выполнить приложение под Sun Java System Application Server. SJS Application Server установился (как я понимаю) вместе с установкой всего пакета явы. В папку C:\Sun\AppServer. Я делаю предварительно: 1. Choose Tools > Server Manager from the main window. 2. Click Add Server. Select the server type and give a name to the instance. Then click Next. 3. Specify the server information, the location of the local instance of the application server, and the domain to which you want to deploy. ( кстати, http://localhost:8080/ пишет "Your server is up and running!") и я пытаюсь запустить свое только что созданное веб-приложение HelloWeb (естественно Что не так? Надо как-то настроить-запустить сервер предварительно или что делать? Всем заранее большое спасибо. |
| Автор: Zamuta 4.9.2007, 13:55 | ||
evropa,
Компилируешь при запущенном сервере или остановленном? |
| Автор: evropa 4.9.2007, 14:06 |
| Набираешь http://localhost:8080/ пишет "Your server is up and running!" , как-то надо специально запускать сервер? Компилирую, как есть (очевидно, не зная, что нужно запустить и как запустить) |
| Автор: evropa 4.9.2007, 14:47 |
| Как правильно запустить сервер? |
| Автор: Zamuta 4.9.2007, 15:20 |
| Не знаю как у Sun App Server, думаю, что также, но под томкатом скомпилировать и деплоить приложение при запущенном сервере не получится и судя по твоей ошибке "Deployment error:" , т.е. ошибка разворачивания приложения на сервере происходит по этой причине. Попробуй остановить сервер, сделать build main project, а потом жми F6.... |
| Автор: evropa 4.9.2007, 15:35 |
| Нормально сделал build Но потом...The module has not been deployed. И та же самая ошибка |
| Автор: evropa 5.9.2007, 08:46 | ||
так я так и делаю... (ты ж видишь, у меня проект то называется ХеллоВорлд |
| Автор: powerOn 5.9.2007, 09:26 |
| ну а в лог сервера что нибудь пишется? |
| Автор: evropa 5.9.2007, 09:44 |
| Я прошу прощения за свою глупость в данном случае, но я не знаю как посмотреть лог сервера...... Мне кажется, что я что-то пропускаю в процессе разворачивания проекта. Точно всё так же как в TоmCat, F6 и всё? |
| Автор: powerOn 5.9.2007, 10:09 |
в окне Runtime, в контекстном меню на SJSAS выбери View Server Log. В принципе, да. Но можешь еще Clean and Build Project делать. Это не помещает. |
| Автор: batigoal 5.9.2007, 12:07 |
| Можешь сделать war-файл и попробовать задеполоить его через серверный веб-интерфес, либо через командную строку. |
| Автор: Gugle 7.9.2007, 10:57 |
| Проверь откуда netbeans берет файлы для запуска сервера. Если сервер запускать из самого netbeans-->run, то netbeans создает временную папку для его запуска и должен класть скомпилиные файлы в нее, а НЕ в папку куда был установлен сам сервер (C:\Sun\AppServer по умолчанию). Посмотри внимательно логи запуска сервера из netbeans, он там должен говорить что то типа: Using CATALINA_BASE: C:\Documents and Settings... Using CATALINA_HOME: C:\Sun... Using CATALINA_TMPDIR: C:\Documents and Settings... Соответственно надо проверить эти пути, действительно ли он кладет туда откомпилированные файлы проекта. |