Версия для печати темы
Нажмите сюда для просмотра этой темы в оригинальном формате
Форум программистов > Администрирование Web серверов и Web служб > Странный редирект


Автор: vintyara 9.1.2007, 01:06
Есть у меня машина с реальным ip. На него был повешен доменный имя. Всё работало и работает прекрасно, кроме одной весчи.
Задумал поставить я postfixadmin. Да вот ерунда. Есть там одно место, где нада кликнуть по сцылке, для продолжения конфигурирования.
Ведёт ссылка на:
http://moj_url/postfixadmin/admin
а когда переходит, получается
http://pingvin.home/postfixadmin/admin/

Думаю со скриптом всё в порядке. Что-то у меня не так настроено. Всё, что нашёл похожего, лежит в /etc/hosts. А именно -

# For loopbacking.
#127.0.0.1              localhost
127.0.0.1               pingvin.home
192.168.0.1             pingvin.home pingvin

Пробовал исправлять на

# For loopbacking.
#127.0.0.1              localhost
127.0.0.1               pingvin.home
127.0.0.1               vint.od.ua
192.168.0.1             pingvin.home pingvin
192.168.0.1             vint.od.ua


Эффект тот же. Пробовал

#127.0.0.1               pingvin.home
#192.168.0.1            pingvin.home pingvin

127.0.0.1       vint.od.ua
192.168.0.1     vint.od.ua

при рестарте апача ошибка появляется

[Mon Jan  8 23:35:33 2007] [alert] httpd: Could not determine the server's fully qualified domain name, using 127.0.0.1 for ServerName
/usr/sbin/apachectl start: httpd could not be started

Вобщем понятия не имею почему так. Идеи будут ?


Автор: Mal Hack 9.1.2007, 01:24
moj_url на самом деле что?

Автор: vintyara 9.1.2007, 10:04
Mal Hack, vint.od.ua. Т.е. получается http://vint.od.ua/postfixadmin/admin

Автор: Mal Hack 9.1.2007, 14:41
Цитата(vintyara @  9.1.2007,  01:06 Найти цитируемый пост)
127.0.0.1       vint.od.ua
192.168.0.1     vint.od.ua

Теперь давай вместе подумаем, куда будет отправлен запрос... Ежели это один сервак то смысл делать такой изврат? Домен можно повесить только на один IP, который должен быть соответственно прописан.

Автор: vintyara 9.1.2007, 15:38
Mal Hack, 
домен висит на 194.143.137.48 (мой ip). Соответственно всё вышеописаное закомментировал и прописал

194.143.137.48 vint.od.ua

после чего рестартанул апач. Ошибок во время перестарта апача не возникло, однако проблема осталась та же smile Редиректит на пингвин.хоме....

Добавлено @ 15:42 
Ха... При рестарте ошибок не показал, однако ошибки есть. Апач был остановлен после рестарта. При старте вот что получилось -

root@pingvin:/etc# apachectl restart
/usr/sbin/apachectl restart: httpd restarted
root@pingvin:/etc#
root@pingvin:/etc# apachectl start
[Tue Jan  9 14:41:28 2007] [alert] httpd: Could not determine the server's fully qualified domain name, using 127.0.0.1 for ServerName
/usr/sbin/apachectl start: httpd could not be started

Автор: Mal Hack 9.1.2007, 18:09
Цитата(vintyara @  9.1.2007,  15:38 Найти цитируемый пост)
[Tue Jan  9 14:41:28 2007] [alert] httpd: Could not determine the server's fully qualified domain name, using 127.0.0.1 for ServerName
/usr/sbin/apachectl start: httpd could not be started

Ну так укажи Servername ему перед описанием домена в httpd.conf

Автор: vintyara 9.1.2007, 19:33
Mal Hack, 
гм.. вот такая бага -

в httpd.conf замутил

ServerName www.vint.od.ua

в hosts

127.0.0.1               pingvin.home
192.168.0.1             pingvin.home pingvin

И бага исчезла. При

194.143.137.48 vint.od.ua

Апач не стартует 

root@pingvin:/etc# apachectl start
/usr/sbin/apachectl start: httpd could not be started

Интересно, почему smile Но в любом случае сейчас работает smile Спасибо smile !

Автор: ZeeLax 9.1.2007, 19:54
Цитата(vintyara @  9.1.2007,  22:33 Найти цитируемый пост)
в hosts

127.0.0.1               pingvin.home
192.168.0.1             pingvin.home pingvin

И бага исчезла. При

194.143.137.48 vint.od.ua

Апач не стартует 

А если и то и другое написать?

Автор: Mal Hack 9.1.2007, 20:00
vintyara, покопайся в доках на http://httpd.apache.org

Автор: vintyara 9.1.2007, 20:11
ZeeLax, если и то и то написать - тоже работает smile

Mal Hack, ок smile изучу !

Автор: ZeeLax 9.1.2007, 20:17
vintyara, конечно работает smile Ман, как советовал Mal Hack, изучи обязательно и про /etc/host и вообще DNS обязательно почитай в гугле.

Автор: Mal Hack 9.1.2007, 20:26
vintyara, тебе сюда:
http://httpd.apache.org/docs/2.0/ru/vhosts/
http://httpd.apache.org/docs/2.0/ru/vhosts/ip-based.html
Скажу сразу, я с сетевыми дела не имел и DNS не приходилось настраивать, как и Апач на сервере...

Powered by Invision Power Board (http://www.invisionboard.com)
© Invision Power Services (http://www.invisionpower.com)