![]() |
|
|
![]()
|
|
| vintyara |
|
|||
|
Опытный ![]() ![]() Профиль Группа: Участник Сообщений: 491 Регистрация: 24.3.2005 Где: Ode$$a Репутация: нет Всего: 2 |
Есть у меня машина с реальным ip. На него был повешен доменный имя. Всё работало и работает прекрасно, кроме одной весчи.
Задумал поставить я postfixadmin. Да вот ерунда. Есть там одно место, где нада кликнуть по сцылке, для продолжения конфигурирования. Ведёт ссылка на: http://moj_url/postfixadmin/admin а когда переходит, получается http://pingvin.home/postfixadmin/admin/ Думаю со скриптом всё в порядке. Что-то у меня не так настроено. Всё, что нашёл похожего, лежит в /etc/hosts. А именно - # For loopbacking. #127.0.0.1 localhost 127.0.0.1 pingvin.home 192.168.0.1 pingvin.home pingvin Пробовал исправлять на # For loopbacking. #127.0.0.1 localhost 127.0.0.1 pingvin.home 127.0.0.1 vint.od.ua 192.168.0.1 pingvin.home pingvin 192.168.0.1 vint.od.ua Эффект тот же. Пробовал #127.0.0.1 pingvin.home #192.168.0.1 pingvin.home pingvin 127.0.0.1 vint.od.ua 192.168.0.1 vint.od.ua при рестарте апача ошибка появляется [Mon Jan 8 23:35:33 2007] [alert] httpd: Could not determine the server's fully qualified domain name, using 127.0.0.1 for ServerName /usr/sbin/apachectl start: httpd could not be started Вобщем понятия не имею почему так. Идеи будут ? Это сообщение отредактировал(а) vintyara - 9.1.2007, 01:07 |
|||
|
||||
| Mal Hack |
|
|||
![]() Мудрый... ![]() ![]() ![]() ![]() Профиль Группа: Участник Клуба Сообщений: 9926 Регистрация: 15.2.2004 Репутация: 15 Всего: 261 |
moj_url на самом деле что?
|
|||
|
||||
| vintyara |
|
|||
|
Опытный ![]() ![]() Профиль Группа: Участник Сообщений: 491 Регистрация: 24.3.2005 Где: Ode$$a Репутация: нет Всего: 2 |
Mal Hack, vint.od.ua. Т.е. получается http://vint.od.ua/postfixadmin/admin
|
|||
|
||||
| Mal Hack |
|
|||
![]() Мудрый... ![]() ![]() ![]() ![]() Профиль Группа: Участник Клуба Сообщений: 9926 Регистрация: 15.2.2004 Репутация: 15 Всего: 261 |
||||
|
||||
| vintyara |
|
|||
|
Опытный ![]() ![]() Профиль Группа: Участник Сообщений: 491 Регистрация: 24.3.2005 Где: Ode$$a Репутация: нет Всего: 2 |
Mal Hack,
домен висит на 194.143.137.48 (мой ip). Соответственно всё вышеописаное закомментировал и прописал 194.143.137.48 vint.od.ua после чего рестартанул апач. Ошибок во время перестарта апача не возникло, однако проблема осталась та же Добавлено @ 15:42 Ха... При рестарте ошибок не показал, однако ошибки есть. Апач был остановлен после рестарта. При старте вот что получилось - root@pingvin:/etc# apachectl restart /usr/sbin/apachectl restart: httpd restarted root@pingvin:/etc# root@pingvin:/etc# apachectl start [Tue Jan 9 14:41:28 2007] [alert] httpd: Could not determine the server's fully qualified domain name, using 127.0.0.1 for ServerName /usr/sbin/apachectl start: httpd could not be started |
|||
|
||||
| Mal Hack |
|
|||
![]() Мудрый... ![]() ![]() ![]() ![]() Профиль Группа: Участник Клуба Сообщений: 9926 Регистрация: 15.2.2004 Репутация: 15 Всего: 261 |
||||
|
||||
| vintyara |
|
|||
|
Опытный ![]() ![]() Профиль Группа: Участник Сообщений: 491 Регистрация: 24.3.2005 Где: Ode$$a Репутация: нет Всего: 2 |
Mal Hack,
гм.. вот такая бага - в httpd.conf замутил ServerName www.vint.od.ua в hosts 127.0.0.1 pingvin.home 192.168.0.1 pingvin.home pingvin И бага исчезла. При 194.143.137.48 vint.od.ua Апач не стартует root@pingvin:/etc# apachectl start /usr/sbin/apachectl start: httpd could not be started Интересно, почему |
|||
|
||||
| ZeeLax |
|
|||
![]() Эксперт ![]() ![]() ![]() ![]() Профиль Группа: Модератор Сообщений: 4388 Регистрация: 20.8.2006 Где: Алма-Ата Репутация: 2 Всего: 88 |
А если и то и другое написать? -------------------- Utility is when you have one telephone, luxury is when you have two, opulence is when you have three — and paradise is when you have none. — Doug Larson |
|||
|
||||
| Mal Hack |
|
|||
![]() Мудрый... ![]() ![]() ![]() ![]() Профиль Группа: Участник Клуба Сообщений: 9926 Регистрация: 15.2.2004 Репутация: 15 Всего: 261 |
||||
|
||||
| vintyara |
|
|||
|
Опытный ![]() ![]() Профиль Группа: Участник Сообщений: 491 Регистрация: 24.3.2005 Где: Ode$$a Репутация: нет Всего: 2 |
ZeeLax, если и то и то написать - тоже работает
Mal Hack, ок |
|||
|
||||
| ZeeLax |
|
|||
![]() Эксперт ![]() ![]() ![]() ![]() Профиль Группа: Модератор Сообщений: 4388 Регистрация: 20.8.2006 Где: Алма-Ата Репутация: 2 Всего: 88 |
vintyara, конечно работает
-------------------- Utility is when you have one telephone, luxury is when you have two, opulence is when you have three — and paradise is when you have none. — Doug Larson |
|||
|
||||
| Mal Hack |
|
|||
![]() Мудрый... ![]() ![]() ![]() ![]() Профиль Группа: Участник Клуба Сообщений: 9926 Регистрация: 15.2.2004 Репутация: 15 Всего: 261 |
vintyara, тебе сюда:
http://httpd.apache.org/docs/2.0/ru/vhosts/ http://httpd.apache.org/docs/2.0/ru/vhosts/ip-based.html Скажу сразу, я с сетевыми дела не имел и DNS не приходилось настраивать, как и Апач на сервере... |
|||
|
||||
![]()
|
| 0 Пользователей читают эту тему (0 Гостей и 0 Скрытых Пользователей) | |
| 0 Пользователей: | |
| « Предыдущая тема | Администрирование Web серверов и Web служб | Следующая тема » |
|
|
По вопросам размещения рекламы пишите на vladimir(sobaka)vingrad.ru
Отказ от ответственности Powered by Invision Power Board(R) 1.3 © 2003 IPS, Inc. |