| Версия для печати темы
Нажмите сюда для просмотра этой темы в оригинальном формате |
| Форум программистов > Администрирование Web серверов и Web служб > ошибка в apache |
| Автор: kuzyara 14.6.2007, 11:24 |
| устанавливаю как положено апач, в ie ввожу server (и при установке вводил), а он мне выдает ошибку 403. Сетки нет. - я имел ввиду, что у меня пока сети нет Почему не выдается страница, которая показана в инструкциях по установке? |
| Автор: Сумасшедший 14.6.2007, 11:46 |
| kuzyara, попробуй ввести 127.0.0.1 или localhost Что покажет? |
| Автор: kuzyara 14.6.2007, 12:44 | ||
тоже самое |
| Автор: marykone 14.6.2007, 13:23 |
| а ты вбиваешь в ie c той машины на которой апач поставлен может у тебя в действительности нет сетки |
| Автор: z-END 14.6.2007, 13:27 |
| с каких пор 403 = нет сетки?! 403 = нет прав для просмотра страницы. |
| Автор: kuzyara 14.6.2007, 16:52 | ||
я же говорил, что сеть есчо не сделал, просто хотел попробовать php-сайт сделать, который будет в будующей сетке |
| Автор: mxp100 14.6.2007, 21:39 | ||
| проверь в настройках апача директиву Directory чтобы было например
, где c:/home - это директория где находиться сайт |
| Автор: kuzyara 15.6.2007, 06:00 | ||||
вот это изменил на твое, mxp100, выдает ошибку:
|
| Автор: z-END 15.6.2007, 09:59 |
этож че за адрес такой?! короче ошибка в кривых руках настройщика апача. качай себе денвер и не мучайся |
| Автор: marykone 15.6.2007, 14:00 |
вот с этим не очень то согласен с апачем пусть лучше учиться пользоваться найди строчку listen 0.0.0.0:80 и поставь там 127.0.0.1:80 и вбей в браузере локалхост |
| Автор: mxp100 15.6.2007, 17:58 |
| вообще то он поидее и на 0.0.0.0 должен был запуститься у тебя еще что то висит просто на 80 порту! проверь что у тебя не запущен еще один апач или IIS и изменил ты зря, то лучше оставить без изминений иначе будет нехилая дырка в защите! а мое добавить!!! |
| Автор: kuzyara 16.6.2007, 08:38 |
а вот этого все заработало! Ура! Правда пришлось переустановить апач... ух и намучался я, оказывается при удалении апача остаются некоторые папки с настройками, и если их не удалить, то ошибки остаются, хоть запереустанавливайся! Итак, по порядку:
ах да, чуть не забыл, огромное спасибо mxp100 зы: это ещё не последняя встреча, я ещё пхп устанавливать буду |
| Автор: kuzyara 16.6.2007, 09:04 |
| апач выдает "реквест оперэйщн хэз фэйлд" версии софта: apache_2.2.4-win32-x86-no_ssl.msi php-5.2.3-Win32.zip понял! во и заморочки, для первого апача дллка просто, для второго с двойкой, а для последней 2_2 все, спасибо, тему закрываю |
| Автор: StJaguar 21.6.2009, 14:46 |
| Помогите пожалуйста. Поставил apache_2.2.11-win32-x86-openssl-0.9.8i , запустил в браузере все работает, после поставил php-5.2.9-1-win32-installer запустил браузер все также работал, остановил сервер и выключил. Но через пару минут антивирус находит вирус и удаляет его, пробую запустить снова сервер - не запускается выкидывает ошибку: szAppName : httpd.exe szAppVer : 2.2.11.0 szModName : libapr-1.dll szModVer : 1.3.3.0 offset : 00006d1c Решил переустановить. Снес все что поставил и по новой стал устанавливать apache и в конце установки та же ошибка, и все также сервер не запустить. Все кидает туже ошибку. |
| Автор: StJaguar 5.7.2009, 15:42 |
| винда - XP sp2 в C:\Program Files\Apache Software Foundation\Apache2.2\logs\error пишет следущие: [Sun Jul 05 16:22:12 2009] [warn] pid file C:/Program Files/Apache Software Foundation/Apache2.2/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run? [Sun Jul 05 16:22:12 2009] [notice] Apache/2.2.11 (Win32) configured -- resuming normal operations [Sun Jul 05 16:22:12 2009] [notice] Server built: Dec 10 2008 00:10:06 [Sun Jul 05 16:22:12 2009] [error] (OS 2)Не удается найти указанный файл. : Parent: Could not set child process stdout [Sun Jul 05 16:22:12 2009] [notice] Child 3768: Child process is running [Sun Jul 05 16:22:17 2009] [crit] (OS 109)Канал был закрыт. : Child 3768: Unable to retrieve the ready event from the parent |
| Автор: StJaguar 7.7.2009, 17:35 |
| на сколько понял конфликт был с файлом libapr-1.dll решил проблему только установкой апача другой версии |