Поиск:

Ответ в темуСоздание новой темы Создание опроса
> ошибка в apache, "нет прав для просмотра этой страницы" 
V
    Опции темы
kuzyara
Дата 14.6.2007, 11:24 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Бывалый
*


Профиль
Группа: Участник
Сообщений: 215
Регистрация: 13.11.2006

Репутация: нет
Всего: 1



устанавливаю как положено апач, в ie ввожу server (и при установке вводил), а он мне выдает ошибку 403. Сетки нет. - я имел ввиду, что у меня пока сети нет

Почему не выдается страница, которая показана в инструкциях по установке?

Это сообщение отредактировал(а) kuzyara - 15.6.2007, 06:06
--------------------
подпись
PM MAIL   Вверх
Сумасшедший
Дата 14.6.2007, 11:46 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Чилавек-Каропка
***


Профиль
Группа: Завсегдатай
Сообщений: 1503
Регистрация: 15.8.2004
Где: Москва

Репутация: 13
Всего: 107



kuzyara, попробуй ввести 127.0.0.1 или localhost
Что покажет?


--------------------
Однажды ты спросишь, а я отвечу: "Время ожидания специалиста - 10 минут". Ты бросишь трубку, так и не узнав, что Ваш звонок очень важен для нас!
PM MAIL WWW Jabber   Вверх
kuzyara
Дата 14.6.2007, 12:44 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Бывалый
*


Профиль
Группа: Участник
Сообщений: 215
Регистрация: 13.11.2006

Репутация: нет
Всего: 1



Цитата

Что покажет?


тоже самое
--------------------
подпись
PM MAIL   Вверх
marykone
Дата 14.6.2007, 13:23 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Эксперт
****


Профиль
Группа: Комодератор
Сообщений: 2722
Регистрация: 2.5.2006
Где: Краснодар

Репутация: 10
Всего: 67



Цитата(kuzyara @  14.6.2007,  11:24 Найти цитируемый пост)
403. Сетки нет. 
 

а ты вбиваешь в ie c той машины на которой апач поставлен может у тебя в действительности нет сетки



--------------------
получил ответ, пометь вопрос как решенный (правый верхний угол вашей темы).

PM   Вверх
z-END
Дата 14.6.2007, 13:27 (ссылка) |    (голосов:1) Загрузка ... Загрузка ... Быстрая цитата Цитата


прафесар™
****


Профиль
Группа: Комодератор
Сообщений: 3014
Регистрация: 13.3.2003
Где: Венья, Пиетари

Репутация: 2
Всего: 102



с каких пор 403 = нет сетки?! 
403 = нет прав для просмотра страницы. 


--------------------
Каждый чилавек пасвоему праф...а памоему НЕТ! 

PM WWW ICQ   Вверх
kuzyara
Дата 14.6.2007, 16:52 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Бывалый
*


Профиль
Группа: Участник
Сообщений: 215
Регистрация: 13.11.2006

Репутация: нет
Всего: 1



Цитата

может у тебя в действительности нет сетки

я же говорил, что сеть есчо не сделал, просто хотел попробовать php-сайт сделать, который будет в будующей сетке
--------------------
подпись
PM MAIL   Вверх
mxp100
Дата 14.6.2007, 21:39 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Шустрый
*


Профиль
Группа: Участник
Сообщений: 67
Регистрация: 2.10.2006
Где: Санкт-Петербург

Репутация: нет
Всего: нет



проверь в настройках апача директиву Directory
чтобы было например
Код

<Directory "C:/home">
     Options Indexes FollowSymLinks Includes ExecCGI
     AllowOverride All
    Order allow,deny
    Allow from all
</Directory>

, где c:/home - это директория где находиться сайт
PM MAIL ICQ   Вверх
kuzyara
Дата 15.6.2007, 06:00 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Бывалый
*


Профиль
Группа: Участник
Сообщений: 215
Регистрация: 13.11.2006

Репутация: нет
Всего: 1



Цитата

# First, we configure the "default" to be a very restrictive set of 
# features.  
#
<Directory />
    Options FollowSymLinks
    AllowOverride None
    Order deny,allow
    Deny from all
    Satisfy all
</Directory>


вот это изменил на твое, mxp100, выдает ошибку:
Код

(OS 10048)╬с√ўэю ЁрчЁх°рхЄё  юфэю шёяюы№чютрэшх рфЁхёр ёюъхЄр (яЁюЄюъюы/ёхЄхтющ
рфЁхё/яюЁЄ).  : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
Note the errors or messages above, and press the <ESC> key to exit.  28...


Это сообщение отредактировал(а) kuzyara - 15.6.2007, 09:49
--------------------
подпись
PM MAIL   Вверх
z-END
Дата 15.6.2007, 09:59 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


прафесар™
****


Профиль
Группа: Комодератор
Сообщений: 3014
Регистрация: 13.3.2003
Где: Венья, Пиетари

Репутация: 2
Всего: 102



Цитата(kuzyara @  15.6.2007,  07:00 Найти цитируемый пост)
could not bind to address 0.0.0.0:80

этож че за адрес такой?! 
короче ошибка в кривых руках настройщика апача.
качай себе денвер и не мучайся


--------------------
Каждый чилавек пасвоему праф...а памоему НЕТ! 

PM WWW ICQ   Вверх
marykone
Дата 15.6.2007, 14:00 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Эксперт
****


Профиль
Группа: Комодератор
Сообщений: 2722
Регистрация: 2.5.2006
Где: Краснодар

Репутация: 10
Всего: 67



Цитата(z-END @  15.6.2007,  09:59 Найти цитируемый пост)

качай себе денвер и не мучайся


вот с этим не очень то согласен с апачем пусть лучше учиться пользоваться 


найди строчку listen 0.0.0.0:80

и поставь там 127.0.0.1:80

и вбей в браузере локалхост



--------------------
получил ответ, пометь вопрос как решенный (правый верхний угол вашей темы).

PM   Вверх
mxp100
Дата 15.6.2007, 17:58 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Шустрый
*


Профиль
Группа: Участник
Сообщений: 67
Регистрация: 2.10.2006
Где: Санкт-Петербург

Репутация: нет
Всего: нет



вообще то он поидее и на 0.0.0.0 должен был запуститься
у тебя еще что то висит просто на 80 порту!
проверь что у тебя не запущен еще один апач или IIS
и изменил ты зря, то лучше оставить без изминений иначе будет нехилая дырка в защите!
а мое добавить!!!

Это сообщение отредактировал(а) mxp100 - 15.6.2007, 17:59
PM MAIL ICQ   Вверх
kuzyara
Дата 16.6.2007, 08:38 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Бывалый
*


Профиль
Группа: Участник
Сообщений: 215
Регистрация: 13.11.2006

Репутация: нет
Всего: 1



Цитата(z-END @  15.6.2007,  09:59 Найти цитируемый пост)
ошибка в кривых руках настройщика апача

а вот этого не нада, руки выпрямились, все заработало! Ура! 



Правда пришлось переустановить апач... ух и намучался я, оказывается при удалении апача остаются некоторые папки с настройками, и если их не удалить, то ошибки остаются, хоть запереустанавливайся! smile 

Итак, по порядку:
  • при установке в server information по порядку "в edit'ах" написал "server","server","admin@server"
  • сделал изменения в DocumentRoot :DocumentRoot "C:/www"
  • сделал изменения mxp100:
    <Directory "C:/www">
         Options Indexes FollowSymLinks Includes ExecCGI
         AllowOverride All
        Order allow,deny
        Allow from all
    </Directory>
  • сделал изменения в DirectoryIndex: DirectoryIndex index.htm index.html index.html.var
вроде все, но сначала я руководствовался вот этим

ах да, чуть не забыл, огромное спасибо mxp100
зы: это ещё не последняя встреча, я ещё пхп устанавливать будуsmile)

Это сообщение отредактировал(а) kuzyara - 16.6.2007, 08:40
--------------------
подпись
PM MAIL   Вверх
kuzyara
Дата 16.6.2007, 09:04 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Бывалый
*


Профиль
Группа: Участник
Сообщений: 215
Регистрация: 13.11.2006

Репутация: нет
Всего: 1



 smile  давайте уж добьем и пхп, почему когда я добавляю строчку LoadModule php5_module C:/php/php5apache2.dll
 апач выдает "реквест оперэйщн хэз фэйлд"

версии софта:
apache_2.2.4-win32-x86-no_ssl.msi
php-5.2.3-Win32.zip

понял! во и заморочки, для первого апача дллка просто, для второго с двойкой, а для последней 2_2

все, спасибо, тему закрываю

Это сообщение отредактировал(а) kuzyara - 16.6.2007, 10:40
--------------------
подпись
PM MAIL   Вверх
StJaguar
Дата 21.6.2009, 14:46 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Новичок



Профиль
Группа: Участник
Сообщений: 3
Регистрация: 21.6.2009

Репутация: нет
Всего: нет



Помогите пожалуйста. Поставил apache_2.2.11-win32-x86-openssl-0.9.8i  , запустил в браузере все работает, после поставил php-5.2.9-1-win32-installer  запустил браузер все также работал, остановил сервер и выключил. Но через пару минут антивирус находит вирус и удаляет его, пробую запустить снова сервер - не запускается  выкидывает ошибку:
szAppName : httpd.exe     szAppVer : 2.2.11.0     szModName : libapr-1.dll     
szModVer : 1.3.3.0     offset : 00006d1c    
Решил переустановить. Снес все что поставил и по новой стал устанавливать apache и в конце установки та же ошибка, и все также сервер не запустить. Все кидает туже ошибку.

PM MAIL   Вверх
StJaguar
Дата 5.7.2009, 15:42 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Новичок



Профиль
Группа: Участник
Сообщений: 3
Регистрация: 21.6.2009

Репутация: нет
Всего: нет



винда - XP sp2
в C:\Program Files\Apache Software Foundation\Apache2.2\logs\error пишет следущие:

[Sun Jul 05 16:22:12 2009] [warn] pid file C:/Program Files/Apache Software Foundation/Apache2.2/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Sun Jul 05 16:22:12 2009] [notice] Apache/2.2.11 (Win32) configured -- resuming normal operations
[Sun Jul 05 16:22:12 2009] [notice] Server built: Dec 10 2008 00:10:06
[Sun Jul 05 16:22:12 2009] [error] (OS 2)Не удается найти указанный файл.  : Parent: Could not set child process stdout
[Sun Jul 05 16:22:12 2009] [notice] Child 3768: Child process is running
[Sun Jul 05 16:22:17 2009] [crit] (OS 109)Канал был закрыт.  : Child 3768: Unable to retrieve the ready event from the parent


PM MAIL   Вверх
Ответ в темуСоздание новой темы Создание опроса
0 Пользователей читают эту тему (0 Гостей и 0 Скрытых Пользователей)
0 Пользователей:
« Предыдущая тема | Администрирование Web серверов и Web служб | Следующая тема »


 




[ Время генерации скрипта: 0.0535 ]   [ Использовано запросов: 21 ]   [ GZIP включён ]


Реклама на сайте     Информационное спонсорство

 
По вопросам размещения рекламы пишите на vladimir(sobaka)vingrad.ru
Отказ от ответственности     Powered by Invision Power Board(R) 1.3 © 2003  IPS, Inc.