Версия для печати темы
Нажмите сюда для просмотра этой темы в оригинальном формате
Форум программистов > Базы данных под .NET > Проблемы с подключением к базе данных


Автор: amorphius 8.1.2010, 11:00
Только начал изучать asp.net. Чуть ли не в первую очередь конечно решил изучить работу с базами данных. Задача элементарная - прочесть логин из базы данных стоящей не на локальном сервере. Запрос будет типа "SEL ECT nickname FR OM users WHERE ID=1". Сервер базы данных стоит допустим на сервере mysql.server.com.
Для решения задачи кидаю компонент SqlDataSource, выбираю New Connection, тип базы - other (у меня обычная MySQL), Data provider - .NET Framework Data Provider for SQL Server, нажимаю continue, далее в поле Server name пишу mysql.server.com, и ввожу в Use SQL Authentication свои логин и пароль к базе данных (которые правильные на все 100%), а также указываю имя базы данных, с которой соединяюсь. При нажатии на ОК выскакивает ошибка 
An error has occurred while established a connection to the server. When connection to SQL Server 2005, this failure may be caused by the fact that under the default settings SQL Server does not allow remote connections. (provider: Named Pipes Provider, error: 40- Could not open a connection to SQL Server)
При всем этом пхпмайадмин работает нормально, пробовал конектится к базе также с помощью Navicat - все работает

Автор: ForveAvar 8.1.2010, 13:20
для подключения MySql базы данных нужно скачать и установить mysqlconnect желательно последних версий

кажется я тут качал
http://dev.mysql.com/downloads/connector/net/6.2.html

Автор: amorphius 8.1.2010, 17:42
скачал, установил, но в списке драйверов баз данных ничего нового не появилось...
я не понимаю в какую сторону копать, так бы давно сам нашел решение. Перемудрено как всегда у майкрософта все

Автор: KuMa1104 8.1.2010, 21:46
Цитата(amorphius @  8.1.2010,  11:00 Найти цитируемый пост)
An error has occurred while established a connection to the server. When connection to SQL Server 2005, this failure may be caused by the fact that under the default settings SQL Server does not allow remote connections. (provider: Named Pipes Provider, error: 40- Could not open a connection to SQL Server)


Это исключение очень часто встречается. Вбейте его в гугл и увидете сами.Там очень много уже готовых решений.

Я тоже не очень искушён в этом вопросе.
Но.ИМХО. Это больше имеет отношение к разделу БД а не к ASP

Вы проверте правильность строки подключения.Лично у меня из за этого в приложении вылетало.

Код

DataSourse = "..............................."
 

Автор: ForveAvar 9.1.2010, 00:50
странно...лично у меня после установки MYSQL Connector/net 6.1(тогда еще не было версии 6.2) в списке выбора Datasource появился пункт MYSQL Database и в списке ссылок появился Mysql.Data.MySqlClient и Мysql.Data.Types...

ну можно в принципе попробовать поместить вашу базу в папку допустимо App_data и вручную прописывать connectionstring, но какой вид провайдера тогда туда писать....?

Автор: thomas 9.1.2010, 17:07
amorphius, 
Приветствую.
У MS ничего мудреного нет, там все заточено под MS SQL.
Но если вам так уж приспичило работать с MySQL, то не плохо 
посетить  сайт http://connectionstrings.com/
А там посмотреть http://connectionstrings.com/mysql для MySQL.

Во вторых, ваша ошибка еще в том что, вы пытаетесь подключиться к MySQL через провайдер, проедназначенный для MS SQL.
И как следствие получаете сообщение об ошибке подключения к MS SQL Server 2005.

В вашей ситуации:
либо используем "нормальный" и родной сервер;
либо используем соответствующий провайдер и пишем корректную строку подключения.

Успехов.  smile 

Powered by Invision Power Board (http://www.invisionboard.com)
© Invision Power Services (http://www.invisionpower.com)