Модераторы: gambit
  

Поиск:

Ответ в темуСоздание новой темы Создание опроса
> Проблемы с подключением к базе данных 
:(
    Опции темы
amorphius
Дата 8.1.2010, 11:00 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Шустрый
*


Профиль
Группа: Участник
Сообщений: 58
Регистрация: 4.4.2009

Репутация: нет
Всего: нет



Только начал изучать asp.net. Чуть ли не в первую очередь конечно решил изучить работу с базами данных. Задача элементарная - прочесть логин из базы данных стоящей не на локальном сервере. Запрос будет типа "SEL ECT nickname FR OM users WHERE ID=1". Сервер базы данных стоит допустим на сервере mysql.server.com.
Для решения задачи кидаю компонент SqlDataSource, выбираю New Connection, тип базы - other (у меня обычная MySQL), Data provider - .NET Framework Data Provider for SQL Server, нажимаю continue, далее в поле Server name пишу mysql.server.com, и ввожу в Use SQL Authentication свои логин и пароль к базе данных (которые правильные на все 100%), а также указываю имя базы данных, с которой соединяюсь. При нажатии на ОК выскакивает ошибка 
An error has occurred while established a connection to the server. When connection to SQL Server 2005, this failure may be caused by the fact that under the default settings SQL Server does not allow remote connections. (provider: Named Pipes Provider, error: 40- Could not open a connection to SQL Server)
При всем этом пхпмайадмин работает нормально, пробовал конектится к базе также с помощью Navicat - все работает
PM MAIL   Вверх
ForveAvar
Дата 8.1.2010, 13:20 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Шустрый
*


Профиль
Группа: Участник
Сообщений: 73
Регистрация: 6.8.2009

Репутация: нет
Всего: 1



для подключения MySql базы данных нужно скачать и установить mysqlconnect желательно последних версий

кажется я тут качал
http://dev.mysql.com/downloads/connector/net/6.2.html

Это сообщение отредактировал(а) ForveAvar - 8.1.2010, 13:23
PM MAIL   Вверх
amorphius
Дата 8.1.2010, 17:42 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Шустрый
*


Профиль
Группа: Участник
Сообщений: 58
Регистрация: 4.4.2009

Репутация: нет
Всего: нет



скачал, установил, но в списке драйверов баз данных ничего нового не появилось...
я не понимаю в какую сторону копать, так бы давно сам нашел решение. Перемудрено как всегда у майкрософта все

Это сообщение отредактировал(а) amorphius - 8.1.2010, 17:42
PM MAIL   Вверх
KuMa1104
Дата 8.1.2010, 21:46 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Опытный
**


Профиль
Группа: Участник
Сообщений: 541
Регистрация: 16.4.2009
Где: Ростов-на-Дону

Репутация: 1
Всего: 3



Цитата(amorphius @  8.1.2010,  11:00 Найти цитируемый пост)
An error has occurred while established a connection to the server. When connection to SQL Server 2005, this failure may be caused by the fact that under the default settings SQL Server does not allow remote connections. (provider: Named Pipes Provider, error: 40- Could not open a connection to SQL Server)


Это исключение очень часто встречается. Вбейте его в гугл и увидете сами.Там очень много уже готовых решений.

Я тоже не очень искушён в этом вопросе.
Но.ИМХО. Это больше имеет отношение к разделу БД а не к ASP

Вы проверте правильность строки подключения.Лично у меня из за этого в приложении вылетало.

Код

DataSourse = "..............................."
 


--------------------
Галактика – суровая штука. Чтобы в ней выжить, надо знать, где твое полотенце.

Время - штука относительная... а время обеда - ещё более относительная
PM MAIL   Вверх
ForveAvar
Дата 9.1.2010, 00:50 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Шустрый
*


Профиль
Группа: Участник
Сообщений: 73
Регистрация: 6.8.2009

Репутация: нет
Всего: 1



странно...лично у меня после установки MYSQL Connector/net 6.1(тогда еще не было версии 6.2) в списке выбора Datasource появился пункт MYSQL Database и в списке ссылок появился Mysql.Data.MySqlClient и Мysql.Data.Types...

ну можно в принципе попробовать поместить вашу базу в папку допустимо App_data и вручную прописывать connectionstring, но какой вид провайдера тогда туда писать....?
PM MAIL   Вверх
thomas
Дата 9.1.2010, 17:07 (ссылка) |    (голосов:1) Загрузка ... Загрузка ... Быстрая цитата Цитата


Доцент... почти
***


Профиль
Группа: Завсегдатай
Сообщений: 1385
Регистрация: 3.10.2006
Где: " Сказочное королевство"

Репутация: 35
Всего: 65



amorphius, 
Приветствую.
У MS ничего мудреного нет, там все заточено под MS SQL.
Но если вам так уж приспичило работать с MySQL, то не плохо 
посетить  сайт описывающий строки подключения.
А там посмотреть стриничку для MySQL.

Во вторых, ваша ошибка еще в том что, вы пытаетесь подключиться к MySQL через провайдер, проедназначенный для MS SQL.
И как следствие получаете сообщение об ошибке подключения к MS SQL Server 2005.

В вашей ситуации:
либо используем "нормальный" и родной сервер;
либо используем соответствующий провайдер и пишем корректную строку подключения.

Успехов.  smile 


--------------------
Крепко жму горло, искренне ваш Thomas. (С)vingrad
Некоторые сорта флоры буквально за одно мгновение превращают нас в фауну!
Проблемы негров шерифа не волнуют.
PM MAIL   Вверх
  
Ответ в темуСоздание новой темы Создание опроса
Прежде чем создать тему, посмотрите сюда:
stab
mr.DUDA
Exception

Используйте теги [code=csharp][/code] для подсветки кода. Используйтe чекбокс "транслит" если у Вас нет русских шрифтов.

Если Вам понравилась атмосфера форума, заходите к нам чаще! С уважением, stab, mr.DUDA, Exception.

 
0 Пользователей читают эту тему (0 Гостей и 0 Скрытых Пользователей)
0 Пользователей:
« Предыдущая тема | Базы данных под .NET | Следующая тема »


 




[ Время генерации скрипта: 0.0473 ]   [ Использовано запросов: 22 ]   [ GZIP включён ]


Реклама на сайте     Информационное спонсорство

 
По вопросам размещения рекламы пишите на vladimir(sobaka)vingrad.ru
Отказ от ответственности     Powered by Invision Power Board(R) 1.3 © 2003  IPS, Inc.