![]() |
|
Модераторы: skyboy, MoLeX, Aliance, ksnk |
![]()
|
|
| ruslandlion |
|
|||
|
Шустрый ![]() Профиль Группа: Участник Сообщений: 115 Регистрация: 12.8.2006 Репутация: нет Всего: нет |
Уважаемые программисты, подскажите пожалуйста что мне делать? Дело в том что у меня стоит виртуальный сервер на моей машине Денвер 2, до этого момента он прекрасно работал, и вдруг перестаёт отвечать. Запускаю его (появляеться красное пёрышко в трее),открываю браузер Firefox. ввожу в адресную строку http://localhost/phpmyadmin , в ответ мне выдаётся ошибка "Firefox не может установить соединение с сервером localhost. Попытка соединения не удалась" Заранее спасибо.
|
|||
|
||||
| ruslandlion |
|
|||
|
Шустрый ![]() Профиль Группа: Участник Сообщений: 115 Регистрация: 12.8.2006 Репутация: нет Всего: нет |
Уважаемые программисты, подскажите пожалуйста что мне делать? Дело в том что у меня стоит виртуальный сервер на моей машине Денвер 2, до этого момента он прекрасно работал, и вдруг перестаёт отвечать. Запускаю его (появляеться красное пёрышко в трее),открываю браузер Firefox. ввожу в адресную строку http://localhost/phpmyadmin , в ответ мне выдаётся ошибка "Firefox не может установить соединение с сервером localhost. Попытка соединения не удалась". Заранее спасибо.
|
|||
|
||||
| masp |
|
|||
![]() Новичок Профиль Группа: Участник Сообщений: 34 Регистрация: 22.2.2007 Репутация: нет Всего: 2 |
пропингуй localhost
проверь работает ли апач |
|||
|
||||
| unicross |
|
|||
|
Опытный ![]() ![]() Профиль Группа: Участник Сообщений: 422 Регистрация: 15.6.2008 Репутация: 21 Всего: 53 |
К phpmyadmin ваша проблема никакого отношения не имеет, так же как и к PHP... У вас не запускается Апач. Виной тому скорее всего установленные программы, которые занимают порт 80 или вы пытались редактировать конфигурационные файлы и допустили ошибку. Для проверки занятости порта в командной строке набираем команду:
В списке не должно быть строки с портом 80. Если есть, то Apache не сможет запуститься. Обычно этот порт занимают программы Skype и Web-сервер IIS. Если вы установили Skype: заходим в "Настройки -> Дополнительно -> Соединения" и снимаем флажок "Использовать порты 80 и 443 в качестве входящих альтернатив". P.S. Вы еще и несколько тем создали... Это сообщение отредактировал(а) unicross - 26.9.2009, 15:04 |
|||
|
||||
| ruslandlion |
|
|||
|
Шустрый ![]() Профиль Группа: Участник Сообщений: 115 Регистрация: 12.8.2006 Репутация: нет Всего: нет |
Да пингует ответ поступает, апачи тоже работает вроде бы , пёрышко в трее есть. Уже 3 час мучаюсь с этой проблемой |
|||
|
||||
| Simpliest |
|
|||
|
Опытный ![]() ![]() Профиль Группа: Участник Сообщений: 625 Регистрация: 1.9.2009 Репутация: 1 Всего: 3 |
Звездный совет Перышко до одного места. Зайди в сервисы и посмотри запущен ли аппач. Можешь еще чере TaskManager найти процесс httpd.exe если он есть - то копай дальше (например посмотри в конфигах на какой порт ты его повесил - 80й или другой). |
|||
|
||||
| ruslandlion |
|
|||
|
Шустрый ![]() Профиль Группа: Участник Сообщений: 115 Регистрация: 12.8.2006 Репутация: нет Всего: нет |
К сожалению у меня это не сработало.Галочку снял в скайпе но безрезультатно.
|
|||
|
||||
| ruslandlion |
|
|||
|
Шустрый ![]() Профиль Группа: Участник Сообщений: 115 Регистрация: 12.8.2006 Репутация: нет Всего: нет |
80 порт был занят программой Skype, я исправил эту ошибку, в сервисах апач запущен причём дважды? а он ### не работает
|
|||
|
||||
| skyboy |
|
|||
|
неОпытный ![]() ![]() ![]() ![]() Профиль Группа: Модератор Сообщений: 9820 Регистрация: 18.5.2006 Где: Днепропетровск Репутация: 75 Всего: 260 |
|
|||
|
||||
| Simpliest |
|
|||
|
Опытный ![]() ![]() Профиль Группа: Участник Сообщений: 625 Регистрация: 1.9.2009 Репутация: 1 Всего: 3 |
Да ну? Тогда убери скайп из автозапуска и перезагрузи машину. Должно заработать. Если не заработает - то надо читать ошибки. В MMC посмотреть events для приложения httpd.exe или Apache... Можно еще найти лог апача и посмотреть там (обычно это ...\...\Apache2\logs\error.log) |
|||
|
||||
| ruslandlion |
|
|||
|
Шустрый ![]() Профиль Группа: Участник Сообщений: 115 Регистрация: 12.8.2006 Репутация: нет Всего: нет |
Чувак, у меня и так скайп с автозапуска снят, но phpmyadmin не загружается, я на набрал команду в командной строке( сори за тофтологию) netstat -anb, по идее должно быть три процесса
а их там нету, что делать?Переустанавливать пробовал не получается. |
|||
|
||||
| Simpliest |
|
|||
|
Опытный ![]() ![]() Профиль Группа: Участник Сообщений: 625 Регистрация: 1.9.2009 Репутация: 1 Всего: 3 |
||||
|
||||
| Strilo4ka |
|
|||
|
Шустрый ![]() Профиль Группа: Участник Сообщений: 97 Регистрация: 27.2.2009 Репутация: нет Всего: нет |
может еще что то 80 порт занимает!!!??????(или апач не перегрузил был когда снял отметку а skype). Может хтттп.конф изменял. И что то каряво записано с ошыбкой... Короче просто переустанови, тю проблема.
|
|||
|
||||
| USD |
|
|||
|
Новичок Профиль Группа: Участник Сообщений: 7 Регистрация: 21.11.2011 Репутация: нет Всего: нет |
.......................
Это сообщение отредактировал(а) USD - 23.11.2011, 10:23 |
|||
|
||||
| $дмитрий |
|
|||
![]() Эксперт ![]() ![]() ![]() Профиль Группа: Завсегдатай Сообщений: 1037 Регистрация: 19.6.2004 Репутация: 17 Всего: 45 |
Жми кнопку "Пуск" в поле "Найти программы и файлы" впиши "cmd" появится окошко, далее пиши "ping localhost" и нажимай enter |
|||
|
||||
![]()
|
| Правила форума "PHP" | |
|
|
Новичкам:
Важно:
Внимание:
Если Вам понравилась атмосфера форума, заходите к нам чаще! С уважением, IZ@TOP, skyboy, SamDark, MoLeX, awers. |
| 0 Пользователей читают эту тему (0 Гостей и 0 Скрытых Пользователей) | |
| 0 Пользователей: | |
| « Предыдущая тема | PHP: Общие вопросы | Следующая тема » |
|
|
По вопросам размещения рекламы пишите на vladimir(sobaka)vingrad.ru
Отказ от ответственности Powered by Invision Power Board(R) 1.3 © 2003 IPS, Inc. |