![]() |
|
Модераторы: Се ля ви |
![]()
|
|
| Kasjan |
|
|||
|
Новичок Профиль Группа: Участник Сообщений: 7 Регистрация: 4.12.2006 Репутация: нет Всего: нет |
Установил все на одном компе: Apache, SVN и TortoiseSVN.
Создал хранилище Через браузер его отлично видно как http://localhost/svn/SVNRep1/. (и видно через "Обозреватель хранилища" в TortoiseSVN) Когда пытаюсь импортировать папку, выдает такую ошибку Error * PROPFIND request failed on '/svn/SVNRep1' PROPFIND of '/svn/SVNRep1': Could not resolve hostname `http://localhost/svn/': The requested name is valid and was found in the database, but it does not have the correct associated data being resolved Где я чего забыл? Спасибо |
|||
|
||||
| Bose |
|
|||
![]() Эксперт ![]() ![]() ![]() Профиль Группа: Участник Клуба Сообщений: 1458 Регистрация: 5.3.2005 Где: Riga, Latvia Репутация: 1 Всего: 51 |
А если обращаться к репозиторию как к папке?
Например: c:\program files\svn\svnrep1 ? |
|||
|
||||
| ShadeSt |
|
|||
![]() Опытный ![]() ![]() Профиль Группа: Участник Сообщений: 256 Регистрация: 9.8.2005 Где: Россия, г. Ставро поль Репутация: нет Всего: 7 |
в svnserve.conf настройки раскомментарены?
в passwd пользователи добавлены? вроде, если обращаешься по протоколу svn:// то там надо все прописывать, если просто через file:/// то должно прокатить без изменения настроек. -------------------- It's nice to be importand, but it's more importand to be nice © Scooter |
|||
|
||||
| Kasjan |
|
|||
|
Новичок Профиль Группа: Участник Сообщений: 7 Регистрация: 4.12.2006 Репутация: нет Всего: нет |
Bose,
Если обращаться как к папке (file://), то все нормально. ShadeSt,
А где такой файл? Я не нашел. Кстати, если обращаться не по http, а по svn:// , то другая ошибка: Error * Can't connect to host '10.74.13.112': No connection could be made because the target machine actively refused it. |
|||
|
||||
| ShadeSt |
|
|||
![]() Опытный ![]() ![]() Профиль Группа: Участник Сообщений: 256 Регистрация: 9.8.2005 Где: Россия, г. Ставро поль Репутация: нет Всего: 7 |
в каталоге репозитория лежит. Например у меня: E:\SVN_REP\conf\* Создается админом, при создании репозитория. Это сообщение отредактировал(а) ShadeSt - 26.2.2007, 08:51 -------------------- It's nice to be importand, but it's more importand to be nice © Scooter |
|||
|
||||
| ShadeSt |
|
|||
![]() Опытный ![]() ![]() Профиль Группа: Участник Сообщений: 256 Регистрация: 9.8.2005 Где: Россия, г. Ставро поль Репутация: нет Всего: 7 |
Кстати, а как ты сделал так, что бы содержимое хранилища было видно в браузере? это еще какая то надстройка что-то типа SVN::WEB или сам snv это может по умолчанию?
-------------------- It's nice to be importand, but it's more importand to be nice © Scooter |
|||
|
||||
| Bose |
|
|||
![]() Эксперт ![]() ![]() ![]() Профиль Группа: Участник Клуба Сообщений: 1458 Регистрация: 5.3.2005 Где: Riga, Latvia Репутация: 1 Всего: 51 |
Некстати. Нашёл на форуме есть ветка для обсуждения инструментария подобного Subversion. http://forum.vingrad.ru/forum-276.html
|
|||
|
||||
| Kasjan |
|
||||
|
Новичок Профиль Группа: Участник Сообщений: 7 Регистрация: 4.12.2006 Репутация: нет Всего: нет |
Продолжаю борьбу с SVN.
Решил сделать доступ через svnserve, а не через Апач. В svnserve.conf поставил anon-access = write Но теперь на запрос svn://localhost/SVNRep1 выдает такое: Error * E:\SVN\SVNRep1\conf\svnserve.conf:12: Option expected Чего ему еще надо??
Это надо апач устанавливать и подключаться по протоколу http://.
Не буду против, если модераторы переместят ветку туда. |
||||
|
|||||
| ShadeSt |
|
|||
![]() Опытный ![]() ![]() Профиль Группа: Участник Сообщений: 256 Регистрация: 9.8.2005 Где: Россия, г. Ставро поль Репутация: нет Всего: 7 |
файлик так выглядит?
-------------------- It's nice to be importand, but it's more importand to be nice © Scooter |
|||
|
||||
| Kasjan |
|
|||
|
Новичок Профиль Группа: Участник Сообщений: 7 Регистрация: 4.12.2006 Репутация: нет Всего: нет |
Оказывается ему не нравилось, что перед anon-access = write стоял пробел. |
|||
|
||||
![]()
|
| Правила форума "Системный анализ, проектирование и UML" | |
|
|
Форум "Системный анализ, проектирование и UML" предназначен для обсуждения вопросов, так или иначе связанных с этапами жизненного цикла автоматизированных (программных, информационных, автоматических) систем: • предпроектные обследования объектов автоматизации; • разработка концепции создания систем; • моделирование бизнес-процессов (в т.ч. на UML); • проектирование архитектуры систем; • управление проектами; • управление качеством; • CASE-средства; • реинжиниринг. Если Вам понравилась атмосфера форума, заходите к нам чаще! С уважением, Се ля ви. |
| 0 Пользователей читают эту тему (0 Гостей и 0 Скрытых Пользователей) | |
| 0 Пользователей: | |
| « Предыдущая тема | Системный анализ, проектирование и UML | Следующая тема » |
|
|
По вопросам размещения рекламы пишите на vladimir(sobaka)vingrad.ru
Отказ от ответственности Powered by Invision Power Board(R) 1.3 © 2003 IPS, Inc. |