Модераторы: LSD, AntonSaburov

Поиск:

Ответ в темуСоздание новой темы Создание опроса
> Websphere клиент, вызвать EJB из тругого апп-серверва  
:(
    Опции темы
chief39
Дата 17.4.2007, 19:16 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


карманная тигра
***


Профиль
Группа: Участник Клуба
Сообщений: 1631
Регистрация: 20.5.2005
Где: Киев

Репутация: 11
Всего: 77



Тих, не лупи так башкой апстену, соседи сбегутся smile


Цитата(KostenkoSergey @  17.4.2007,  16:15 Найти цитируемый пост)
В дистрибутиве с WS ND есть AppClient, после его инсталяции обнаружил следующие библиотеки: ibmext.jar, ibmorb.jar, ibmorbapi.jar, 

Клиент, гришь, въебсферовски?

И он же кастит въебсферовски контекстфэктори на орбимпл?
Цитата(KostenkoSergey @  17.4.2007,  16:15 Найти цитируемый пост)
Скорее всего - это из-за того, что клиент кастит com.ibm.websphere.naming.WsnInitialContextFactory на com.sun.corba.se.impl.orb.ORBImpl, а сервер в моём случае на сom.inprise.vbroker.orb.ORB...


А у тебя вылазят бесовские уши, так?
Попробуй поглядеть в джариках въебсферовского клиента их реализацию контекста. И попробуй явно указать этот класс при 
Цитата(KostenkoSergey @  16.4.2007,  10:49 Найти цитируемый пост)
InitialContext icontext = new InitialContext(env);
.
Типа org.ws.bla-bla.our.great.mega.Context вместо InitialContext



--------------------
Люди - это свечи. Они либо горят, либо их - в жопу!(с)

PM MAIL   Вверх
KostenkoSergey
Дата 17.4.2007, 20:14 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Опытный
**


Профиль
Группа: Участник
Сообщений: 290
Регистрация: 31.10.2005
Где: Kiev

Репутация: 3
Всего: 8



Цитата(chief39 @  17.4.2007,  19:16 Найти цитируемый пост)
А у тебя вылазят бесовские уши, так?


ну не совсем бесовские ... 

Код

2007-04-17 20:12:30,593 ERROR  - javax.naming.NamingException: Failed to initialize the ORB [Root exception is java.lang.ClassCastExcept
ion: com.inprise.vbroker.orb.ORB]
2007-04-17 20:12:30,593 ERROR  -        at com.ibm.ws.naming.util.Helpers.getOrb(Helpers.java:294)
2007-04-17 20:12:30,593 ERROR  -        at com.ibm.ws.naming.util.WsnInitCtxFactory.getInitialContextInternal(WsnInitCtxFactory.java:373
)
2007-04-17 20:12:30,593 ERROR  -        at com.ibm.ws.naming.util.WsnInitCtx.getContext(WsnInitCtx.java:112)
2007-04-17 20:12:30,593 ERROR  -        at com.ibm.ws.naming.util.WsnInitCtx.getContextIfNull(WsnInitCtx.java:422)
2007-04-17 20:12:30,593 ERROR  -        at com.ibm.ws.naming.util.WsnInitCtx.lookup(WsnInitCtx.java:143)
2007-04-17 20:12:30,593 ERROR  -        at javax.naming.InitialContext.lookup(InitialContext.java:351)


я так понял этот самый орб om.ibm.ws.naming.util.Helpers.getOrb просто не кастится на com.inprise.vbroker.orb.ORB толи из-за различий в ибмовских и сановских интерфейсах, толи исчё какогото... вообчем полная ...
PM ICQ   Вверх
KostenkoSergey
Дата 18.4.2007, 12:35 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Опытный
**


Профиль
Группа: Участник
Сообщений: 290
Регистрация: 31.10.2005
Где: Kiev

Репутация: 3
Всего: 8



Наконец-то удалось победить lockup:  smile 
Оказываеццо, через CORBA object URL можно обращаться к WS, минуя ибмовскую реализацию jndi.
Пробовал через borlandовскую, прокатило :

Код

      Hashtable env = new Hashtable();
      //env.put(Context.INITIAL_CONTEXT_FACTORY, "com.ibm.websphere.naming.WsnInitialContextFactory");
      env.put(Context.INITIAL_CONTEXT_FACTORY, "com.inprise.j2ee.jndi.CtxFactory");
      env.put (Context.PROVIDER_URL, "corbaname:iiop:localhost:9100/NameServiceServerRoot");
      InitialContext icontext = new InitialContext(env);
      Object remoteObj =  icontext.lookup("ejb/ua/io/SQLEntryHome");


Через сановскую, кстати тоже: com.sun.jndi.cosnaming.CNCtxFactory

источник: http://publib.boulder.ibm.com/infocenter/w...mple_prop2.html

Правда до конца схема всё же ещё не работает  smile  smile  smile 

Найденая ссылка портаблится(portableRemoteObject.narrow), объект создаётся, но при попытке вызвать remote-метод получаю:
Код

java.rmi.MarshalException: CORBA MARSHAL 1229125786[]; nested exception is: 
    org.omg.CORBA.MARSHAL:   vmcid: 0x4942f000  minor code: 2202  completed: No


С чем это может быть связано ?

Это сообщение отредактировал(а) KostenkoSergey - 18.4.2007, 12:52
PM ICQ   Вверх
chief39
Дата 18.4.2007, 13:09 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


карманная тигра
***


Профиль
Группа: Участник Клуба
Сообщений: 1631
Регистрация: 20.5.2005
Где: Киев

Репутация: 11
Всего: 77



Цитата(chief39 @  17.4.2007,  19:16 Найти цитируемый пост)
Попробуй поглядеть в джариках въебсферовского клиента их реализацию контекста. И попробуй явно указать этот класс при 
Цитата(KostenkoSergey @  16.4.2007,  10:49 Найти цитируемый пост)
InitialContext icontext = new InitialContext(env);
.
Типа org.ws.bla-bla.our.great.mega.Context вместо InitialContext

Пробовал?

У тебя и на сервере и на клиенте должна быть WS реализация, выходит что на сервере ты просто гребёшь WS а на клиенте, по дефалту, создаёшь реализацию БЕСовского контекста.
Попробуй явно создать WSский инитиал контекст через нью и передать его переменой типа InitialContext



--------------------
Люди - это свечи. Они либо горят, либо их - в жопу!(с)

PM MAIL   Вверх
KostenkoSergey
Дата 18.4.2007, 14:46 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Опытный
**


Профиль
Группа: Участник
Сообщений: 290
Регистрация: 31.10.2005
Где: Kiev

Репутация: 3
Всего: 8



Цитата(chief39 @  18.4.2007,  13:09 Найти цитируемый пост)
Пробовал?


Это ничего не меняет, когда я  делаю : env.put(Context.INITIAL_CONTEXT_FACTORY,"com.ibm.websphere.naming.WsnInitialContextFactory"), я и так получаю IBM'овский контекст, соответственно с его jndi- и ORB-реализацией, последние под Sun JRE глючат.

Используя другой контекст, соответственно получаю другую реализацию, к-я отрабатывает.
Цитата(chief39 @  18.4.2007,  13:09 Найти цитируемый пост)
У тебя и на сервере и на клиенте должна быть WS реализация
 - тут, наверное, немного не так. Не то, что бы "должна быть одинаковой", а достаточно что бы реализации "понимали" друг друга.
Используя CORBA URL это достигается.

Что примечательно: Вызов без параметров или с пераметрами = null до WS доходит и отрабатывается, а с не нуловыми значениями приводит к возникновению приведённой выше ошибки. Это наталкивает на мысль, что проблема переместилась на уровень "упаковки параметров"



PM ICQ   Вверх
w1nd
Дата 19.4.2007, 11:32 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Вертилятор
***


Профиль
Группа: Завсегдатай
Сообщений: 1077
Регистрация: 22.3.2006
Где: Москва

Репутация: 7
Всего: 54



Цитата(KostenkoSergey @  17.4.2007,  10:38 Найти цитируемый пост)
w1nd, а вы точно не плугабили жре от сан ?

Что значит "плугабили"? JRE нетронутый.


Цитата(KostenkoSergey @  17.4.2007,  10:38 Найти цитируемый пост)
И ещё возвращаясь к твоему совету "Также установить системные свойства:" - это где надо было сделать ?

Можно при старте приложения, до создания каких-либо контекстов получения каких-либо удалённых объектов. Ы помощью System.setProperty(). Только у меня websphere 6.1.0

Добавлено @ 11:36

Цитата(KostenkoSergey @  18.4.2007,  14:46 Найти цитируемый пост)
Используя CORBA URL это достигается

Урл такого вида: corbaloc:iiop:<имя_сервера>:<порт> (с WsnInitialContextFactory)

Это сообщение отредактировал(а) w1nd - 19.4.2007, 11:37


--------------------
user posted imageuser posted image
PM MAIL ICQ   Вверх
Ответ в темуСоздание новой темы Создание опроса
Правила форума "Java"
LSD   AntonSaburov
powerOn   tux
  • Прежде, чем задать вопрос, прочтите это!
  • Книги по Java собираются здесь.
  • Документация и ресурсы по Java находятся здесь.
  • Используйте теги [code=java][/code] для подсветки кода. Используйтe чекбокс "транслит", если у Вас нет русских шрифтов.
  • Помечайте свой вопрос как решённый, если на него получен ответ. Ссылка "Пометить как решённый" находится над первым постом.
  • Действия модераторов можно обсудить здесь.
  • FAQ раздела лежит здесь.

Если Вам помогли, и атмосфера форума Вам понравилась, то заходите к нам чаще! С уважением, LSD, AntonSaburov, powerOn, tux.

 
0 Пользователей читают эту тему (0 Гостей и 0 Скрытых Пользователей)
0 Пользователей:
« Предыдущая тема | Java EE (J2EE) и Spring | Следующая тема »


 




[ Время генерации скрипта: 0.0526 ]   [ Использовано запросов: 21 ]   [ GZIP включён ]


Реклама на сайте     Информационное спонсорство

 
По вопросам размещения рекламы пишите на vladimir(sobaka)vingrad.ru
Отказ от ответственности     Powered by Invision Power Board(R) 1.3 © 2003  IPS, Inc.