![]() |
|
Модераторы: powerfox, ZeeLax |
![]()
|
|
| condor |
|
|||
![]() Новичок Профиль Группа: Участник Сообщений: 14 Регистрация: 23.9.2006 Репутация: нет Всего: нет |
Возникли проблемы с Самбой, в /var/log.nmbd пишут:
find_response_record: response packet id ..... received with no matching record $ smbstatus Failed to open byte range locking database ERROR: Failed to initialise locking database Can't initialise locking module - exiting Вот smb.conf : [global] netbios name=HYDRA workgroup=SIMPLE interfaces=rl0 security=share domain master=no guest account=nobody preferred master=false local master=no locking=no hosts allow=192.168. browseable=yes [homes] read only=no [test] path=.. writable=yes read only=no public=yes guest ok=yes locking=no что можно сделать? Это сообщение отредактировал(а) condor - 14.11.2006, 10:47 |
|||
|
||||
| blast99 |
|
|||
![]() сисадмин ![]() Профиль Группа: Участник Сообщений: 134 Регистрация: 3.5.2005 Где: Россия, г. Ставро поль Репутация: нет Всего: 3 |
Попробовать перепроверить права пользователей. Попробуй стартовать самбу от рута и статус от рута попробуй.
--------------------
Зачастую, наши возможности ограничены лишь нашими желаниями. И ничто так не ограничивает желания, как заниженная оценка своих возможностей. |
|||
|
||||
| condor |
|
|||
![]() Новичок Профиль Группа: Участник Сообщений: 14 Регистрация: 23.9.2006 Репутация: нет Всего: нет |
Возникла новая ошибка:
Failed to open nmb socket on interface 0.0.0.0 for 137. Error was Address already in use ... ERROR: Failed when creating subnet lists. Exiting. Не понятно, где берется interface 0.0.0.0? smb.conf ----------- [global] workgroup=SIMPLE netbios name=BSD interfaces=rl0 192.168.0.10 security=SHARE preferred master=yes encrypt passwords=yes |
|||
|
||||
| ZeeLax |
|
|||
![]() Эксперт ![]() ![]() ![]() ![]() Профиль Группа: Модератор Сообщений: 4388 Регистрация: 20.8.2006 Где: Алма-Ата Репутация: 26 Всего: 88 |
Под 0.0.0.0 подразумеваются все доступные интерфейсы.
Видимо, запущена вторая копия самбы. -------------------- Utility is when you have one telephone, luxury is when you have two, opulence is when you have three — and paradise is when you have none. — Doug Larson |
|||
|
||||
| condor |
|
|||
![]() Новичок Профиль Группа: Участник Сообщений: 14 Регистрация: 23.9.2006 Репутация: нет Всего: нет |
ZeeLax, вот вот, я пришел к такому мнению. Как проверить запущена ли копия самбы, как это предотвратить?
|
|||
|
||||
| Сумасшедший |
|
||||||||
|
Чилавек-Каропка ![]() ![]() ![]() Профиль Группа: Завсегдатай Сообщений: 1503 Регистрация: 15.8.2004 Где: Москва Репутация: 8 Всего: 107 |
condor,
Должно показывать один процесс smbd и один nmbd Предотвратить: найти файлы, которые запускают дополнительные процессы самбы и отредактировать их. Теперь смотри: Какая версия самбы у тебя? Если до 3.0.23с, то там был такой баг:
В версии 3.0.23с его пофиксили. По поводу
Попробуй в конфиг дописать подобную этому весчь:
-------------------- Однажды ты спросишь, а я отвечу: "Время ожидания специалиста - 10 минут". Ты бросишь трубку, так и не узнав, что Ваш звонок очень важен для нас! |
||||||||
|
|||||||||
| condor |
|
|||
![]() Новичок Профиль Группа: Участник Сообщений: 14 Регистрация: 23.9.2006 Репутация: нет Всего: нет |
После команды smbclient -U% -L localhost добавляется интерфейс на 0.0.0.0, т.е на все допустимые в системе. Хотя в smb.conf указано: interfaces = rl0.
Интерфейс rl0 прописан: ifconfig_rl0="inet 192.168.0.10 netmask 255.255.255.0", с Windows машины пингуется. Версия Самбы: 2.0.4b Если прописывать в smc.conf, в interfaces сразу ip(192.168.0.10), то все нормально, добавляется интерфейс на нужный ip(+маска), но Windows, 192.168.0.10 всеравно не видит. Если добавить в smb.conf: hosts allow=192.168.0.8 #(windows машина), то получаются такие ошибки: samba session request to LOCALHOST failed samba session request to *SMBSERVER failed Как с этим можно разобраться? |
|||
|
||||
| Сумасшедший |
|
|||
|
Чилавек-Каропка ![]() ![]() ![]() Профиль Группа: Завсегдатай Сообщений: 1503 Регистрация: 15.8.2004 Где: Москва Репутация: 8 Всего: 107 |
А если добавить в hosts allow локальные ip?
Что противит переходу на smb3x? -------------------- Однажды ты спросишь, а я отвечу: "Время ожидания специалиста - 10 минут". Ты бросишь трубку, так и не узнав, что Ваш звонок очень важен для нас! |
|||
|
||||
| condor |
|
||||
![]() Новичок Профиль Группа: Участник Сообщений: 14 Регистрация: 23.9.2006 Репутация: нет Всего: нет |
В hosts allow получается добавить только 127.0.0.1, при 192.168.0.8 (windows) и 192.168.0.10(freebsd) ошибка: samba session request to LOCALHOST failed samba session request to *SMBSERVER failed
Особой разницы на данный момент не вижу, кроме привиденной ощибки, но к данной проблеме, на мой взляд, она не относится. Кроме того, эта версия(2.0.4b) рабочая и уже стояла у меня, но по ряду причин, мне пришлось переустанавливать дистрибутив, в том числе и самбу. Отмечу только, что до переустановки она работала. Какие будут еще предположения? |
||||
|
|||||
| condor |
|
|||
![]() Новичок Профиль Группа: Участник Сообщений: 14 Регистрация: 23.9.2006 Репутация: нет Всего: нет |
Записав такие параметры в smb.conf:
[global] workgroup = SIMPLE interfaces = 192.168.0.10/24 127.0.0.1 bind interfaces only = no security = share # hosts allow = 192.168.0. # комментируем, т.к что-то не работает netbiosname = CLIENT socket options=TCP_NODELAY guest account = nobody preferred master = yes browseable = yes [test] comment = Only test path=... public=yes ... , после старта smbclient -U% -L localhost получаем: Samba client: Added interface ip=192.168.0.10 bcast=192.168.0.255 nmask=255.255.255.0 Added interface ip=127.0.0.1 bcast=127.255.255.255 nmask=255.0.0.0 Domain=[SIMPLE] OS=[UNIX] Server=[Samba 2.0.4b] Sharename Type Comment -------------- ----- ------------ homes Disk home test Disk Only test IPC$ IPC IPC ... Server Comment -------- ------------ CLIENT Samba 2.0.4b Workgroup Master -------------- --------- SIMPLE CLIENT Workgroup на windows(XP) машине - SIMPLE, name - CLIENT. Т.е все вродебы проходит удачно, но FreeBSD всеже не видно. |
|||
|
||||
![]()
|
| Правила форума "Linux/UNIX: Oбщие вопросы" | |
|
|
В тему здесь вопросы общие - не привязанные к определенному ПО или дистрибутиву BSD/Linux/UNIX.
За интересные статьи, находки, решения, программы и просто реальную помощь будут ставиться + в репу). В данный момент этот раздел модерируют nerezus, nickless, powerfox, pythonwin, Imple и ZeeLax. Если вы хотите помочь нам, пишите в ПМ и мы обсудим. Спасибо. И use UNIX or die; С уважением, nerezus, nickless, powerfox, pythonwin, Imple, ZeeLax. |
| 0 Пользователей читают эту тему (0 Гостей и 0 Скрытых Пользователей) | |
| 0 Пользователей: | |
| « Предыдущая тема | *NIX системы: Общие вопросы | Следующая тема » |
|
|
По вопросам размещения рекламы пишите на vladimir(sobaka)vingrad.ru
Отказ от ответственности Powered by Invision Power Board(R) 1.3 © 2003 IPS, Inc. |