Модераторы: Akina
  

Поиск:

Ответ в темуСоздание новой темы Создание опроса
> Проблема с запуском сервера, помогите с запуском 
:(
    Опции темы
Sergio
Дата 23.2.2007, 23:37 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Опытный
**


Профиль
Группа: Участник
Сообщений: 843
Регистрация: 28.7.2006
Где: Solar System-> Earth

Репутация: нет
Всего: 1



Здраствуйте. Установил SQL 2000 Develop Запускаю сервис менеджер. Вибыраю мой комп и SQL сервер. Нажимаю старт и выбивает ошибку: "Служба не запущена из за ошибки входа в систему" Что это может быть?
У меня Виндовс ХР
Спасибо.

Это сообщение отредактировал(а) Sergio - 23.2.2007, 23:54
PM MAIL ICQ   Вверх
zluka
Дата 24.2.2007, 10:37 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Опытный
**


Профиль
Группа: Участник
Сообщений: 278
Регистрация: 27.7.2006

Репутация: нет
Всего: 2



Цитата(Sergio @  23.2.2007,  23:37 Найти цитируемый пост)
"Служба не запущена из за ошибки входа в систему" Что это может быть?

Конечно я в этом не спец, но возможно ты не указал host, user и password. Посмотри в опциях..



--------------------
user posted image
PM MAIL   Вверх
Sergio
Дата 24.2.2007, 14:52 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Опытный
**


Профиль
Группа: Участник
Сообщений: 843
Регистрация: 28.7.2006
Где: Solar System-> Earth

Репутация: нет
Всего: 1



Цитата

возможно ты не указал host, user и password


В MS SQL сервис менеджере не указывается. Задаётся только имя машины и служба.
Народ может кто-то встречался с этой проблемой? Помогите плз.

Это сообщение отредактировал(а) Sergio - 24.2.2007, 16:04
PM MAIL ICQ   Вверх
Альберт
Дата 24.2.2007, 21:26 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Новичок



Профиль
Группа: Участник
Сообщений: 7
Регистрация: 28.12.2005

Репутация: нет
Всего: нет



а ты вообще экземпляр сервера создал? не помню, создается ли он автоматически при установке
попробуй в enterprise manager'е сначала создать
PM MAIL   Вверх
Данкинг
Дата 24.2.2007, 21:29 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Yersinia pestis
****


Профиль
Группа: Завсегдатай
Сообщений: 8302
Регистрация: 7.11.2006
Где: მოსკოვი

Репутация: нет
Всего: 130



Цитата(Альберт @ 24.2.2007,  21:26)
а ты вообще экземпляр сервера создал? не помню, создается ли он автоматически при установке
попробуй в enterprise manager'е сначала создать

При установке предлагается установить сервер или же только клиент.


--------------------
There's nothing left but silent epitaphs.
PM MAIL WWW   Вверх
Sergio
Дата 25.2.2007, 00:10 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Опытный
**


Профиль
Группа: Участник
Сообщений: 843
Регистрация: 28.7.2006
Где: Solar System-> Earth

Репутация: нет
Всего: 1



Альберт, он автоматически создаётся. Вот скриншот:
http://slil.ru/23986602

Добавлено @ 00:24 
Вот как я делал:
1. Установил SQL 2000 Develper edition (клиент и сервер)
2. Запускаю сервис менеджер. В поле сервер выбираю имя моего компьютера. В поле сервис SQL Server. И тут выпадает окно: "Служба не запущена из за ошибки входа в систему" а потом ошибка An error 1069  "Служба не запущена из за ошибки входа в систему". 

Наверное я не правильно что-то сделал smile Помогите пожалуйста.

Это сообщение отредактировал(а) Sergio - 25.2.2007, 00:48
PM MAIL ICQ   Вверх
SergKO
Дата 26.2.2007, 08:18 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Бывалый
*


Профиль
Группа: Участник
Сообщений: 231
Регистрация: 14.3.2005

Репутация: 17
Всего: 20



Посмотрите в сервисах свойства MSSQLSERVER вкладка "Вход в систему".
PM MAIL   Вверх
SergeBS
Дата 26.2.2007, 09:13 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Эксперт
***


Профиль
Группа: Завсегдатай
Сообщений: 1111
Регистрация: 10.6.2005
Где: Владимир

Репутация: 5
Всего: 22



Sergio, 
Установка с правами админа?
Local user account?
Короче вот:
Грабли №1. Сервер просто не установлен.
Обычно при этом плодятся сообщения типа «Не вижу сервер», «Не могу подключиться к базе», «Сервер не запускается».
Причины (сортировка - из собственного опыта):
1.    Нет ни сетевой карты и подключения к сети, ни ее эмулятора от Микрософт.
2.    Попытка установить сервер не на своей машине (по сети через «Удаленный помощник» терминалку и т.п.).
3.    Недостаточно прав на установку (надо быть администратором).
4.    Операционная система и сервер – слишком разных поколений. Т.е. если например пытаться установить MS SQL 7.0 на ОС MS SQL 2003, то операционка Вас пошлет подальше с криком «Мне такого старья не надо». Это еще ничего – хорошо заметно по крайней мере. А вот если наоборот, то инсталляшка скромно предупредит: «сервер поставить нельзя, будет установлена только клиентская часть» и предложит двигаться дальше. Ну а поскольку предупреждение будет на английском и без афиширования типа «Error», «Warning» и т.п., торопыги, особенно не шибко понимающие буржуйские буквы, кнопкой «Continue» летят со свистом дальше, а потом судорожно ищут сервер, которого просто нет.
5.    Всякие разные досадные мелочи, типа слишком длинный путь к папкам временных файлов, русские буквы и пробелы в именах папок и устанавливающего.
6.    Наличие работающих IIS, Terminal Service, PWS, Disk Keeper и т.п., просто работающая по ODBC программа. Этот список сервисов и т.п неполон, а правило простое – перед установкой сервера все, что можно - остановить. Что нельзя – тоже попробовать остановить, например процессор J.
Вообще, идеальный вариант – поставить операционку, сервис-паки, сетевые прибамбасы, а сразу после этого – сервер. А уже после этого – антивирусник и т.п. По минимуму.

4 пункт явно не твой - на ХР desktop 2000 ставится влет.
PM MAIL   Вверх
Sergio
Дата 3.3.2007, 15:20 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Опытный
**


Профиль
Группа: Участник
Сообщений: 843
Регистрация: 28.7.2006
Где: Solar System-> Earth

Репутация: нет
Всего: 1



 smile Решил проблему. Дело в том что если оставить имя сервера по дефолту то его нельзя найти. Во всяком случае у меня smile Поэтому я назвал имя сервера и всё работает. Все спасибо.
PM MAIL ICQ   Вверх
  
Ответ в темуСоздание новой темы Создание опроса
Правила форума "MS SQL"
Akina

Akina

Запрещается!

Публиковать ссылки и обсуждать взлом чего бы то ни было.

  • Действия модераторов можно обсудить здесь
  • С просьбами о написании курсовой, реферата и т.п. обращаться сюда
  • Вопросы составления неспецифических запросов рассматриваются здесь
  • Используйте теги [code=sql][/code] для подсветки кода. Используйтe чекбокс "транслит" (возле кнопок кодов) если у Вас нет русских шрифтов.

Если Вам понравилась атмосфера форума, заходите к нам чаще! С уважением, Zloxa, Akina.

 
0 Пользователей читают эту тему (0 Гостей и 0 Скрытых Пользователей)
0 Пользователей:
« Предыдущая тема | MS SQL Server | Следующая тема »


 




[ Время генерации скрипта: 0.0497 ]   [ Использовано запросов: 22 ]   [ GZIP включён ]


Реклама на сайте     Информационное спонсорство

 
По вопросам размещения рекламы пишите на vladimir(sobaka)vingrad.ru
Отказ от ответственности     Powered by Invision Power Board(R) 1.3 © 2003  IPS, Inc.