Модераторы: korob2001, ginnie
  

Поиск:

Ответ в темуСоздание новой темы Создание опроса
> Парам. name в Content-Type 
:(
    Опции темы
Адреналина
  Дата 25.7.2003, 15:37 (ссылка)    |    (голосов: 0) Загрузка ... Загрузка ... Быстрая цитата Цитата


Unregistered











Почему когда я отсылаю файл броузеру msie он не хочет давать файлу имя, кот. я прописываю в параметре name:
print "Content-type: application/x-fucking-type; name=\"report.doc\"\n\n";
,а предлагает следующее имя: имя_скрипта.cgi
  Вверх
Cepera
Дата 25.8.2003, 19:49 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


PHPexp
****


Профиль
Группа: Экс. модератор
Сообщений: 2146
Регистрация: 25.3.2002
Где: Russia, Samara

Репутация: нет
Всего: 7



Цитата
"Content-type: application/x-fucking-type; name=\"report.doc\"\n\n";

а объясните мне , что это за тип такой?


--------------------
I know it is heavy for reading, but I know you will read it anyway...
PM MAIL WWW ICQ   Вверх
Nobody
Дата 25.8.2003, 19:54 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Опытный
**


Профиль
Группа: Участник
Сообщений: 838
Регистрация: 25.8.2003
Где: Россия, Москва

Репутация: нет
Всего: 16



Да нету такого типа. Я вообще не понимаю, откуда он это взял.


--------------------
Алгоритм помещения вопросов на форуме
Выражаем спасибо вот ТАК
Use the Source, Luke!
PM MAIL WWW ICQ   Вверх
Cepera
Дата 25.8.2003, 20:06 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


PHPexp
****


Профиль
Группа: Экс. модератор
Сообщений: 2146
Регистрация: 25.3.2002
Где: Russia, Samara

Репутация: нет
Всего: 7



уважаемый Nobody, ваш предыдущий пост я удалил, будьте, пожалуйста, более корректны
я думаю, что люди, если задают вопрос, то хотят услышать на него ответ, а не пространные рассуждения, что де есть бог и де есть сатана


--------------------
I know it is heavy for reading, but I know you will read it anyway...
PM MAIL WWW ICQ   Вверх
Nobody
Дата 25.8.2003, 20:12 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Опытный
**


Профиль
Группа: Участник
Сообщений: 838
Регистрация: 25.8.2003
Где: Россия, Москва

Репутация: нет
Всего: 16



Мдя... Ну хорошо, то же самое можно сказать и более приземленными словами. Експлорер предлагает сохранять файлы под теми именами, какой УРЛ у них и есть. И ничто это не изменит.


--------------------
Алгоритм помещения вопросов на форуме
Выражаем спасибо вот ТАК
Use the Source, Luke!
PM MAIL WWW ICQ   Вверх
Cepera
Дата 25.8.2003, 20:16 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


PHPexp
****


Профиль
Группа: Экс. модератор
Сообщений: 2146
Регистрация: 25.3.2002
Где: Russia, Samara

Репутация: нет
Всего: 7



хех... а как насчет генерируемых файлов?smile.gif
в данном случае это именно так и выходит...
я, кстати, очень часто так делаю в своих скриптах, при бекапе бд имена генерятся из имени бд + текущей даты


--------------------
I know it is heavy for reading, but I know you will read it anyway...
PM MAIL WWW ICQ   Вверх
MuToGeN
Дата 26.8.2003, 09:55 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Лесник
****


Профиль
Группа: Модератор
Сообщений: 4379
Регистрация: 15.8.2002
Где: Москва

Репутация: нет
Всего: 32



Content-disposition: inline; filename="my_file.txt"
Вроде как-то так
Цитата
Експлорер предлагает сохранять файлы под теми именами, какой УРЛ у них и есть. И ничто это не изменит.
Nobody, позвольте с вами не согласиться...

Это сообщение отредактировал(а) MuToGeN - 5.9.2003, 09:15


--------------------
Three pings for the token rings,
Five pings for the UNIX machines,
Hundred pings for the broken links,
One special ping to check them all
Through Simple Network Management Protocol!
PM MAIL ICQ   Вверх
NightGoblin
Дата 31.8.2003, 06:17 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Эксперт
***


Профиль
Группа: Участник Клуба
Сообщений: 1021
Регистрация: 24.11.2002
Где: 127.0.0.1

Репутация: нет
Всего: 11



А что за Content-description? в HTTP 1.1 такого нет... confused.gif


--------------------
Kernel panic: /dev/null overflow!
GCS/IT/MU/O d-@ s: a- C++$>++++$ ULSB(+++) P+++ L+++>++++ !E W++(-) N o? K w-- O? M>+ V? PS+ PE Y+ PGP+>+++ t- 5 X+ R- !tv b+ DI+ D+ G e++ h--- r++ y?
B4F1 54B6 8738 26CD 5125 0581 B923 9273 FE59 1981
PM MAIL WWW ICQ   Вверх
MuToGeN
Дата 1.9.2003, 09:06 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Лесник
****


Профиль
Группа: Модератор
Сообщений: 4379
Регистрация: 15.8.2002
Где: Москва

Репутация: нет
Всего: 32



Ошибся... Content-disposition, вроде. Короче, где-то тут (или в PHP) оно уже обсуждалось....

Это сообщение отредактировал(а) MuToGeN - 5.9.2003, 09:15


--------------------
Three pings for the token rings,
Five pings for the UNIX machines,
Hundred pings for the broken links,
One special ping to check them all
Through Simple Network Management Protocol!
PM MAIL ICQ   Вверх
NightGoblin
Дата 4.9.2003, 23:02 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Эксперт
***


Профиль
Группа: Участник Клуба
Сообщений: 1021
Регистрация: 24.11.2002
Где: 127.0.0.1

Репутация: нет
Всего: 11



Выдержка из RFC 2068 "Hypertext Transfer Protocol -- HTTP/1.1"

Цитата

7.1 Entity Header Fields
...
          entity-header  = Allow                    ; Section 14.7             
                        | Content-Base            ; Section 14.11           
                        | Content-Encoding        ; Section 14.12           
                        | Content-Language        ; Section 14.13           
                        | Content-Length          ; Section 14.14           
                        | Content-Location        ; Section 14.15           
                        | Content-MD5              ; Section 14.16           
                        | Content-Range            ; Section 14.17           
                        | Content-Type            ; Section 14.18           
                        | ETag                    ; Section 14.20           
                        | Expires                  ; Section 14.21           
                        | Last-Modified            ; Section 14.29           
                        | extension-header                                   


То есть, в самом HTTP/1.1 ничего подобного нет... Однако, далее следует вот что:

Цитата

          extension-header = message-header                                   
                                                                               
  The extension-header mechanism allows additional entity-header fields       
  to be defined without changing the protocol, but these fields cannot       
  be assumed to be recognizable by the recipient. Unrecognized header         
  fields SHOULD be ignored by the recipient and forwarded by proxies.         


т. е., заголовок типа Content-desposition (или как его уже там) - уже не часть протоола HTTP, а фантазия некоторой фирмы, не имеющей отношения к W3C, а потому таких вещей, ИМХО, следует избегать. Ну конечно, если вы не разрабатываете замечательные сайты "IE Only".


--------------------
Kernel panic: /dev/null overflow!
GCS/IT/MU/O d-@ s: a- C++$>++++$ ULSB(+++) P+++ L+++>++++ !E W++(-) N o? K w-- O? M>+ V? PS+ PE Y+ PGP+>+++ t- 5 X+ R- !tv b+ DI+ D+ G e++ h--- r++ y?
B4F1 54B6 8738 26CD 5125 0581 B923 9273 FE59 1981
PM MAIL WWW ICQ   Вверх
MuToGeN
Дата 5.9.2003, 09:12 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Лесник
****


Профиль
Группа: Модератор
Сообщений: 4379
Регистрация: 15.8.2002
Где: Москва

Репутация: нет
Всего: 32



Цитата
Выдержка из RFC 2068 "Hypertext Transfer Protocol -- HTTP/1.1"
Выдержка из RFC 2616 "Hypertext Transfer Protocol -- HTTP/1.1":
Цитата
...Obsoletes: 2068...
Цитата
15.5 Content-Disposition Issues

   RFC 1806 [35], from which the often implemented Content-Disposition
   (see section 19.5.1) header in HTTP is derived, has a number of very
   serious security considerations. Content-Disposition is not part of
   the HTTP standard, but since it is widely implemented, we are
   documenting its use and risks for implementors. See RFC 2183 [49]
   (which updates RFC 1806) for details.
Цитата
19.5.1 Content-Disposition

   The Content-Disposition response-header field has been proposed as a
   means for the origin server to suggest a default filename if the user
   requests that the content is saved to a file. This usage is derived
   from the definition of Content-Disposition in RFC 1806 [35].

        content-disposition = "Content-Disposition" ":"
                              disposition-type *( ";" disposition-parm )
        disposition-type = "attachment" | disp-extension-token
        disposition-parm = filename-parm | disp-extension-parm
        filename-parm = "filename" "=" quoted-string
        disp-extension-token = token
        disp-extension-parm = token "=" ( token | quoted-string )

   An example is

        Content-Disposition: attachment; filename="fname.ext"

   The receiving user agent SHOULD NOT respect any directory path
   information present in the filename-parm parameter, which is the only
   parameter believed to apply to HTTP implementations at this time. The
   filename SHOULD be treated as a terminal component only.

   If this header is used in a response with the application/octet-
   stream content-type, the implied suggestion is that the user agent
   should not display the response, but directly enter a `save response
   as...' dialog.

   See section 15.5 for Content-Disposition security issues.



--------------------
Three pings for the token rings,
Five pings for the UNIX machines,
Hundred pings for the broken links,
One special ping to check them all
Through Simple Network Management Protocol!
PM MAIL ICQ   Вверх
MuToGeN
Дата 5.9.2003, 09:16 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Лесник
****


Профиль
Группа: Модератор
Сообщений: 4379
Регистрация: 15.8.2002
Где: Москва

Репутация: нет
Всего: 32



Кстати, тогда тоже ошибся... Не Content-desposition, а Content-disposition


--------------------
Three pings for the token rings,
Five pings for the UNIX machines,
Hundred pings for the broken links,
One special ping to check them all
Through Simple Network Management Protocol!
PM MAIL ICQ   Вверх
GoodBoy
Дата 9.9.2003, 12:48 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Главный джедай
****


Профиль
Группа: Модератор
Сообщений: 3886
Регистрация: 8.1.2003
Где: КМВ

Репутация: 4
Всего: 83



Попробуйте вот так:

print "Content-Type: type/subtype\n";
print "Content-Disposition: attachment; filename=\"$file_name\"\n\n";

my $buff = '';
open(F, "<$path/$file");
while (read (F, $buff, 1024)) { print STDOUT $buff; }
close F;

у меня работает...


--------------------
Чем дальше в лес, тем толще партизаны...

Цитата(igorold @  1.5.2016,  17:40 Найти цитируемый пост)
Индейцы не обратили внимания на поток беженцев из Европы… Теперь они живут в резервациях. 
PM MAIL   Вверх
NightGoblin
Дата 10.9.2003, 04:58 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Эксперт
***


Профиль
Группа: Участник Клуба
Сообщений: 1021
Регистрация: 24.11.2002
Где: 127.0.0.1

Репутация: нет
Всего: 11



Цитата(MuToGeN @ 5.9.2003, 06:12)
Выдержка из RFC 2616 "Hypertext Transfer Protocol -- HTTP/1.1"

hmmm.gif кстати, спасибо за инфу - пригодится wink.gif


--------------------
Kernel panic: /dev/null overflow!
GCS/IT/MU/O d-@ s: a- C++$>++++$ ULSB(+++) P+++ L+++>++++ !E W++(-) N o? K w-- O? M>+ V? PS+ PE Y+ PGP+>+++ t- 5 X+ R- !tv b+ DI+ D+ G e++ h--- r++ y?
B4F1 54B6 8738 26CD 5125 0581 B923 9273 FE59 1981
PM MAIL WWW ICQ   Вверх
  
Ответ в темуСоздание новой темы Создание опроса
Правила форума "Perl: CGI программирование"
korob2001
sharq
  • В этом разделе обсуждаются вопросы относящиеся только к CGI программированию
  • Если ваш вопрос не относится к системному или CGI программированию, задавайте его в общем разделе
  • Если ваш вопрос относится к системному программированию, задавайте его здесь
  • Интерпретатор Perl можно скачать здесь ActiveState, O'REILLY, The source for Perl
  • Справочное руководство "Установка perl-модулей", качать здесь


Если Вам понравилась атмосфера форума, заходите к нам чаще! С уважением, korob2001, sharq.

 
0 Пользователей читают эту тему (0 Гостей и 0 Скрытых Пользователей)
0 Пользователей:
« Предыдущая тема | Perl: разработка для Web | Следующая тема »


 




[ Время генерации скрипта: 0.1052 ]   [ Использовано запросов: 22 ]   [ GZIP включён ]


Реклама на сайте     Информационное спонсорство

 
По вопросам размещения рекламы пишите на vladimir(sobaka)vingrad.ru
Отказ от ответственности     Powered by Invision Power Board(R) 1.3 © 2003  IPS, Inc.