Модераторы: LSD, AntonSaburov
  

Поиск:

Ответ в темуСоздание новой темы Создание опроса
> Sun Java System Application Server и NetBeans, не запускается веб-приложение.  
:(
    Опции темы
evropa
Дата 4.9.2007, 13:44 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Новичок



Профиль
Группа: Участник
Сообщений: 15
Регистрация: 3.8.2007

Репутация: нет
Всего: нет



Здравствуйте. 
Вопрос от новичка. 
В NetBeans 5.5 создаю File > New Project > Web > Web Application 

Мне нужно выполнить приложение под Sun Java System Application Server. 
SJS Application Server установился (как я понимаю) вместе с установкой всего пакета явы. В папку C:\Sun\AppServer.
Я делаю предварительно: 
1. Choose Tools > Server Manager from the main window. 
2. Click Add Server. Select the server type and give a name to the instance. Then click Next. 
3. Specify the server information, the location of the local instance of the application server, and the domain to which you want to deploy.


( кстати, http://localhost:8080/ пишет "Your server is up and running!")

и я пытаюсь запустить свое только что созданное веб-приложение HelloWeb (естественно  smile ), нажав F6. Ничего в коде я не меняю. Вроде как должна запуститься пустая страничка? да? А у меня не компилируется, пишет ошибку C:\Java projects\HelloWeb\nbproject\build-impl.xml:440: Deployment error:   в строке <nbdeploy debugmode="false" clientUrlPart="${client.urlPart}" forceRedeploy="${forceRedeploy}"/>

Что не так? Надо как-то настроить-запустить сервер предварительно или что делать?

Всем заранее большое спасибо.



PM MAIL   Вверх
Zamuta
Дата 4.9.2007, 13:55 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Опытный
**


Профиль
Группа: Участник
Сообщений: 389
Регистрация: 18.1.2006

Репутация: 1
Всего: 6



evropa, 
Цитата

 А у меня не компилируется, пишет ошибку C:\Java projects\HelloWeb\nbproject\build-impl.xml:440: Deployment error:   в строке <nbdeploy debugmode="false" clientUrlPart="${client.urlPart}" forceRedeploy="${forceRedeploy}"/>


Компилируешь при запущенном сервере или остановленном?


--------------------
Thank you opensource.
PM MAIL ICQ   Вверх
evropa
Дата 4.9.2007, 14:06 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Новичок



Профиль
Группа: Участник
Сообщений: 15
Регистрация: 3.8.2007

Репутация: нет
Всего: нет



Набираешь http://localhost:8080/ пишет "Your server is up and running!" , как-то надо специально запускать сервер? 

Компилирую, как есть (очевидно, не зная, что нужно запустить и  как запустить)
PM MAIL   Вверх
evropa
Дата 4.9.2007, 14:47 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Новичок



Профиль
Группа: Участник
Сообщений: 15
Регистрация: 3.8.2007

Репутация: нет
Всего: нет



Как правильно запустить сервер?
PM MAIL   Вверх
Zamuta
Дата 4.9.2007, 15:20 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Опытный
**


Профиль
Группа: Участник
Сообщений: 389
Регистрация: 18.1.2006

Репутация: 1
Всего: 6



Не знаю как у Sun App Server, думаю, что также, но под томкатом скомпилировать и деплоить приложение при запущенном сервере не получится и судя по твоей ошибке "Deployment error:" , т.е. ошибка разворачивания приложения на сервере происходит по этой причине.

Попробуй остановить сервер, сделать build main project, а потом жми F6....




--------------------
Thank you opensource.
PM MAIL ICQ   Вверх
evropa
Дата 4.9.2007, 15:35 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Новичок



Профиль
Группа: Участник
Сообщений: 15
Регистрация: 3.8.2007

Репутация: нет
Всего: нет



Нормально сделал build

Но потом...The module has not been deployed.
И та же самая ошибка  smile 
PM MAIL   Вверх
powerOn
Дата 4.9.2007, 17:14 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


software saboteur
****


Профиль
Группа: Участник
Сообщений: 4367
Регистрация: 7.10.2005

Репутация: 28
Всего: 159



evropa, попробуй (ради интереса) создать новый чистый web-проект и развернуть его на сервере.

P.S.: Кстати, глянь в лог сервера, нет ли там чего неординарного. 

Цитата(Zamuta @  4.9.2007,  16:20 Найти цитируемый пост)
Не знаю как у Sun App Server, думаю, что также, но под томкатом скомпилировать и деплоить приложение при запущенном сервере не получится и судя по твоей ошибке "Deployment error:"

про разворачивание под Tomcat отдельная песня: дело в том, что деплой происходит не war файла, а непосредственно проектных папок. Т.е. на уровне процессов и NetBeans и Tomcat используют одни папки... а когда делается редиплой, то NetBeans пытается часть папок удалить, на что вылетает ошибка ОС -  мол, директорию удалить не могу, она другим процессом используется...
Кстати, при таком способе развертывания, нет необходимости делать редиплой, если изменения внесены в веб-часть (html, jsp и прочие страницы), достаточно просто сохранить изменения и обновить страницу в браузере, что бы увидеть результат.


--------------------
user posted image нет времени думать - нужно писать КОД!

PM MAIL   Вверх
evropa
Дата 5.9.2007, 08:46 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Новичок



Профиль
Группа: Участник
Сообщений: 15
Регистрация: 3.8.2007

Репутация: нет
Всего: нет



Цитата(powerOn @ 4.9.2007,  17:14)
evropa, попробуй (ради интереса) создать новый чистый web-проект и развернуть его на сервере.


так я так и делаю...  (ты ж видишь, у меня проект то называется ХеллоВорлд smile )

PM MAIL   Вверх
powerOn
Дата 5.9.2007, 09:26 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


software saboteur
****


Профиль
Группа: Участник
Сообщений: 4367
Регистрация: 7.10.2005

Репутация: 28
Всего: 159



ну а в лог сервера что нибудь пишется? 


--------------------
user posted image нет времени думать - нужно писать КОД!

PM MAIL   Вверх
evropa
Дата 5.9.2007, 09:44 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Новичок



Профиль
Группа: Участник
Сообщений: 15
Регистрация: 3.8.2007

Репутация: нет
Всего: нет



Я прошу прощения за свою глупость в данном случае, но я не знаю как посмотреть лог сервера...... smile 

Мне кажется, что я что-то пропускаю в процессе разворачивания проекта. Точно всё так же как в TоmCat, F6 и всё? 

PM MAIL   Вверх
powerOn
Дата 5.9.2007, 10:09 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


software saboteur
****


Профиль
Группа: Участник
Сообщений: 4367
Регистрация: 7.10.2005

Репутация: 28
Всего: 159



Цитата(evropa @  5.9.2007,  10:44 Найти цитируемый пост)
я не знаю как посмотреть лог сервера...... 

в окне Runtime, в контекстном меню на SJSAS выбери View Server Log.

Цитата(evropa @  5.9.2007,  10:44 Найти цитируемый пост)
Точно всё так же как в TоmCat, F6 и всё? 

В принципе, да. Но можешь еще Clean and Build Project делать. Это не помещает.



--------------------
user posted image нет времени думать - нужно писать КОД!

PM MAIL   Вверх
batigoal
Дата 5.9.2007, 12:07 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Нелетучий Мыш
****


Профиль
Группа: Участник Клуба
Сообщений: 6423
Регистрация: 28.12.2004
Где: Санктъ-Петербургъ

Репутация: 11
Всего: 151



Можешь сделать war-файл и попробовать задеполоить его через серверный веб-интерфес, либо через командную строку.


--------------------
"Чтобы правильно задать вопрос, нужно знать большую часть ответа" (Р. Шекли)
ЖоржЖЖ
PM WWW   Вверх
Gugle
Дата 7.9.2007, 10:57 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Шустрый
*


Профиль
Группа: Участник
Сообщений: 117
Регистрация: 9.12.2005

Репутация: нет
Всего: нет



Проверь откуда netbeans берет файлы для запуска сервера. 
Если сервер запускать из самого netbeans-->run, то netbeans создает временную папку для его запуска и должен класть скомпилиные файлы в нее, а НЕ в папку куда был установлен сам сервер (C:\Sun\AppServer по умолчанию).
Посмотри  внимательно логи запуска сервера из netbeans, он там должен говорить что то типа:
Using CATALINA_BASE:   C:\Documents and Settings...
Using CATALINA_HOME:   C:\Sun...
Using CATALINA_TMPDIR: C:\Documents and Settings...

Соответственно надо проверить эти пути, действительно ли он кладет туда откомпилированные файлы проекта.

PM MAIL   Вверх
  
Ответ в темуСоздание новой темы Создание опроса
Правила форума "Java"
LSD   AntonSaburov
powerOn   tux
  • Прежде, чем задать вопрос, прочтите это!
  • Книги по Java собираются здесь.
  • Документация и ресурсы по Java находятся здесь.
  • Используйте теги [code=java][/code] для подсветки кода. Используйтe чекбокс "транслит", если у Вас нет русских шрифтов.
  • Помечайте свой вопрос как решённый, если на него получен ответ. Ссылка "Пометить как решённый" находится над первым постом.
  • Действия модераторов можно обсудить здесь.
  • FAQ раздела лежит здесь.

Если Вам помогли, и атмосфера форума Вам понравилась, то заходите к нам чаще! С уважением, LSD, AntonSaburov, powerOn, tux.

 
0 Пользователей читают эту тему (0 Гостей и 0 Скрытых Пользователей)
0 Пользователей:
« Предыдущая тема | Java tools & IDE's | Следующая тема »


 




[ Время генерации скрипта: 0.0561 ]   [ Использовано запросов: 22 ]   [ GZIP включён ]


Реклама на сайте     Информационное спонсорство

 
По вопросам размещения рекламы пишите на vladimir(sobaka)vingrad.ru
Отказ от ответственности     Powered by Invision Power Board(R) 1.3 © 2003  IPS, Inc.