![]() |
|
Модераторы: skyboy |
![]()
|
|
| sir_nuf_nuf |
|
||||
![]() Опытный ![]() ![]() Профиль Группа: Участник Сообщений: 920 Регистрация: 6.1.2008 Репутация: 8 Всего: 31 |
Привет.
Такая проблема: 1) есть пользователь zif 2) у него есть права на все в рамках схемы:
3) создан триггер для исполнения от лица zif
Однако при insert в таблицу (через perl DBI) получаем: DBD::mysql::st execute failed: TRIGGER command denied to user 'zif'@'192.168.2.6' Гугл молчит.. никто не сталкивался ? |
||||
|
|||||
| sir_nuf_nuf |
|
|||
![]() Опытный ![]() ![]() Профиль Группа: Участник Сообщений: 920 Регистрация: 6.1.2008 Репутация: 8 Всего: 31 |
проблему исправили, заменой definer'а на 'root'@'localhost' .
Но причина проблемы так и не выяснена. На аналогичной базе работает с definer = zif |
|||
|
||||
![]()
|
| 0 Пользователей читают эту тему (0 Гостей и 0 Скрытых Пользователей) | |
| 0 Пользователей: | |
| « Предыдущая тема | MySQL | Следующая тема » |
|
|
По вопросам размещения рекламы пишите на vladimir(sobaka)vingrad.ru
Отказ от ответственности Powered by Invision Power Board(R) 1.3 © 2003 IPS, Inc. |