Поиск:

Ответ в темуСоздание новой темы Создание опроса
> Взгромаздил апач, а он........! could not bind to address 0.0.0.0:80 
:(
    Опции темы
-=Ustas=-
  Дата 4.8.2005, 10:30 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Ustix IT Group
****


Профиль
Группа: Участник Клуба
Сообщений: 2222
Регистрация: 21.1.2005
Где: Краснодар

Репутация: нет
Всего: 69



Мое почтение!
Скажите, что это может быть! При установке, перед самым финишем появляется командное окошко, в котором появляется эта ругань :
Цитата
(OS 10048)+?v??? ?????°????  ???? ????????????? ?????? ?????? (????????/???????
?????/????).  : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs

Затем, после финиша, пробую пускать его, но выскакивает точно такая же лажа! Что делать подскажите! У меня ХРюша СП1, Апач 2.0.54.
smile


--------------------
В искаженном мире все догмы одинаково произвольны, включая догму о произвольности догм.
-----
PM WWW ICQ Skype   Вверх
Akina
Дата 4.8.2005, 11:29 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Советчик
****


Профиль
Группа: Модератор
Сообщений: 20581
Регистрация: 8.4.2004
Где: Зеленоград

Репутация: нет
Всего: 454



Установленные приложения вообще-то принято настраивать. Применительно к данному случаю - параметр Listen глобальной секции в файле httpd.conf


--------------------
 О(б)суждение моих действий - в соответствующей теме, пожалуйста. Или в РМ. И высшая инстанция - Администрация форума.

PM MAIL WWW ICQ Jabber   Вверх
Styler
Дата 4.8.2005, 13:15 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Шустрый
*


Профиль
Группа: Участник
Сообщений: 61
Регистрация: 24.7.2005

Репутация: нет
Всего: 1



Akina у него ошибка появляется еще на этапе установки.

-=Ustas=- у меня было такое когдя я ставил Апач на компьютере на котором не было нр локальной сети ни модема. Выкрутился из проблемы простой установкой контроллера удаленнного доступа.
PM MAIL   Вверх
Akina
Дата 4.8.2005, 13:22 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Советчик
****


Профиль
Группа: Модератор
Сообщений: 20581
Регистрация: 8.4.2004
Где: Зеленоград

Репутация: нет
Всего: 454



Цитата(Styler @ 4.8.2005, 14:15)
у него ошибка появляется еще на этапе установки

Неверно. Последний этап установки - первичное конфигурирование. Именно оно сбоит. Приведенная тобой причина - одна из возможных. Решение тоже нормальное, хотя правильнее (именно в этом конкретном случае) ставить Microsoft Loopback adapter.


--------------------
 О(б)суждение моих действий - в соответствующей теме, пожалуйста. Или в РМ. И высшая инстанция - Администрация форума.

PM MAIL WWW ICQ Jabber   Вверх
-=Ustas=-
Дата 4.8.2005, 13:31 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Ustix IT Group
****


Профиль
Группа: Участник Клуба
Сообщений: 2222
Регистрация: 21.1.2005
Где: Краснодар

Репутация: нет
Всего: 69



Моя тачка находится в сравнительно небольшой локальной сети и на выделенке через прокси, если это имеет какое-то значение. Ставил себе "денвера", пашет только localhost, другие домены делал - они не хотят работать, хотя я для них создавал, так как и надо - виртуальные хосты и привязывал их в файле hosts. Что за муть такая?!


--------------------
В искаженном мире все догмы одинаково произвольны, включая догму о произвольности догм.
-----
PM WWW ICQ Skype   Вверх
Mal Hack
Дата 4.8.2005, 14:08 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Мудрый...
****


Профиль
Группа: Участник Клуба
Сообщений: 9926
Регистрация: 15.2.2004

Репутация: 15
Всего: 261



Ты конфиг трогал?
По дефолту апач работает с 127.0.0.1, а у тебя нулевый UP, который даже в теории никуда тебя не приведетю
Цитата(Akina @ 4.8.2005, 12:29)
параметр Listen глобальной секции в файле httpd.conf


PM ICQ   Вверх
-=Ustas=-
Дата 4.8.2005, 15:04 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Ustix IT Group
****


Профиль
Группа: Участник Клуба
Сообщений: 2222
Регистрация: 21.1.2005
Где: Краснодар

Репутация: нет
Всего: 69



Нет, еще не успел потрогать! smile Я же говорю, эта ошибка выскакивает еще в процессе установки. А в конфиге у меня localhost стоит.


--------------------
В искаженном мире все догмы одинаково произвольны, включая догму о произвольности догм.
-----
PM WWW ICQ Skype   Вверх
Styler
Дата 5.8.2005, 12:43 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Шустрый
*


Профиль
Группа: Участник
Сообщений: 61
Регистрация: 24.7.2005

Репутация: нет
Всего: 1



-=Ustas=- - в случае с установкой Денвера тебе нужно было всего лишь создать нужные папки в директории /home и вовсе необязательно было трогать сам файл hosts - Денвер вносит в него коррективы автоматически.
PM MAIL   Вверх
-=Ustas=-
Дата 8.8.2005, 08:08 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Ustix IT Group
****


Профиль
Группа: Участник Клуба
Сообщений: 2222
Регистрация: 21.1.2005
Где: Краснодар

Репутация: нет
Всего: 69



Цитата(Styler @ 5.8.2005, 12:43)
в случае с установкой Денвера тебе нужно было всего лишь создать нужные папки в директории /home и вовсе необязательно было трогать сам файл hosts - Денвер вносит в него коррективы автоматически.

При денвере я никакие файлы не трогал. Я же говорю, у меня выделенка, и когда я добавляю новый хост, то он лезет в нэт. Так что мен с апачем делать? Или это у меня операционка глючит?


--------------------
В искаженном мире все догмы одинаково произвольны, включая догму о произвольности догм.
-----
PM WWW ICQ Skype   Вверх
-=Ustas=-
Дата 9.8.2005, 08:28 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Ustix IT Group
****


Профиль
Группа: Участник Клуба
Сообщений: 2222
Регистрация: 21.1.2005
Где: Краснодар

Репутация: нет
Всего: 69



Что, я так понимаю, советы кончились...?!


--------------------
В искаженном мире все догмы одинаково произвольны, включая догму о произвольности догм.
-----
PM WWW ICQ Skype   Вверх
Akina
Дата 9.8.2005, 08:42 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Советчик
****


Профиль
Группа: Модератор
Сообщений: 20581
Регистрация: 8.4.2004
Где: Зеленоград

Репутация: нет
Всего: 454



Запусти тест httpd.conf - у тебя в нем ошибки. Исправь.


--------------------
 О(б)суждение моих действий - в соответствующей теме, пожалуйста. Или в РМ. И высшая инстанция - Администрация форума.

PM MAIL WWW ICQ Jabber   Вверх
Moses
Дата 3.6.2006, 11:41 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Новичок



Профиль
Группа: Участник
Сообщений: 16
Регистрация: 3.6.2006

Репутация: нет
Всего: нет



У меня возникли точно такие же проблемы. В командном окне то-же сообщение. Машина не подключена ни к локальной сети, ни к и-нету. 
В httpd.conf ошибок, на сколько я понимаю, нет. Если я умышленно делаю ошибку ближе к концу файла, то при повторной инсталляции (исправлении) Apache  в командном окне выдает сообщение Error в строке н-р 145. Если же исправить ошибку - выдает сообщение, приведенное автором данной темы. Кроме того, при инсталляции не создает log файлы. В папке logs только 1 файл - instal. 
Просьба советовать попроще. Я чайник в этом деле. По градации чайников - чайник 1-го порядка.
 
PM MAIL   Вверх
Сумасшедший
Дата 4.6.2006, 18:49 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Чилавек-Каропка
***


Профиль
Группа: Завсегдатай
Сообщений: 1503
Регистрация: 15.8.2004
Где: Москва

Репутация: 13
Всего: 107



Так апач сообщает, что порт 80 на ip 0.0.0.0 используется другим процессом. Посмотри какие процессы слушают этот порт на таком ip. 


--------------------
Однажды ты спросишь, а я отвечу: "Время ожидания специалиста - 10 минут". Ты бросишь трубку, так и не узнав, что Ваш звонок очень важен для нас!
PM MAIL WWW Jabber   Вверх
Moses
Дата 5.6.2006, 12:49 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Новичок



Профиль
Группа: Участник
Сообщений: 16
Регистрация: 3.6.2006

Репутация: нет
Всего: нет



Разобрался. Просто Apache, установленный на работе, на компьютере, подключенном к локальной сети, ведет себя совсем по-другому. В моем случае - понадобилась просто перезагрузка. Спасибо. 
PM MAIL   Вверх
Cheba1
Дата 28.6.2006, 19:01 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Новичок



Профиль
Группа: Участник
Сообщений: 1
Регистрация: 28.6.2006

Репутация: нет
Всего: нет



У меня проблема продолжается, после перезагрузки тоже все работате, но вот через 2-4 часа сново стопорится 80 порт...  Я в конфиге его убираю, - все работает... Но как тока я сново его прописываю - ничего не происходит.... И в логах как всегда ничего не записано...  Как я понял - надо искать прогу, которая грузит порт 80 - но такого я не нашол, если ставить другие версии апача, то без результатно, тоже самое происходит...  Мой вопрос в другом - как найти какая прога занимает порт 80....???? smile  
PM MAIL   Вверх
Ответ в темуСоздание новой темы Создание опроса
0 Пользователей читают эту тему (0 Гостей и 0 Скрытых Пользователей)
0 Пользователей:
« Предыдущая тема | Администрирование Web серверов и Web служб | Следующая тема »


 




[ Время генерации скрипта: 0.0698 ]   [ Использовано запросов: 21 ]   [ GZIP включён ]


Реклама на сайте     Информационное спонсорство

 
По вопросам размещения рекламы пишите на vladimir(sobaka)vingrad.ru
Отказ от ответственности     Powered by Invision Power Board(R) 1.3 © 2003  IPS, Inc.