Модераторы: LSD
  

Поиск:

Ответ в темуСоздание новой темы Создание опроса
> Oracle 8.1.7i под Windows XP SP1 (error:ORA-12560) 
:(
    Опции темы
avsemenov
Дата 2.12.2005, 13:37 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Новичок



Профиль
Группа: Участник
Сообщений: 2
Регистрация: 2.12.2005

Репутация: нет
Всего: нет



Добрый день!
Обращаюсь к вам с проблемкой...
Имееться дома компутер с установленной Windows XP SP1
решил я домой работу взять....
Установил Oracle 8.1.7i прописал "листенер" на 127.0.0.1 на порт 1251 стартанул его говорит ОК!
Сделал ему "ТНСпинг" говорит ок!
СОздал сервис oradim ..... в службах появился...
И вот кульминация запускаю svrmgrl , а он мне ЕГГОГ:ORA-12560
А sqlplus system@SID/manager говорит ERROR:ORA-12500: TNS:listener failed to start a dedicated server process
Может кто сталкивалси с такой проблемой так подскажите пожалуйста!
Заранее благодарен!

Это сообщение отредактировал(а) avsemenov - 3.12.2005, 11:44
PM MAIL   Вверх
Marriage
Дата 3.12.2005, 13:36 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Опытный
**


Профиль
Группа: Участник
Сообщений: 842
Регистрация: 4.5.2004
Где: Таганрог

Репутация: нет
Всего: 2



TNS-12500 TNS:listener failed to start a dedicated server process
Cause: The process of starting up a dedicated server process failed. The
executable could not be found or the environment may be set up incorrectly.
Action: Turn on tracing at the ADMIN level and re-execute the operation.
Verify that the Oracle Server executable is present and has execute permissions
enabled. Ensure that the Oracle environment is specified correctly in
LISTENER.ORA. The Oracle Protocol Adapter that is being called may not be
installed on the local hard drive. Check that the correct Protocol Adapter are
successfully linked. If the error persists, contact Oracle Customer Support.


--------------------
Praemonitus, praemunitus
PM MAIL ICQ   Вверх
LSD
Дата 4.12.2005, 23:51 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Leprechaun Software Developer
****


Профиль
Группа: Модератор
Сообщений: 15718
Регистрация: 24.3.2004
Где: Dublin

Репутация: 18
Всего: 538



Согласен, стоит включить трассировку для listener-а и посмотреть, что он напишет в лог.
Включать ее так: запускаешь Net8 Assistant там идешь в Local\Listeners\LISTENER\Genral parameters\Logging & Tracing и устанавиливаешь Tracing Enable в уровень Administrator.


--------------------
Disclaimer: this post contains explicit depictions of personal opinion. So, if it sounds sarcastic, don't take it seriously. If it sounds dangerous, do not try this at home or at all. And if it offends you, just don't read it.
PM MAIL WWW   Вверх
avsemenov
Дата 7.12.2005, 00:34 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Новичок



Профиль
Группа: Участник
Сообщений: 2
Регистрация: 2.12.2005

Репутация: нет
Всего: нет



Включил трасировку ...и ровным счётом нечего....
в логи при старте пишет стартовал...на каком порту ...
даю ТНСПИНГ в ло и трасер честно пишет пинг...
а при запуске СВРМГРЛ или SQLPLUS НИ В ЛОГ НИ В ТРАСЕР НЕЧЕГО ВОООБЩЕ НЕ ПИШЕТЬСЯ!!!!!


PM MAIL   Вверх
LSD
Дата 9.12.2005, 00:05 (ссылка) | (нет голосов) Загрузка ... Загрузка ... Быстрая цитата Цитата


Leprechaun Software Developer
****


Профиль
Группа: Модератор
Сообщений: 15718
Регистрация: 24.3.2004
Где: Dublin

Репутация: 18
Всего: 538



Поиск выдал что чаще всего это случается, или из-за нехватки памяти на сервере (маловероятно, если у тебя более 128Мб оперативки), или из-за ошибок при создании сервиса (просто попробуй его пересоздать), или ошибок конфигурирования LISTENER.ORA и TNSNAMES.ORA (попробуй указать не 127.0.0.1 а имя компьютера).
Вот что рекомендует в таком случае Oracle
Код
This solution covers the following topics: 

    A. TNS-12500 on Microsoft Windows NT 
    B. Intermittent TNS-12500 Errors on Microsoft Windows NT 
 
A.  TNS-12500 on Microsoft Windows NT 
----------------------------------------- 

    1. Please make sure that the userid that installed/started  
       oracle, and started the listener is administrator. 

    2. Go to the Control Panel by clicking on [START]-->  
       [Settings]---> [Control Panel] and then double click  
       on "Services".   A window is displayed which  
       looks similar to this: 

+---------------------------------------------------------+     
|                                                         |  
| Service                   Status                Startup |     
+---------------------------------------------------------+    
|OracleNamesService80                             Manual  |     
|OracleServiceORCL          Started               Auto    | 
|OracleStartORCL            Started               Auto    |     
|OracleTNSListener          Started               Auto    | 
|OracleTNSListener80                              Manual  |     
|OracleWebAssistant                               Manual  |    
|pcANYWHERE Service         Started               Manual  |     
+---------------------------------------------------------+  

    Look at "OracleService" and "OracleStart".  These two  
    services are followed by your SID name (in this case ORCL).   
    These services should be started.  If they are not click  
    on the [START] button on the right side of the dialog box. 

    3. Verify the SID names shown with "OracleService" and  
       "OracleStart" in the Control Panel:Services are the same  
       SID names in the client's TNSNAMES.ORA and the server's  
       LISTENER.ORA files. 

    4. Make sure that the listener is logged on as the System  
       Account. You can check this by going into Control         
       Panel/Services highlight the OracleTNSListener then  
       click on Startup. The listener should be logged on as  
       the System Account. Once you make this change make  
       sure that you stop and start the listener. 

    5. Make sure that the tnsnames.ora file doesn't specify the  
       ORACLE_HOME parameter in the connect_data section.  If it  
       does, remove it.  

    6. You may want to simply try restarting your instance. 


B.  Intermittent TNS-12500 Errors on Microsoft Windows NT 
--------------------------------------------------------- 

    1. Increase the amount of memory available to the system  
       either by removing unnecessary processes or increasing  
       the amount of physical memory. 

    2. Increasing the amount of swap space will also  
       temporarily help relieve the symptoms. 

    3. Disable OTRACE.  OTRACE is a tracing feature that can  
       cause many problems. OTRACE is enabled by default.   
       To disable OTRACE: 

       a. Stop the Oracle database. 
       b. Go to the orant/otrace/admin directory. 
       c. Delete all files with a �.dat� extension. 
       d. Restart the Oracle database. 

    4. The TNS-12500 can be a result of the 'processes'  
       parameter in the init<sid>.ora file being too low.



--------------------
Disclaimer: this post contains explicit depictions of personal opinion. So, if it sounds sarcastic, don't take it seriously. If it sounds dangerous, do not try this at home or at all. And if it offends you, just don't read it.
PM MAIL WWW   Вверх
  
Ответ в темуСоздание новой темы Создание опроса
Правила форума "Oracle"
Zloxa
LSD

Данный раздел предназначен для обсуждения проблем с Oracle Database, другие продукты Oracle здесь не обсуждаются. Просьба при создании темы, придерживаться следующих правил:

  • при создании темы давайте ей осмысленное название, описывающее суть проблемы
  • указывайте используемую версию базы, способ соединения и язык программирования
  • при ошибках обязательно приводите код ошибки и сообщение сервера
  • приводите код в котором возникла ошибка, по возможности дайте тестовый пример демонстрирующий ошибку
  • при вставке кода используйте соответсвующие теги: [code=sql] [/code] для подсветки SQL и PL/SQL кода, [code=java] [/code] - для Java, и т.д.

  • документация по Oracle: 9i, 10g, 11g
  • книги по Oracle можно поискать здесь
  • действия модераторов можно обсудить здесь

Если Вам понравилась атмосфера форума, заходите к нам чаще! С уважением, Zloxa, LSD.

 
0 Пользователей читают эту тему (0 Гостей и 0 Скрытых Пользователей)
0 Пользователей:
« Предыдущая тема | Oracle | Следующая тема »


 




[ Время генерации скрипта: 0.0477 ]   [ Использовано запросов: 22 ]   [ GZIP включён ]


Реклама на сайте     Информационное спонсорство

 
По вопросам размещения рекламы пишите на vladimir(sobaka)vingrad.ru
Отказ от ответственности     Powered by Invision Power Board(R) 1.3 © 2003  IPS, Inc.